summaryrefslogtreecommitdiffstats
path: root/meta-openstack/recipes-devtools/ruby/pry_git.bb
diff options
context:
space:
mode:
authorAmy Fong <amy.fong@windriver.com>2014-05-20 15:24:32 -0400
committerBruce Ashfield <bruce.ashfield@windriver.com>2014-05-24 00:27:14 -0400
commit76a0fd8f546fc0a5407e154331f5ba7be331cefe (patch)
tree2335d0b08c8c4df93eb87f42f0a807b895421657 /meta-openstack/recipes-devtools/ruby/pry_git.bb
parent614b4a5196ab7cecef46616805a77ab09702e569 (diff)
downloadmeta-cloud-services-76a0fd8f546fc0a5407e154331f5ba7be331cefe.tar.gz
Ruby/chef solo: Add recipes-devtools/ruby/pry_git.bb
Pry is a powerful alternative to the standard IRB shell for Ruby. It is written from scratch to provide a number of advanced features. Signed-off-by: Mark Asselstine <mark.asselstine@windriver.com> Signed-off-by: Amy Fong <amy.fong@windriver.com>
Diffstat (limited to 'meta-openstack/recipes-devtools/ruby/pry_git.bb')
-rw-r--r--meta-openstack/recipes-devtools/ruby/pry_git.bb35
1 files changed, 35 insertions, 0 deletions
diff --git a/meta-openstack/recipes-devtools/ruby/pry_git.bb b/meta-openstack/recipes-devtools/ruby/pry_git.bb
new file mode 100644
index 0000000..91e3c43
--- /dev/null
+++ b/meta-openstack/recipes-devtools/ruby/pry_git.bb
@@ -0,0 +1,35 @@
1#
2# Copyright (C) 2014 Wind River Systems, Inc.
3#
4SUMMARY = "Pry is an alternative to the standard IRB shell for Ruby."
5DESCRIPTION = "Pry is a powerful alternative to the standard IRB shell \
6for Ruby. It is written from scratch to provide a number of advanced \
7features."
8
9LICENSE = "MIT"
10LIC_FILES_CHKSUM = "file://LICENSE;md5=7d1a6fbb73f604e1e716380490938bd4"
11
12PR = "r0"
13
14BPV = "0.9.12.6"
15PV = "${BPV}"
16SRCREV = "047788c4225b25bb0462e06715616964e4f0da15"
17
18S = "${WORKDIR}/git"
19
20SRC_URI = " \
21 git://github.com/pry/pry.git \
22 file://rdoc-fixup-opt.banner-heredoc.patch \
23 "
24
25inherit ruby
26
27RUBY_COMPILE_FLAGS = ""
28
29RDEPENDS += " \
30 coderay \
31 method-source \
32 slop \
33 "
34
35BBCLASSEXTEND = "native"