summaryrefslogtreecommitdiffstats
path: root/meta-openstack/recipes-devtools/ruby/http-parser.rb_0.6.1.bb
diff options
context:
space:
mode:
authorHitendra Prajapati <hprajapati@mvista.com>2024-01-12 11:20:43 +0530
committerBruce Ashfield <bruce.ashfield@gmail.com>2024-01-15 21:50:19 +0000
commitd02fe61c35a7c5dcec5f4e7e6b9f89eae0da8440 (patch)
treef9699a78c39b74519c15adf8dfe59b96cae3be68 /meta-openstack/recipes-devtools/ruby/http-parser.rb_0.6.1.bb
parent28fcb27fbbab03a412f2126da3bec79acda6d9b0 (diff)
downloadmeta-cloud-services-d02fe61c35a7c5dcec5f4e7e6b9f89eae0da8440.tar.gz
Remove tag values from SRC_URI to build recipe
To build the fluentd recipe, facing the Bitbake Fetcher Error: FetchError("Recipe uses a floating tag/branch 'v1.9.2' for repo 'github.com/fluent/fluentd.git' without a fixed SRCREV yet doesn't call bb.fetch2.get_srcrev() (use SRCPV in PV for OE).", None) To fix this issue, Remove tag values from SRC_URI for recipe and its dependent recipe file. Upgrade "cool.io", "http-parser.rb" and "strptime" recipe to resolve the runtime dependency issue. Signed-off-by: Hitendra Prajapati <hprajapati@mvista.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
Diffstat (limited to 'meta-openstack/recipes-devtools/ruby/http-parser.rb_0.6.1.bb')
-rw-r--r--meta-openstack/recipes-devtools/ruby/http-parser.rb_0.6.1.bb26
1 files changed, 26 insertions, 0 deletions
diff --git a/meta-openstack/recipes-devtools/ruby/http-parser.rb_0.6.1.bb b/meta-openstack/recipes-devtools/ruby/http-parser.rb_0.6.1.bb
new file mode 100644
index 0000000..5452c12
--- /dev/null
+++ b/meta-openstack/recipes-devtools/ruby/http-parser.rb_0.6.1.bb
@@ -0,0 +1,26 @@
1SUMMARY = "simple callback-based HTTP request/response parser"
2HOMEPAGE = "https://rubygems.org/gems/http_parser.rb"
3
4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://LICENSE-MIT;md5=157efc3766c6d07d3d857ebbab43351a"
6
7SRCREV = "c8dae7c6c2c78a5016d082a7fbda7e362292c14a"
8
9SRC_URI = "gitsm://github.com/tmm1/http_parser.rb.git;protocol=https;branch=master"
10
11S = "${WORKDIR}/git"
12
13# Bitbake doesn't allow the underscore in file name, hence the dash
14SRCNAME = "http_parser.rb"
15
16DEPENDS = "git"
17
18inherit ruby
19
20# Download the submodules
21do_configure:prepend() {
22 cd ${WORKDIR}/git
23 git submodule update --init --recursive
24}
25
26FILES:${PN} += "${libdir}/*"