summaryrefslogtreecommitdiffstats
path: root/meta-openstack/recipes-devtools/python/python-xstatic-magic-search_0.2.5.1.bb
diff options
context:
space:
mode:
authorMark Asselstine <mark.asselstine@windriver.com>2015-08-05 16:29:52 -0400
committerBruce Ashfield <bruce.ashfield@windriver.com>2015-08-06 09:35:50 -0400
commit7f56afd14ccacb8ea52e7ca0822c86cdba5bea0f (patch)
treec3b7cd30b62841e6a4994ac1140a2f5514977b99 /meta-openstack/recipes-devtools/python/python-xstatic-magic-search_0.2.5.1.bb
parent086c96d2f51766638d7c9a1466f3454d0bfa66fc (diff)
downloadmeta-cloud-services-7f56afd14ccacb8ea52e7ca0822c86cdba5bea0f.tar.gz
horizon: add missing dependencies to address startup errors
Horizon requires python-xstatic-angular-lrdragndrop and xstatic-magic-search otherwise errors will prevent the dashboard from being accessed. The depencies are spelled out clearly in the openstack-dashboard-error.log, as per the following error: ImportError: Could not import settings 'openstack_dashboard.settings' (Is it on sys.path? Is there an import error in the settings file?): No module named angular_lrdragndrop Even with these added dependencies there are other issues that prevent the dashboard from being accessed but at least with these dependencies satisfied we can move on to fixing the remaining runtime issues. Signed-off-by: Mark Asselstine <mark.asselstine@windriver.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
Diffstat (limited to 'meta-openstack/recipes-devtools/python/python-xstatic-magic-search_0.2.5.1.bb')
-rw-r--r--meta-openstack/recipes-devtools/python/python-xstatic-magic-search_0.2.5.1.bb21
1 files changed, 21 insertions, 0 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-xstatic-magic-search_0.2.5.1.bb b/meta-openstack/recipes-devtools/python/python-xstatic-magic-search_0.2.5.1.bb
new file mode 100644
index 0000000..23fb832
--- /dev/null
+++ b/meta-openstack/recipes-devtools/python/python-xstatic-magic-search_0.2.5.1.bb
@@ -0,0 +1,21 @@
1DESCRIPTION = "An AngularJS directive that provides a UI for both faceted filtering and as-you-type filtering"
2HOMEPAGE = "https://pypi.python.org/pypi/XStatic-Magic-Search"
3SECTION = "devel/python"
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://PKG-INFO;md5=e3d8469611ec04e52d71f2e293d54e9c"
6
7SRCNAME = "XStatic-Magic-Search"
8SRC_URI = "http://pypi.python.org/packages/source/X/${SRCNAME}/${SRCNAME}-${PV}.tar.gz"
9
10SRC_URI[md5sum] = "cfb8a82129fffbe1f5c6339240cb6139"
11SRC_URI[sha256sum] = "9b2f35a5792f4e763e6dc319036e3676f3e18f46153096f3ab5e507177ec007e"
12
13S = "${WORKDIR}/${SRCNAME}-${PV}"
14
15inherit setuptools
16
17DEPENDS += " \
18 "
19
20RDEPENDS_${PN} += " \
21 "