diff options
author | Mark Asselstine <mark.asselstine@windriver.com> | 2015-08-05 16:29:52 -0400 |
---|---|---|
committer | Bruce Ashfield <bruce.ashfield@windriver.com> | 2015-08-06 09:35:50 -0400 |
commit | 7f56afd14ccacb8ea52e7ca0822c86cdba5bea0f (patch) | |
tree | c3b7cd30b62841e6a4994ac1140a2f5514977b99 /meta-openstack | |
parent | 086c96d2f51766638d7c9a1466f3454d0bfa66fc (diff) | |
download | meta-cloud-services-7f56afd14ccacb8ea52e7ca0822c86cdba5bea0f.tar.gz |
horizon: add missing dependencies to address startup errors
Horizon requires python-xstatic-angular-lrdragndrop and
xstatic-magic-search otherwise errors will prevent the dashboard from
being accessed. The depencies are spelled out clearly in the
openstack-dashboard-error.log, as per the following error:
ImportError: Could not import settings 'openstack_dashboard.settings'
(Is it on sys.path? Is there an import error in the settings file?):
No module named angular_lrdragndrop
Even with these added dependencies there are other issues that prevent
the dashboard from being accessed but at least with these dependencies
satisfied we can move on to fixing the remaining runtime issues.
Signed-off-by: Mark Asselstine <mark.asselstine@windriver.com>
Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
Diffstat (limited to 'meta-openstack')
3 files changed, 46 insertions, 1 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-horizon_git.bb b/meta-openstack/recipes-devtools/python/python-horizon_git.bb index 9dd764f..f5c6c03 100644 --- a/meta-openstack/recipes-devtools/python/python-horizon_git.bb +++ b/meta-openstack/recipes-devtools/python/python-horizon_git.bb | |||
@@ -40,6 +40,8 @@ RDEPENDS_${PN} += " python-django \ | |||
40 | python-xstatic-angular-mock \ | 40 | python-xstatic-angular-mock \ |
41 | python-xstatic-angular-bootstrap \ | 41 | python-xstatic-angular-bootstrap \ |
42 | python-xstatic-angular-irdragndrop \ | 42 | python-xstatic-angular-irdragndrop \ |
43 | python-xstatic-angular-lrdragndrop \ | ||
44 | python-xstatic-magic-search \ | ||
43 | python-xstatic-d3 \ | 45 | python-xstatic-d3 \ |
44 | python-xstatic-hogan \ | 46 | python-xstatic-hogan \ |
45 | python-xstatic-jasmine \ | 47 | python-xstatic-jasmine \ |
@@ -71,7 +73,7 @@ SRC_URI = "git://github.com/openstack/${SRCNAME}.git;branch=stable/kilo \ | |||
71 | " | 73 | " |
72 | 74 | ||
73 | SRCREV = "b99cf48ff346494198fb9740495eacc14fa406bf" | 75 | SRCREV = "b99cf48ff346494198fb9740495eacc14fa406bf" |
74 | PV = "2015.1.0+git${SRCPV}" | 76 | PV = "2015.1.0+git${SRCPV}p1" |
75 | S = "${WORKDIR}/git" | 77 | S = "${WORKDIR}/git" |
76 | 78 | ||
77 | inherit setuptools update-rc.d python-dir default_configs openstackchef monitor | 79 | inherit setuptools update-rc.d python-dir default_configs openstackchef monitor |
diff --git a/meta-openstack/recipes-devtools/python/python-xstatic-angular-lrdragndrop_1.0.2.2.bb b/meta-openstack/recipes-devtools/python/python-xstatic-angular-lrdragndrop_1.0.2.2.bb new file mode 100644 index 0000000..1bc71a3 --- /dev/null +++ b/meta-openstack/recipes-devtools/python/python-xstatic-angular-lrdragndrop_1.0.2.2.bb | |||
@@ -0,0 +1,22 @@ | |||
1 | DESCRIPTION = "LrDragNDrop javascript library packaged for setuptools" | ||
2 | HOMEPAGE = "https://pypi.python.org/pypi/XStatic-Angular-lrdragndrop" | ||
3 | SECTION = "devel/python" | ||
4 | LICENSE = "MIT" | ||
5 | LIC_FILES_CHKSUM = "file://PKG-INFO;md5=92d5d5d8e51c0c2f4f6db4a084a59173" | ||
6 | |||
7 | SRCNAME = "XStatic-Angular-lrdragndrop" | ||
8 | SRC_URI = "http://pypi.python.org/packages/source/X/${SRCNAME}/${SRCNAME}-${PV}.tar.gz" | ||
9 | |||
10 | SRC_URI[md5sum] = "afd682cab9f436cf22b025dfcabaa225" | ||
11 | SRC_URI[sha256sum] = "1cf04495981db5dfd5536441e17ec69bb18d624f847ddc203f3259d81b10a77e" | ||
12 | |||
13 | S = "${WORKDIR}/${SRCNAME}-${PV}" | ||
14 | |||
15 | inherit setuptools | ||
16 | |||
17 | DEPENDS += " \ | ||
18 | python-pip \ | ||
19 | " | ||
20 | |||
21 | RDEPENDS_${PN} += " \ | ||
22 | " | ||
diff --git a/meta-openstack/recipes-devtools/python/python-xstatic-magic-search_0.2.5.1.bb b/meta-openstack/recipes-devtools/python/python-xstatic-magic-search_0.2.5.1.bb new file mode 100644 index 0000000..23fb832 --- /dev/null +++ b/meta-openstack/recipes-devtools/python/python-xstatic-magic-search_0.2.5.1.bb | |||
@@ -0,0 +1,21 @@ | |||
1 | DESCRIPTION = "An AngularJS directive that provides a UI for both faceted filtering and as-you-type filtering" | ||
2 | HOMEPAGE = "https://pypi.python.org/pypi/XStatic-Magic-Search" | ||
3 | SECTION = "devel/python" | ||
4 | LICENSE = "Apache-2.0" | ||
5 | LIC_FILES_CHKSUM = "file://PKG-INFO;md5=e3d8469611ec04e52d71f2e293d54e9c" | ||
6 | |||
7 | SRCNAME = "XStatic-Magic-Search" | ||
8 | SRC_URI = "http://pypi.python.org/packages/source/X/${SRCNAME}/${SRCNAME}-${PV}.tar.gz" | ||
9 | |||
10 | SRC_URI[md5sum] = "cfb8a82129fffbe1f5c6339240cb6139" | ||
11 | SRC_URI[sha256sum] = "9b2f35a5792f4e763e6dc319036e3676f3e18f46153096f3ab5e507177ec007e" | ||
12 | |||
13 | S = "${WORKDIR}/${SRCNAME}-${PV}" | ||
14 | |||
15 | inherit setuptools | ||
16 | |||
17 | DEPENDS += " \ | ||
18 | " | ||
19 | |||
20 | RDEPENDS_${PN} += " \ | ||
21 | " | ||