summaryrefslogtreecommitdiffstats
path: root/meta-openstack/recipes-devtools/python/python-oslo.utils.inc
diff options
context:
space:
mode:
authorZheng Ruoqin <zhengrq.fnst@cn.fujitsu.com>2019-08-12 16:48:48 +0800
committerBruce Ashfield <bruce.ashfield@gmail.com>2019-08-12 10:59:06 -0400
commit57e4f99d8923571a4cf2601afd8da61e305ff60e (patch)
tree79b8d4b1c86bc41831a328c89a5027d248a1f2f6 /meta-openstack/recipes-devtools/python/python-oslo.utils.inc
parent44373ef5877371be7ecc2a0d145913e4d416ff47 (diff)
downloadmeta-cloud-services-57e4f99d8923571a4cf2601afd8da61e305ff60e.tar.gz
python-oslo.utils: Add python3 version
Providing a python3 version of python-oslo.utils. Signed-off-by: Zheng Ruoqin <zhengrq.fnst@cn.fujitsu.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
Diffstat (limited to 'meta-openstack/recipes-devtools/python/python-oslo.utils.inc')
-rw-r--r--meta-openstack/recipes-devtools/python/python-oslo.utils.inc41
1 files changed, 41 insertions, 0 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-oslo.utils.inc b/meta-openstack/recipes-devtools/python/python-oslo.utils.inc
new file mode 100644
index 0000000..04aa24a
--- /dev/null
+++ b/meta-openstack/recipes-devtools/python/python-oslo.utils.inc
@@ -0,0 +1,41 @@
1DESCRIPTION = "Oslo utils"
2HOMEPAGE = "https://launchpad.net/oslo"
3SECTION = "devel/python"
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=34400b68072d710fecd0a2940a0d1658"
6
7SRCNAME = "oslo.utils"
8SRC_URI = "git://github.com/openstack/${SRCNAME}.git;branch=stable/pike"
9
10PV = "3.28.0+git${SRCPV}"
11SRCREV = "8b3965b9bbe1e31a4939f2f69c5239d6d5c7f72c"
12S = "${WORKDIR}/git"
13
14inherit setuptools
15
16# DEPENDS_default: python-pip
17
18DEPENDS += " \
19 ${PYTHON_PN}-pip \
20 ${PYTHON_PN}-pbr \
21 "
22
23# Satisfy setup.py 'setup_requires'
24DEPENDS += " \
25 ${PYTHON_PN}-pbr-native \
26 "
27
28# RDEPENDS_default:
29RDEPENDS_${PN} += " \
30 ${PYTHON_PN}-pbr \
31 ${PYTHON_PN}-six \
32 ${PYTHON_PN}-iso8601 \
33 ${PYTHON_PN}-oslo.i18n \
34 ${PYTHON_PN}-monotonic \
35 ${PYTHON_PN}-pytz \
36 ${PYTHON_PN}-netaddr \
37 ${PYTHON_PN}-netifaces \
38 ${PYTHON_PN}-debtcollector \
39 ${PYTHON_PN}-funcsigs \
40 ${PYTHON_PN}-pyparsing \
41 "