summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-openstack/recipes-devtools/python/python-oslo.utils.inc41
-rw-r--r--meta-openstack/recipes-devtools/python/python-oslo.utils_git.bb41
-rw-r--r--meta-openstack/recipes-devtools/python/python3-oslo.utils_git.bb2
3 files changed, 44 insertions, 40 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-oslo.utils.inc b/meta-openstack/recipes-devtools/python/python-oslo.utils.inc
new file mode 100644
index 0000000..04aa24a
--- /dev/null
+++ b/meta-openstack/recipes-devtools/python/python-oslo.utils.inc
@@ -0,0 +1,41 @@
1DESCRIPTION = "Oslo utils"
2HOMEPAGE = "https://launchpad.net/oslo"
3SECTION = "devel/python"
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=34400b68072d710fecd0a2940a0d1658"
6
7SRCNAME = "oslo.utils"
8SRC_URI = "git://github.com/openstack/${SRCNAME}.git;branch=stable/pike"
9
10PV = "3.28.0+git${SRCPV}"
11SRCREV = "8b3965b9bbe1e31a4939f2f69c5239d6d5c7f72c"
12S = "${WORKDIR}/git"
13
14inherit setuptools
15
16# DEPENDS_default: python-pip
17
18DEPENDS += " \
19 ${PYTHON_PN}-pip \
20 ${PYTHON_PN}-pbr \
21 "
22
23# Satisfy setup.py 'setup_requires'
24DEPENDS += " \
25 ${PYTHON_PN}-pbr-native \
26 "
27
28# RDEPENDS_default:
29RDEPENDS_${PN} += " \
30 ${PYTHON_PN}-pbr \
31 ${PYTHON_PN}-six \
32 ${PYTHON_PN}-iso8601 \
33 ${PYTHON_PN}-oslo.i18n \
34 ${PYTHON_PN}-monotonic \
35 ${PYTHON_PN}-pytz \
36 ${PYTHON_PN}-netaddr \
37 ${PYTHON_PN}-netifaces \
38 ${PYTHON_PN}-debtcollector \
39 ${PYTHON_PN}-funcsigs \
40 ${PYTHON_PN}-pyparsing \
41 "
diff --git a/meta-openstack/recipes-devtools/python/python-oslo.utils_git.bb b/meta-openstack/recipes-devtools/python/python-oslo.utils_git.bb
index e73bf53..fea3c85 100644
--- a/meta-openstack/recipes-devtools/python/python-oslo.utils_git.bb
+++ b/meta-openstack/recipes-devtools/python/python-oslo.utils_git.bb
@@ -1,41 +1,2 @@
1DESCRIPTION = "Oslo utils"
2HOMEPAGE = "https://launchpad.net/oslo"
3SECTION = "devel/python"
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=34400b68072d710fecd0a2940a0d1658"
6
7SRCNAME = "oslo.utils"
8SRC_URI = "git://github.com/openstack/${SRCNAME}.git;branch=stable/pike"
9
10PV = "3.28.0+git${SRCPV}"
11SRCREV = "8b3965b9bbe1e31a4939f2f69c5239d6d5c7f72c"
12S = "${WORKDIR}/git"
13
14inherit setuptools 1inherit setuptools
15 2require python-oslo.utils.inc
16# DEPENDS_default: python-pip
17
18DEPENDS += " \
19 python-pip \
20 python-pbr \
21 "
22
23# Satisfy setup.py 'setup_requires'
24DEPENDS += " \
25 python-pbr-native \
26 "
27
28# RDEPENDS_default:
29RDEPENDS_${PN} += " \
30 python-pbr \
31 python-six \
32 python-iso8601 \
33 python-oslo.i18n \
34 python-monotonic \
35 python-pytz \
36 python-netaddr \
37 python-netifaces \
38 python-debtcollector \
39 python-funcsigs \
40 python-pyparsing \
41 "
diff --git a/meta-openstack/recipes-devtools/python/python3-oslo.utils_git.bb b/meta-openstack/recipes-devtools/python/python3-oslo.utils_git.bb
new file mode 100644
index 0000000..3b4636a
--- /dev/null
+++ b/meta-openstack/recipes-devtools/python/python3-oslo.utils_git.bb
@@ -0,0 +1,2 @@
1inherit setuptools3
2require python-oslo.utils.inc