summaryrefslogtreecommitdiffstats
path: root/meta-openstack/recipes-devtools/python/python-os-traits_git.bb
diff options
context:
space:
mode:
authorMark Asselstine <mark.asselstine@windriver.com>2018-04-04 16:02:46 -0400
committerBruce Ashfield <bruce.ashfield@windriver.com>2018-04-09 10:48:36 -0400
commit5c674203597743efae27be50b1c9903975cc8ab8 (patch)
treee015fe5836f7eea214a9d553f4cab3b540200e8a /meta-openstack/recipes-devtools/python/python-os-traits_git.bb
parent1bd895dc74ef452eb2a9bdb2c6771389d0970252 (diff)
downloadmeta-cloud-services-5c674203597743efae27be50b1c9903975cc8ab8.tar.gz
python-os-traits: initial version (v0.3.3)
Required by python-nova. Signed-off-by: Mark Asselstine <mark.asselstine@windriver.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
Diffstat (limited to 'meta-openstack/recipes-devtools/python/python-os-traits_git.bb')
-rw-r--r--meta-openstack/recipes-devtools/python/python-os-traits_git.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-os-traits_git.bb b/meta-openstack/recipes-devtools/python/python-os-traits_git.bb
new file mode 100644
index 0000000..8d4079b
--- /dev/null
+++ b/meta-openstack/recipes-devtools/python/python-os-traits_git.bb
@@ -0,0 +1,24 @@
1DESCRIPTION = "OpenStack library containing standardized trait strings."
2HOMEPAGE = "https://github.com/openstack/os-traits"
3SECTION = "devel/python"
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=1dece7821bf3fd70fe1309eaa37d52a2"
6
7SRC_URI = "\
8 git://github.com/openstack/os-traits.git;branch=stable/pike \
9 "
10
11PV = "0.3.3+git${SRCPV}"
12SRCREV = "3e8b4a77aaf2d8b64f89ba3b479113d0b44bbe2f"
13S = "${WORKDIR}/git"
14
15inherit setuptools
16
17DEPENDS += " \
18 python-pbr \
19 "
20
21RDEPENDS_${PN} += " \
22 python-pbr \
23 python-six \
24 "