summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-openstack/recipes-devtools/python/python-os-traits_git.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-os-traits_git.bb b/meta-openstack/recipes-devtools/python/python-os-traits_git.bb
new file mode 100644
index 0000000..8d4079b
--- /dev/null
+++ b/meta-openstack/recipes-devtools/python/python-os-traits_git.bb
@@ -0,0 +1,24 @@
1DESCRIPTION = "OpenStack library containing standardized trait strings."
2HOMEPAGE = "https://github.com/openstack/os-traits"
3SECTION = "devel/python"
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=1dece7821bf3fd70fe1309eaa37d52a2"
6
7SRC_URI = "\
8 git://github.com/openstack/os-traits.git;branch=stable/pike \
9 "
10
11PV = "0.3.3+git${SRCPV}"
12SRCREV = "3e8b4a77aaf2d8b64f89ba3b479113d0b44bbe2f"
13S = "${WORKDIR}/git"
14
15inherit setuptools
16
17DEPENDS += " \
18 python-pbr \
19 "
20
21RDEPENDS_${PN} += " \
22 python-pbr \
23 python-six \
24 "