summaryrefslogtreecommitdiffstats
path: root/meta-openstack/recipes-devtools/python/python-os-client-config_git.bb
diff options
context:
space:
mode:
authorMark Asselstine <mark.asselstine@windriver.com>2015-11-11 21:50:28 -0500
committerBruce Ashfield <bruce.ashfield@windriver.com>2015-11-16 15:11:44 -0500
commitd4c210c0903219cf0e048990ab208a18ca828657 (patch)
treeafa629c7b70df922bf4bbe365769e626a117fc7a /meta-openstack/recipes-devtools/python/python-os-client-config_git.bb
parentd0206f9f16905937397f27fb8c18a46331d13056 (diff)
downloadmeta-cloud-services-d4c210c0903219cf0e048990ab208a18ca828657.tar.gz
openstackclient: add missing python modules
Attempting to run 'openstack' commands (such as 'openstack user list') will fail with errors regarding missing python modules. Add the missing module recipes and add the dependencies to openstackclient. Signed-off-by: Mark Asselstine <mark.asselstine@windriver.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
Diffstat (limited to 'meta-openstack/recipes-devtools/python/python-os-client-config_git.bb')
-rw-r--r--meta-openstack/recipes-devtools/python/python-os-client-config_git.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-os-client-config_git.bb b/meta-openstack/recipes-devtools/python/python-os-client-config_git.bb
new file mode 100644
index 0000000..de8c2c2
--- /dev/null
+++ b/meta-openstack/recipes-devtools/python/python-os-client-config_git.bb
@@ -0,0 +1,23 @@
1DESCRIPTION = "OpenStack Client Configuation Library"
2HOMEPAGE = "https://pypi.python.org/pypi/os-client-config"
3SECTION = "devel/python"
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=34400b68072d710fecd0a2940a0d1658"
6
7PV = "1.9.0"
8SRCREV = "790fac98542ba303274180831cbd9a03604a84e8"
9
10SRCNAME = "os-client-config"
11SRC_URI = "git://github.com/openstack/${SRCNAME}.git"
12
13S = "${WORKDIR}/git"
14
15inherit distutils
16
17DEPENDS += " \
18 python-pbr \
19 "
20
21RDEPENDS_${PN} += " \
22 python-pbr \
23 "