summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Asselstine <mark.asselstine@windriver.com>2015-11-11 21:50:28 -0500
committerBruce Ashfield <bruce.ashfield@windriver.com>2015-11-16 15:11:44 -0500
commitd4c210c0903219cf0e048990ab208a18ca828657 (patch)
treeafa629c7b70df922bf4bbe365769e626a117fc7a
parentd0206f9f16905937397f27fb8c18a46331d13056 (diff)
downloadmeta-cloud-services-d4c210c0903219cf0e048990ab208a18ca828657.tar.gz
openstackclient: add missing python modules
Attempting to run 'openstack' commands (such as 'openstack user list') will fail with errors regarding missing python modules. Add the missing module recipes and add the dependencies to openstackclient. Signed-off-by: Mark Asselstine <mark.asselstine@windriver.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
-rw-r--r--meta-openstack/recipes-devtools/python/python-appdirs_git.bb34
-rw-r--r--meta-openstack/recipes-devtools/python/python-keystoneauth1_1.2.0.bb23
-rw-r--r--meta-openstack/recipes-devtools/python/python-openstackclient_1.1.0.bb3
-rw-r--r--meta-openstack/recipes-devtools/python/python-os-client-config_git.bb23
4 files changed, 83 insertions, 0 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-appdirs_git.bb b/meta-openstack/recipes-devtools/python/python-appdirs_git.bb
new file mode 100644
index 0000000..8e40f26
--- /dev/null
+++ b/meta-openstack/recipes-devtools/python/python-appdirs_git.bb
@@ -0,0 +1,34 @@
1DESCRIPTION = "A small Python module for determining appropriate platform-specific dirs, e.g. a user data dir."
2HOMEPAGE = "http://github.com/ActiveState/appdirs"
3SECTION = "devel/python"
4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=31625363c45eb0c67c630a2f73e438e4"
6
7PV = "1.4.0"
8SRCREV = "57f2bc44a8bca99bac6c57496c8b3fdea26f94d5"
9
10SRCNAME = "appdirs"
11SRC_URI = "git://github.com/ActiveState/${SRCNAME}.git"
12
13S = "${WORKDIR}/git"
14
15inherit distutils
16
17DEPENDS += " \
18 python-pip \
19 "
20
21RDEPENDS_${PN} += " \
22 python-pip \
23 "
24
25do_install_append() {
26 # Using these "longest" paths will ensure needed shorter paths will be created
27 install -d ${D}/${libdir}/python2.7/site-packages/${SRCNAME}/test
28 install -d ${D}/${libdir}/python2.7/site-packages/${SRCNAME}.egg-info
29
30 install -m 644 ${S}/${SRCNAME}.py ${D}/${libdir}/python2.7/site-packages/${SRCNAME}/__init__.py
31 install -m 644 ${S}/${SRCNAME}.pyc ${D}/${libdir}/python2.7/site-packages/${SRCNAME}/__init__.pyc
32 install -m 644 ${S}/test/* ${D}/${libdir}/python2.7/site-packages/${SRCNAME}/test/
33 install -m 644 ${S}/${SRCNAME}.egg-info/* ${D}/${libdir}/python2.7/site-packages/${SRCNAME}.egg-info/
34}
diff --git a/meta-openstack/recipes-devtools/python/python-keystoneauth1_1.2.0.bb b/meta-openstack/recipes-devtools/python/python-keystoneauth1_1.2.0.bb
new file mode 100644
index 0000000..a88f8a3
--- /dev/null
+++ b/meta-openstack/recipes-devtools/python/python-keystoneauth1_1.2.0.bb
@@ -0,0 +1,23 @@
1DESCRIPTION = "Authentication Library for OpenStack Identity"
2HOMEPAGE = "https://pypi.python.org/pypi/keystoneauth1"
3SECTION = "devel/python"
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=96f840d59b245a1c817fbcb901afc574"
6
7SRCNAME = "keystoneauth1"
8SRC_URI = "http://pypi.python.org/packages/source/k/${SRCNAME}/${SRCNAME}-${PV}.tar.gz"
9
10SRC_URI[md5sum] = "db4c75346480300fe9015945f73ab33a"
11SRC_URI[sha256sum] = "e8386dc8b0f17d439e1f2f4e6a8ef64fe0f2b81938b2f0b13f80042bb98e2b85"
12
13S = "${WORKDIR}/${SRCNAME}-${PV}"
14
15inherit distutils
16
17DEPENDS += " \
18 python-pbr \
19 "
20
21RDEPENDS_${PN} += " \
22 python-pbr \
23 "
diff --git a/meta-openstack/recipes-devtools/python/python-openstackclient_1.1.0.bb b/meta-openstack/recipes-devtools/python/python-openstackclient_1.1.0.bb
index 3aa733e..37703cc 100644
--- a/meta-openstack/recipes-devtools/python/python-openstackclient_1.1.0.bb
+++ b/meta-openstack/recipes-devtools/python/python-openstackclient_1.1.0.bb
@@ -21,4 +21,7 @@ DEPENDS += "\
21 21
22RDEPENDS_${PN} += "\ 22RDEPENDS_${PN} += "\
23 python-pbr \ 23 python-pbr \
24 python-os-client-config \
25 python-appdirs \
26 python-keystoneauth1 \
24 " 27 "
diff --git a/meta-openstack/recipes-devtools/python/python-os-client-config_git.bb b/meta-openstack/recipes-devtools/python/python-os-client-config_git.bb
new file mode 100644
index 0000000..de8c2c2
--- /dev/null
+++ b/meta-openstack/recipes-devtools/python/python-os-client-config_git.bb
@@ -0,0 +1,23 @@
1DESCRIPTION = "OpenStack Client Configuation Library"
2HOMEPAGE = "https://pypi.python.org/pypi/os-client-config"
3SECTION = "devel/python"
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=34400b68072d710fecd0a2940a0d1658"
6
7PV = "1.9.0"
8SRCREV = "790fac98542ba303274180831cbd9a03604a84e8"
9
10SRCNAME = "os-client-config"
11SRC_URI = "git://github.com/openstack/${SRCNAME}.git"
12
13S = "${WORKDIR}/git"
14
15inherit distutils
16
17DEPENDS += " \
18 python-pbr \
19 "
20
21RDEPENDS_${PN} += " \
22 python-pbr \
23 "