summaryrefslogtreecommitdiffstats
path: root/meta-openstack/recipes-devtools/python/python-novnc
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@windriver.com>2013-09-13 00:11:48 -0400
committerBruce Ashfield <bruce.ashfield@windriver.com>2013-09-13 00:11:48 -0400
commit1902d0a13babdb2b13850dab9baa364be2cadd39 (patch)
tree1d07d9630d6f0831aae59a7df4e353bec30040d6 /meta-openstack/recipes-devtools/python/python-novnc
parentbd6c1e8fb60d628c5818b60094eff1d3406eb618 (diff)
downloadmeta-cloud-services-1902d0a13babdb2b13850dab9baa364be2cadd39.tar.gz
novnc: introduce no VNC for guest console access
Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
Diffstat (limited to 'meta-openstack/recipes-devtools/python/python-novnc')
-rw-r--r--meta-openstack/recipes-devtools/python/python-novnc/python-distutils.patch51
1 files changed, 51 insertions, 0 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-novnc/python-distutils.patch b/meta-openstack/recipes-devtools/python/python-novnc/python-distutils.patch
new file mode 100644
index 0000000..e8acded
--- /dev/null
+++ b/meta-openstack/recipes-devtools/python/python-novnc/python-distutils.patch
@@ -0,0 +1,51 @@
1Index: git/setup.py
2===================================================================
3--- /dev/null
4+++ git/setup.py
5@@ -0,0 +1,14 @@
6+#!/usr/bin/env python
7+
8+from distutils.core import setup
9+
10+setup(name='python-novnc',
11+ version='2012.1~e3',
12+ description='NoVNC python libraries',
13+ author='Ghe Rivero',
14+ author_email='ghe.rivero@stackops.com',
15+ url='http://www.stackops.com',
16+ packages = ['novnc'],
17+ package_dir = {'novnc':'utils'},
18+ py_modules=['wsproxy','websocket','web','json2graph','img2js'],
19+)
20Index: git/utils/__init__.py
21===================================================================
22--- /dev/null
23+++ git/utils/__init__.py
24@@ -0,0 +1 @@
25+# vim: tabstop=4 shiftwidth=4 softtabstop=4
26Index: git/utils/nova-novncproxy
27===================================================================
28--- git.orig/utils/nova-novncproxy
29+++ git/utils/nova-novncproxy
30@@ -27,7 +27,7 @@ from oslo.config import cfg
31 import socket
32 import sys
33
34-import websockify
35+from novnc import wsproxy
36
37 from nova import config
38 from nova import context
39Index: git/utils/websockify
40===================================================================
41--- git.orig/utils/websockify
42+++ git/utils/websockify
43@@ -13,7 +13,7 @@ as taken from http://docs.python.org/dev
44
45 import signal, socket, optparse, time, os, sys, subprocess
46 from select import select
47-import websocket
48+from novnc import websocket
49 try:
50 from urllib.parse import parse_qs, urlparse
51 except: