summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-openstack/recipes-devtools/python/python-novnc/python-distutils.patch51
-rw-r--r--meta-openstack/recipes-devtools/python/python-novnc_git.bb18
-rw-r--r--meta-openstack/recipes-extended/novnc/novnc_git.bb52
3 files changed, 121 insertions, 0 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-novnc/python-distutils.patch b/meta-openstack/recipes-devtools/python/python-novnc/python-distutils.patch
new file mode 100644
index 0000000..e8acded
--- /dev/null
+++ b/meta-openstack/recipes-devtools/python/python-novnc/python-distutils.patch
@@ -0,0 +1,51 @@
1Index: git/setup.py
2===================================================================
3--- /dev/null
4+++ git/setup.py
5@@ -0,0 +1,14 @@
6+#!/usr/bin/env python
7+
8+from distutils.core import setup
9+
10+setup(name='python-novnc',
11+ version='2012.1~e3',
12+ description='NoVNC python libraries',
13+ author='Ghe Rivero',
14+ author_email='ghe.rivero@stackops.com',
15+ url='http://www.stackops.com',
16+ packages = ['novnc'],
17+ package_dir = {'novnc':'utils'},
18+ py_modules=['wsproxy','websocket','web','json2graph','img2js'],
19+)
20Index: git/utils/__init__.py
21===================================================================
22--- /dev/null
23+++ git/utils/__init__.py
24@@ -0,0 +1 @@
25+# vim: tabstop=4 shiftwidth=4 softtabstop=4
26Index: git/utils/nova-novncproxy
27===================================================================
28--- git.orig/utils/nova-novncproxy
29+++ git/utils/nova-novncproxy
30@@ -27,7 +27,7 @@ from oslo.config import cfg
31 import socket
32 import sys
33
34-import websockify
35+from novnc import wsproxy
36
37 from nova import config
38 from nova import context
39Index: git/utils/websockify
40===================================================================
41--- git.orig/utils/websockify
42+++ git/utils/websockify
43@@ -13,7 +13,7 @@ as taken from http://docs.python.org/dev
44
45 import signal, socket, optparse, time, os, sys, subprocess
46 from select import select
47-import websocket
48+from novnc import websocket
49 try:
50 from urllib.parse import parse_qs, urlparse
51 except:
diff --git a/meta-openstack/recipes-devtools/python/python-novnc_git.bb b/meta-openstack/recipes-devtools/python/python-novnc_git.bb
new file mode 100644
index 0000000..6aa54b1
--- /dev/null
+++ b/meta-openstack/recipes-devtools/python/python-novnc_git.bb
@@ -0,0 +1,18 @@
1DESCRIPTION = "This package contains the core python parts of NoVNC"
2HOMEPAGE = "https://github.com/kanaka/noVNC"
3SECTION = "devel/python"
4
5PR = "r0"
6
7LICENSE = "MIT"
8LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=ac06308a999996ffc2d24d81b3a39f1b"
9
10SRCREV = "8f12ca7a5a64144fe548cada332d5d19ef26a1fe"
11PV = "0.4+git${SRCPV}"
12
13SRC_URI = "git://github.com/kanaka/noVNC.git \
14 file://python-distutils.patch"
15
16S = "${WORKDIR}/git"
17
18inherit distutils
diff --git a/meta-openstack/recipes-extended/novnc/novnc_git.bb b/meta-openstack/recipes-extended/novnc/novnc_git.bb
new file mode 100644
index 0000000..ee20e3b
--- /dev/null
+++ b/meta-openstack/recipes-extended/novnc/novnc_git.bb
@@ -0,0 +1,52 @@
1DESCRIPTION = "HTML5 VNC client"
2HOMEPAGE = "https://github.com/kanaka/noVNC"
3SECTION = "web"
4
5PR = "r0"
6
7LICENSE = "MIT"
8LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=ac06308a999996ffc2d24d81b3a39f1b"
9
10SRCREV = "8f12ca7a5a64144fe548cada332d5d19ef26a1fe"
11PV = "0.4+git${SRCPV}"
12
13SRC_URI = "git://github.com/kanaka/noVNC.git"
14
15S = "${WORKDIR}/git"
16
17RDEPENDS_${PN} += "python-numpy"
18RDEPENDS_${PN} += "python-novnc"
19RDEPENDS_${PN} += "python-websockify"
20
21do_compile() {
22 :
23}
24
25do_install() {
26 install -m 755 -d ${D}${bindir}/novnc
27 install -m 755 -d ${D}${datadir}/novnc/include
28
29 install -m 644 ${S}/vnc.html ${D}${datadir}/novnc
30 install -m 644 ${S}/vnc_auto.html ${D}${datadir}/novnc
31 install -m 644 ${S}/images/favicon.ico ${D}${datadir}/novnc
32 install -m 644 ${S}/include/base64.js ${D}${datadir}/novnc/include
33 install -m 644 ${S}/include/des.js ${D}${datadir}/novnc/include
34 install -m 644 ${S}/include/display.js ${D}${datadir}/novnc/include
35 install -m 644 ${S}/include/input.js ${D}${datadir}/novnc/include
36 install -m 644 ${S}/include/logo.js ${D}${datadir}/novnc/include
37 install -m 644 ${S}/include/base.css ${D}${datadir}/novnc/include
38 install -m 644 ${S}/include/blue.css ${D}${datadir}/novnc/include
39 install -m 644 ${S}/include/black.css ${D}${datadir}/novnc/include
40 install -m 644 ${S}/include/playback.js ${D}${datadir}/novnc/include
41 install -m 644 ${S}/include/rfb.js ${D}${datadir}/novnc/include
42 install -m 644 ${S}/include/ui.js ${D}${datadir}/novnc/include
43 install -m 644 ${S}/include/util.js ${D}${datadir}/novnc/include
44 install -m 644 ${S}/include/websock.js ${D}${datadir}/novnc/include
45 install -m 644 ${S}/include/webutil.js ${D}${datadir}/novnc/include
46 install -m 644 ${S}/include/jsunzip.js ${D}${datadir}/novnc/include
47
48 sed -i -e 's:#!/usr/bin/env bash:#!/bin/sh:' ${S}/utils/launch.sh
49
50 install -m 755 ${S}/utils/launch.sh ${D}${bindir}/novnc-launch.sh
51}
52