summaryrefslogtreecommitdiffstats
path: root/meta-openstack/recipes-devtools/python/python-keystoneclient_git.bb
diff options
context:
space:
mode:
authorKeith Holman <Keith.Holman@windriver.com>2014-06-20 13:09:43 -0400
committerBruce Ashfield <bruce.ashfield@windriver.com>2014-06-23 12:41:34 -0400
commitbd0c221f230e26adeb693eb626b08757037a8c6a (patch)
tree9a0ac5a0e09d60e10c1fc3bc90570a8663872eb0 /meta-openstack/recipes-devtools/python/python-keystoneclient_git.bb
parent2854e3b0dcf7f0ac2e115c82ed9686a62f2ee4a0 (diff)
downloadmeta-cloud-services-bd0c221f230e26adeb693eb626b08757037a8c6a.tar.gz
httpretty: create recipe for package
Keystoneclient tests require the package httpretty be available on the system in order to run. This fix includes a recipe file for obtaining and building httpretty. The fix also adds httpretty as a dependency of keystoneclient. Signed-off-by: Keith Holman <Keith.Holman@windriver.com>
Diffstat (limited to 'meta-openstack/recipes-devtools/python/python-keystoneclient_git.bb')
-rw-r--r--meta-openstack/recipes-devtools/python/python-keystoneclient_git.bb6
1 files changed, 5 insertions, 1 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-keystoneclient_git.bb b/meta-openstack/recipes-devtools/python/python-keystoneclient_git.bb
index a326cd7..9e7965c 100644
--- a/meta-openstack/recipes-devtools/python/python-keystoneclient_git.bb
+++ b/meta-openstack/recipes-devtools/python/python-keystoneclient_git.bb
@@ -26,7 +26,8 @@ DEPENDS += " \
26 python-pbr \ 26 python-pbr \
27 " 27 "
28 28
29RDEPENDS_${PN} += "python-iso8601 \ 29RDEPENDS_${PN} += " \
30 python-iso8601 \
30 python-prettytable \ 31 python-prettytable \
31 python-requests \ 32 python-requests \
32 python-simplejson \ 33 python-simplejson \
@@ -49,4 +50,7 @@ FILES_${BPN}-bash-completion = "${sysconfdir}/bash_completion.d/*"
49 50
50FILES_${SRCNAME}-tests = "${D}${PYTHON_SITEPACKAGES_DIR}/${SRCNAME}/examples \ 51FILES_${SRCNAME}-tests = "${D}${PYTHON_SITEPACKAGES_DIR}/${SRCNAME}/examples \
51 " 52 "
53RDEPENDS_${SRCNAME}-tests += " \
54 python-httpretty \
55 "
52 56