summaryrefslogtreecommitdiffstats
path: root/meta-openstack/recipes-devtools/python/python-keystoneclient_git.bb
diff options
context:
space:
mode:
authorKeith Holman <Keith.Holman@windriver.com>2014-06-20 13:06:01 -0400
committerBruce Ashfield <bruce.ashfield@windriver.com>2014-06-23 12:41:34 -0400
commit2854e3b0dcf7f0ac2e115c82ed9686a62f2ee4a0 (patch)
tree7512d09559ea476792140314a27d73168ca0d8a5 /meta-openstack/recipes-devtools/python/python-keystoneclient_git.bb
parent22ec75e2681284f85e4c71bdc428efe19af77891 (diff)
downloadmeta-cloud-services-2854e3b0dcf7f0ac2e115c82ed9686a62f2ee4a0.tar.gz
keystoneclient: add example test certificates
The tests included with keystoneclient require the use of example certificates. This fix copies the example certificates that are found in the source to the target system. It also patches the test files to find the certificates in the correct location. Signed-off-by: Keith Holman <Keith.Holman@windriver.com>
Diffstat (limited to 'meta-openstack/recipes-devtools/python/python-keystoneclient_git.bb')
-rw-r--r--meta-openstack/recipes-devtools/python/python-keystoneclient_git.bb10
1 files changed, 9 insertions, 1 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-keystoneclient_git.bb b/meta-openstack/recipes-devtools/python/python-keystoneclient_git.bb
index de75a63..a326cd7 100644
--- a/meta-openstack/recipes-devtools/python/python-keystoneclient_git.bb
+++ b/meta-openstack/recipes-devtools/python/python-keystoneclient_git.bb
@@ -5,10 +5,12 @@ LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=4a4d0e932ffae1c0131528d30d419c55" 5LIC_FILES_CHKSUM = "file://LICENSE;md5=4a4d0e932ffae1c0131528d30d419c55"
6 6
7PR = "r0" 7PR = "r0"
8SRCNAME = "keystoneclient"
8 9
9SRC_URI = "\ 10SRC_URI = "\
10 git://github.com/openstack/python-keystoneclient.git;branch=master \ 11 git://github.com/openstack/python-keystoneclient.git;branch=master \
11 file://fix_keystoneclient_memory_leak.patch \ 12 file://fix_keystoneclient_memory_leak.patch \
13 file://keystoneclient-fix-test-path-to-example-certificates.patch \
12 " 14 "
13 15
14PV="0.6.0+git${SRCPV}" 16PV="0.6.0+git${SRCPV}"
@@ -38,7 +40,13 @@ PACKAGECONFIG[bash-completion] = ",,bash-completion,bash-completion ${BPN}-bash-
38do_install_append() { 40do_install_append() {
39 install -d ${D}/${sysconfdir}/bash_completion.d 41 install -d ${D}/${sysconfdir}/bash_completion.d
40 install -m 664 ${S}/tools/keystone.bash_completion ${D}/${sysconfdir}/bash_completion.d 42 install -m 664 ${S}/tools/keystone.bash_completion ${D}/${sysconfdir}/bash_completion.d
43
44 cp -r ${S}/examples ${D}${PYTHON_SITEPACKAGES_DIR}/${SRCNAME}
41} 45}
42 46
43PACKAGES =+ "${BPN}-bash-completion" 47PACKAGES =+ " ${SRCNAME}-tests ${BPN}-bash-completion"
44FILES_${BPN}-bash-completion = "${sysconfdir}/bash_completion.d/*" 48FILES_${BPN}-bash-completion = "${sysconfdir}/bash_completion.d/*"
49
50FILES_${SRCNAME}-tests = "${D}${PYTHON_SITEPACKAGES_DIR}/${SRCNAME}/examples \
51 "
52