summaryrefslogtreecommitdiffstats
path: root/meta-openstack/recipes-devtools/python/python-django_git.bb
diff options
context:
space:
mode:
authorMark Asselstine <mark.asselstine@windriver.com>2015-12-09 11:44:21 -0500
committerBruce Ashfield <bruce.ashfield@windriver.com>2015-12-11 12:17:24 -0500
commit18f6951ff709cc78c5519c0a593e39cf8c09f331 (patch)
tree9a11af79c375235b4376019cbac47d96f1c12af7 /meta-openstack/recipes-devtools/python/python-django_git.bb
parent2d260e08c1e1b4f115b226fdcaf02eb9e7dce77f (diff)
downloadmeta-cloud-services-18f6951ff709cc78c5519c0a593e39cf8c09f331.tar.gz
python-django: uprev to 1.8.6
Move to use git to ease future uprevs. Note that a recipe for django exists in meta-python and since it is a versioned recipe instead of a "_git" recipe it seems to be picked up instead of our recipe, so we need to add a PREFERRED_VERSION to ensure our recipe is used. Signed-off-by: Mark Asselstine <mark.asselstine@windriver.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
Diffstat (limited to 'meta-openstack/recipes-devtools/python/python-django_git.bb')
-rw-r--r--meta-openstack/recipes-devtools/python/python-django_git.bb21
1 files changed, 21 insertions, 0 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-django_git.bb b/meta-openstack/recipes-devtools/python/python-django_git.bb
new file mode 100644
index 0000000..f11f8e6
--- /dev/null
+++ b/meta-openstack/recipes-devtools/python/python-django_git.bb
@@ -0,0 +1,21 @@
1DESCRIPTION = "A high-level Python Web framework"
2HOMEPAGE = "http://www.djangoproject.com/"
3SECTION = "devel/python"
4LICENSE = "BSD"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=f09eb47206614a4954c51db8a94840fa"
6
7SRCNAME = "Django"
8
9PV = "1.8.6"
10SRCREV = "80b7e9d09f2d23209b591288f9b2cf3eb3d927c8"
11
12SRC_URI = " \
13 git://github.com/django/django.git;branch=stable/1.8.x \
14 "
15
16S = "${WORKDIR}/git"
17
18inherit setuptools
19
20FILES_${PN} += "${datadir}/django/*"
21