summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Asselstine <mark.asselstine@windriver.com>2015-12-09 11:44:21 -0500
committerBruce Ashfield <bruce.ashfield@windriver.com>2015-12-11 12:17:24 -0500
commit18f6951ff709cc78c5519c0a593e39cf8c09f331 (patch)
tree9a11af79c375235b4376019cbac47d96f1c12af7
parent2d260e08c1e1b4f115b226fdcaf02eb9e7dce77f (diff)
downloadmeta-cloud-services-18f6951ff709cc78c5519c0a593e39cf8c09f331.tar.gz
python-django: uprev to 1.8.6
Move to use git to ease future uprevs. Note that a recipe for django exists in meta-python and since it is a versioned recipe instead of a "_git" recipe it seems to be picked up instead of our recipe, so we need to add a PREFERRED_VERSION to ensure our recipe is used. Signed-off-by: Mark Asselstine <mark.asselstine@windriver.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
-rw-r--r--meta-openstack/conf/layer.conf1
-rw-r--r--meta-openstack/recipes-devtools/python/python-django_git.bb (renamed from meta-openstack/recipes-devtools/python/python-django_1.7.5.bb)11
2 files changed, 7 insertions, 5 deletions
diff --git a/meta-openstack/conf/layer.conf b/meta-openstack/conf/layer.conf
index 2b3a00d..f0d42b8 100644
--- a/meta-openstack/conf/layer.conf
+++ b/meta-openstack/conf/layer.conf
@@ -14,3 +14,4 @@ BB_DANGLINGAPPENDS_WARNONLY ?= "true"
14PREFERRED_VERSION_python-greenlet = "0.4.1" 14PREFERRED_VERSION_python-greenlet = "0.4.1"
15PREFERRED_VERSION_python-sqlalchemy = "0.9.7" 15PREFERRED_VERSION_python-sqlalchemy = "0.9.7"
16PREFERRED_VERSION_python-pexpect = "3.3" 16PREFERRED_VERSION_python-pexpect = "3.3"
17PREFERRED_VERSION_python-django = "1.8.6"
diff --git a/meta-openstack/recipes-devtools/python/python-django_1.7.5.bb b/meta-openstack/recipes-devtools/python/python-django_git.bb
index b462e4d..f11f8e6 100644
--- a/meta-openstack/recipes-devtools/python/python-django_1.7.5.bb
+++ b/meta-openstack/recipes-devtools/python/python-django_git.bb
@@ -6,13 +6,14 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=f09eb47206614a4954c51db8a94840fa"
6 6
7SRCNAME = "Django" 7SRCNAME = "Django"
8 8
9SRC_URI = "https://pypi.python.org/packages/source/D/${SRCNAME}/${SRCNAME}-${PV}.tar.gz \ 9PV = "1.8.6"
10" 10SRCREV = "80b7e9d09f2d23209b591288f9b2cf3eb3d927c8"
11 11
12SRC_URI[md5sum] = "e76c70a5dd7d56a511974b28ab38df20" 12SRC_URI = " \
13SRC_URI[sha256sum] = "1c391f9349c97df503dac3461599f24235e4d04393498e6060e74dd2721460bc" 13 git://github.com/django/django.git;branch=stable/1.8.x \
14 "
14 15
15S = "${WORKDIR}/${SRCNAME}-${PV}" 16S = "${WORKDIR}/git"
16 17
17inherit setuptools 18inherit setuptools
18 19