summaryrefslogtreecommitdiffstats
path: root/meta-openstack/recipes-devtools/python/python-cinderclient_git.bb
diff options
context:
space:
mode:
authorMark Asselstine <mark.asselstine@windriver.com>2017-11-13 14:32:23 -0500
committerBruce Ashfield <bruce.ashfield@windriver.com>2017-11-14 12:38:27 -0500
commit40116bf038970b47f386a01714e499fc54a155b6 (patch)
tree09e2ff37bd2f9dfa32c594ba8ada1b59a3995da9 /meta-openstack/recipes-devtools/python/python-cinderclient_git.bb
parent1853c434f5986bdf763efc07e8b957b74efc9f43 (diff)
downloadmeta-cloud-services-40116bf038970b47f386a01714e499fc54a155b6.tar.gz
python-cinderclient: uprev to latest stable/pike
Remove old patches and update runtime dependencies based on requirements.txt Signed-off-by: Mark Asselstine <mark.asselstine@windriver.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
Diffstat (limited to 'meta-openstack/recipes-devtools/python/python-cinderclient_git.bb')
-rw-r--r--meta-openstack/recipes-devtools/python/python-cinderclient_git.bb30
1 files changed, 15 insertions, 15 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-cinderclient_git.bb b/meta-openstack/recipes-devtools/python/python-cinderclient_git.bb
index e264694..bf76e9d 100644
--- a/meta-openstack/recipes-devtools/python/python-cinderclient_git.bb
+++ b/meta-openstack/recipes-devtools/python/python-cinderclient_git.bb
@@ -8,32 +8,32 @@ DEPENDS = "python-setuptools-git"
8SRCNAME = "python-cinderclient" 8SRCNAME = "python-cinderclient"
9 9
10SRC_URI = "\ 10SRC_URI = "\
11 git://github.com/openstack/python-cinderclient.git;branch=master \ 11 git://github.com/openstack/python-cinderclient.git;branch=stable/pike \
12 file://fix_cinderclient_memory_leak.patch \
13 file://cinder-api-check.sh \ 12 file://cinder-api-check.sh \
14 " 13 "
15 14
16PV="1.4.0+git${SRCPV}" 15PV="3.1.0+git${SRCPV}"
17SRCREV="c167dda40cc65fe437a12b815ef91bbde4efb6bb" 16SRCREV="3640aeab6e11987288a2f149fbeedb1c026045e2"
18S = "${WORKDIR}/git" 17S = "${WORKDIR}/git"
19 18
20inherit setuptools monitor rmargparse 19inherit setuptools monitor
21 20
22DEPENDS += " \ 21DEPENDS += " \
23 python-pip \ 22 python-pip \
24 python-pbr \ 23 python-pbr \
25 " 24 "
26 25
27RDEPENDS_${PN} += "python-prettytable \ 26RDEPENDS_${PN} += " \
28 python-simplejson \ 27 python-pbr \
29 python-requests \ 28 python-prettytable \
30 python-setuptools-git \ 29 python-keystoneauth1 \
31 python-pbr \ 30 python-simplejson \
32 python-keystoneclient \ 31 python-babel \
33 python-babel \ 32 python-six \
34 python-six \ 33 python-oslo.i18n \
35 " 34 python-oslo.utils \
36 35 "
36
37PACKAGECONFIG ?= "bash-completion" 37PACKAGECONFIG ?= "bash-completion"
38PACKAGECONFIG[bash-completion] = ",,bash-completion,bash-completion ${BPN}-bash-completion" 38PACKAGECONFIG[bash-completion] = ",,bash-completion,bash-completion ${BPN}-bash-completion"
39 39