summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Asselstine <mark.asselstine@windriver.com>2017-11-13 14:32:23 -0500
committerBruce Ashfield <bruce.ashfield@windriver.com>2017-11-14 12:38:27 -0500
commit40116bf038970b47f386a01714e499fc54a155b6 (patch)
tree09e2ff37bd2f9dfa32c594ba8ada1b59a3995da9
parent1853c434f5986bdf763efc07e8b957b74efc9f43 (diff)
downloadmeta-cloud-services-40116bf038970b47f386a01714e499fc54a155b6.tar.gz
python-cinderclient: uprev to latest stable/pike
Remove old patches and update runtime dependencies based on requirements.txt Signed-off-by: Mark Asselstine <mark.asselstine@windriver.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
-rw-r--r--meta-openstack/recipes-devtools/python/python-cinderclient/fix_cinderclient_memory_leak.patch37
-rw-r--r--meta-openstack/recipes-devtools/python/python-cinderclient_git.bb30
2 files changed, 15 insertions, 52 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-cinderclient/fix_cinderclient_memory_leak.patch b/meta-openstack/recipes-devtools/python/python-cinderclient/fix_cinderclient_memory_leak.patch
deleted file mode 100644
index 137edfd..0000000
--- a/meta-openstack/recipes-devtools/python/python-cinderclient/fix_cinderclient_memory_leak.patch
+++ /dev/null
@@ -1,37 +0,0 @@
1---
2 cinderclient/openstack/common/apiclient/client.py | 10 ++++++++++
3 1 file changed, 10 insertions(+)
4
5--- a/cinderclient/openstack/common/apiclient/client.py
6+++ b/cinderclient/openstack/common/apiclient/client.py
7@@ -90,6 +90,7 @@
8 self.user_agent = user_agent or self.user_agent
9
10 self.times = [] # [("item", starttime, endtime), ...]
11+ self.times_max_len = 200
12 self.timings = timings
13
14 # requests within the same session can reuse TCP connections from pool
15@@ -142,6 +143,12 @@
16 def reset_timings(self):
17 self.times = []
18
19+ def get_timings_max_len(self):
20+ return self.times_max_len
21+
22+ def set_timings_max_len(self, new_len):
23+ self.times_max_len = new_len
24+
25 def request(self, method, url, **kwargs):
26 """Send an http request with the specified characteristics.
27
28@@ -173,6 +180,9 @@
29 if self.timings:
30 self.times.append(("%s %s" % (method, url),
31 start_time, time.time()))
32+ # remove oldest items until we maintain max length
33+ while len(self.times) > self.times_max_len:
34+ del self.times[0]
35 self._http_log_resp(resp)
36
37 if resp.status_code >= 400:
diff --git a/meta-openstack/recipes-devtools/python/python-cinderclient_git.bb b/meta-openstack/recipes-devtools/python/python-cinderclient_git.bb
index e264694..bf76e9d 100644
--- a/meta-openstack/recipes-devtools/python/python-cinderclient_git.bb
+++ b/meta-openstack/recipes-devtools/python/python-cinderclient_git.bb
@@ -8,32 +8,32 @@ DEPENDS = "python-setuptools-git"
8SRCNAME = "python-cinderclient" 8SRCNAME = "python-cinderclient"
9 9
10SRC_URI = "\ 10SRC_URI = "\
11 git://github.com/openstack/python-cinderclient.git;branch=master \ 11 git://github.com/openstack/python-cinderclient.git;branch=stable/pike \
12 file://fix_cinderclient_memory_leak.patch \
13 file://cinder-api-check.sh \ 12 file://cinder-api-check.sh \
14 " 13 "
15 14
16PV="1.4.0+git${SRCPV}" 15PV="3.1.0+git${SRCPV}"
17SRCREV="c167dda40cc65fe437a12b815ef91bbde4efb6bb" 16SRCREV="3640aeab6e11987288a2f149fbeedb1c026045e2"
18S = "${WORKDIR}/git" 17S = "${WORKDIR}/git"
19 18
20inherit setuptools monitor rmargparse 19inherit setuptools monitor
21 20
22DEPENDS += " \ 21DEPENDS += " \
23 python-pip \ 22 python-pip \
24 python-pbr \ 23 python-pbr \
25 " 24 "
26 25
27RDEPENDS_${PN} += "python-prettytable \ 26RDEPENDS_${PN} += " \
28 python-simplejson \ 27 python-pbr \
29 python-requests \ 28 python-prettytable \
30 python-setuptools-git \ 29 python-keystoneauth1 \
31 python-pbr \ 30 python-simplejson \
32 python-keystoneclient \ 31 python-babel \
33 python-babel \ 32 python-six \
34 python-six \ 33 python-oslo.i18n \
35 " 34 python-oslo.utils \
36 35 "
36
37PACKAGECONFIG ?= "bash-completion" 37PACKAGECONFIG ?= "bash-completion"
38PACKAGECONFIG[bash-completion] = ",,bash-completion,bash-completion ${BPN}-bash-completion" 38PACKAGECONFIG[bash-completion] = ",,bash-completion,bash-completion ${BPN}-bash-completion"
39 39