summaryrefslogtreecommitdiffstats
path: root/meta-openstack-qemu
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@windriver.com>2014-01-08 01:05:55 -0500
committerBruce Ashfield <bruce.ashfield@windriver.com>2014-01-15 00:33:53 -0500
commitb825fa0fac27ee733037ead3f52a2ca18a53a53c (patch)
tree78756bd4d4aa4187c1d8e78d35c6249ef4f6f8f4 /meta-openstack-qemu
parentb45880a1a11007476446c7e2f53b0fee43c43453 (diff)
downloadmeta-cloud-services-b825fa0fac27ee733037ead3f52a2ca18a53a53c.tar.gz
ceilometer: set libvirt_type to KVM, but allow modification for nested virt
We expose the libvirt_type config setting with a default value of 'kvm', but for nested virtualization configurations, we also provide a bbappend that will modify the value to 'qemu' automatically. Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
Diffstat (limited to 'meta-openstack-qemu')
-rw-r--r--meta-openstack-qemu/recipes-devtools/python/python-ceilometer_git.bbappend11
1 files changed, 11 insertions, 0 deletions
diff --git a/meta-openstack-qemu/recipes-devtools/python/python-ceilometer_git.bbappend b/meta-openstack-qemu/recipes-devtools/python/python-ceilometer_git.bbappend
new file mode 100644
index 0000000..5d45d62
--- /dev/null
+++ b/meta-openstack-qemu/recipes-devtools/python/python-ceilometer_git.bbappend
@@ -0,0 +1,11 @@
1do_install_append() {
2 if [ ! -f "${WORKDIR}/ceilometer.conf" ]; then
3 return
4 fi
5
6 TEMPLATE_CONF_DIR=${S}${sysconfdir}/${SRCNAME}
7 CEILOMETER_CONF_DIR=${D}/${sysconfdir}/ceilometer
8
9 sed -e "s:^libvirt_type.*=.*$:libvirt_type = qemu:" \
10 -i ${CEILOMETER_CONF_DIR}/ceilometer.conf
11} \ No newline at end of file