summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-openstack-qemu/recipes-devtools/python/python-ceilometer_git.bbappend11
-rw-r--r--meta-openstack/recipes-devtools/python/python-ceilometer/ceilometer.conf2
2 files changed, 12 insertions, 1 deletions
diff --git a/meta-openstack-qemu/recipes-devtools/python/python-ceilometer_git.bbappend b/meta-openstack-qemu/recipes-devtools/python/python-ceilometer_git.bbappend
new file mode 100644
index 0000000..5d45d62
--- /dev/null
+++ b/meta-openstack-qemu/recipes-devtools/python/python-ceilometer_git.bbappend
@@ -0,0 +1,11 @@
1do_install_append() {
2 if [ ! -f "${WORKDIR}/ceilometer.conf" ]; then
3 return
4 fi
5
6 TEMPLATE_CONF_DIR=${S}${sysconfdir}/${SRCNAME}
7 CEILOMETER_CONF_DIR=${D}/${sysconfdir}/ceilometer
8
9 sed -e "s:^libvirt_type.*=.*$:libvirt_type = qemu:" \
10 -i ${CEILOMETER_CONF_DIR}/ceilometer.conf
11} \ No newline at end of file
diff --git a/meta-openstack/recipes-devtools/python/python-ceilometer/ceilometer.conf b/meta-openstack/recipes-devtools/python/python-ceilometer/ceilometer.conf
index 892a6af..457199d 100644
--- a/meta-openstack/recipes-devtools/python/python-ceilometer/ceilometer.conf
+++ b/meta-openstack/recipes-devtools/python/python-ceilometer/ceilometer.conf
@@ -74,7 +74,7 @@
74 74
75# Libvirt domain type (valid options are: kvm, lxc, qemu, uml, 75# Libvirt domain type (valid options are: kvm, lxc, qemu, uml,
76# xen) (string value) 76# xen) (string value)
77#libvirt_type=kvm 77libvirt_type=kvm
78 78
79# Override the default libvirt URI (which is dependent on 79# Override the default libvirt URI (which is dependent on
80# libvirt_type) (string value) 80# libvirt_type) (string value)