summaryrefslogtreecommitdiffstats
path: root/meta-openstack-qemu/recipes-devtools/python/python-nova-compute_2013.1.3.bbappend
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@windriver.com>2013-09-23 16:35:57 -0400
committerBruce Ashfield <bruce.ashfield@windriver.com>2013-10-03 01:15:42 -0400
commitdfead22088d47a052d2170e126a5c52d942b35d2 (patch)
tree833daa266b5e2f2e6e321ad5b45bc3fb84d684f7 /meta-openstack-qemu/recipes-devtools/python/python-nova-compute_2013.1.3.bbappend
parentfcffddaac729715622760a1c1ad6df62c5ee5e2f (diff)
downloadmeta-cloud-services-dfead22088d47a052d2170e126a5c52d942b35d2.tar.gz
meta-openstack-qemu: initial creation
When included in a build, this layer modifies settings to allow a controller and compute node boot and runtime under qemu system emulation. Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
Diffstat (limited to 'meta-openstack-qemu/recipes-devtools/python/python-nova-compute_2013.1.3.bbappend')
-rw-r--r--meta-openstack-qemu/recipes-devtools/python/python-nova-compute_2013.1.3.bbappend11
1 files changed, 11 insertions, 0 deletions
diff --git a/meta-openstack-qemu/recipes-devtools/python/python-nova-compute_2013.1.3.bbappend b/meta-openstack-qemu/recipes-devtools/python/python-nova-compute_2013.1.3.bbappend
new file mode 100644
index 0000000..45f4307
--- /dev/null
+++ b/meta-openstack-qemu/recipes-devtools/python/python-nova-compute_2013.1.3.bbappend
@@ -0,0 +1,11 @@
1do_install_append() {
2 if [ ! -f "${WORKDIR}/nova.conf" ]; then
3 return
4 fi
5
6 TEMPLATE_CONF_DIR=${S}${sysconfdir}/${SRCNAME}
7 NOVA_CONF_DIR=${D}/${sysconfdir}/nova
8
9 sed -e "s:^libvirt_type.*=.*$:libvirt_type = qemu:" \
10 -i ${NOVA_CONF_DIR}/nova.conf
11}