summaryrefslogtreecommitdiffstats
path: root/meta-openstack-qemu
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@windriver.com>2013-09-23 16:35:57 -0400
committerBruce Ashfield <bruce.ashfield@windriver.com>2013-10-03 01:15:42 -0400
commitdfead22088d47a052d2170e126a5c52d942b35d2 (patch)
tree833daa266b5e2f2e6e321ad5b45bc3fb84d684f7 /meta-openstack-qemu
parentfcffddaac729715622760a1c1ad6df62c5ee5e2f (diff)
downloadmeta-cloud-services-dfead22088d47a052d2170e126a5c52d942b35d2.tar.gz
meta-openstack-qemu: initial creation
When included in a build, this layer modifies settings to allow a controller and compute node boot and runtime under qemu system emulation. Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
Diffstat (limited to 'meta-openstack-qemu')
-rw-r--r--meta-openstack-qemu/README48
-rw-r--r--meta-openstack-qemu/conf/layer.conf9
-rw-r--r--meta-openstack-qemu/recipes-devtools/python/python-nova-compute_2013.1.3.bbappend11
-rw-r--r--meta-openstack-qemu/recipes-devtools/python/python-nova-controller_2013.1.3.bbappend11
4 files changed, 79 insertions, 0 deletions
diff --git a/meta-openstack-qemu/README b/meta-openstack-qemu/README
new file mode 100644
index 0000000..63ef70a
--- /dev/null
+++ b/meta-openstack-qemu/README
@@ -0,0 +1,48 @@
1meta-openstack-qemu
2===================
3
4This layer provides support configuring and deploying OpenStack images that
5are destined to be run under qemu system emulation.
6
7Dependencies
8------------
9
10This layer depends on:
11
12URI: git://github.com/openembedded/oe-core.git
13branch: master
14revision: HEAD
15prio: default
16
17URI: git://github.com/openembedded/meta-oe.git
18patches: 0001-python-sqlalchemy-update-to-0.7.9.patch
19revision: HEAD
20layers: meta-oe
21 meta-networking
22 meta-ruby
23
24URI: git://git.yoctoproject.org/meta-virtualization
25branch: master
26revision: head
27
28meta-openstack
29branch: master
30revision: head
31
32Maintenance
33-----------
34
35Send pull requests, patches, comments or questions to meta-virtualization@yoctoproject.org
36
37When sending single patches, please using something like:
38'git send-email -1 --to meta-virtualization@yoctoproject.org --subject-prefix=meta-virtualization][PATCH'
39
40Maintainers: Bruce Ashfield <bruce.ashfield@windriver.com>
41
42License
43-------
44
45All metadata is MIT licensed unless otherwise stated. Source code included
46in tree for individual recipes is under the LICENSE stated in each recipe
47(.bb file) unless otherwise stated.
48
diff --git a/meta-openstack-qemu/conf/layer.conf b/meta-openstack-qemu/conf/layer.conf
new file mode 100644
index 0000000..6761143
--- /dev/null
+++ b/meta-openstack-qemu/conf/layer.conf
@@ -0,0 +1,9 @@
1# We have a conf and classes directory, append to BBPATH
2BBPATH .= ":${LAYERDIR}"
3
4# We have a recipes directory, add to BBFILES
5BBFILES += "${LAYERDIR}/recipes*/*/*.bb ${LAYERDIR}/recipes*/*/*.bbappend"
6
7BBFILE_COLLECTIONS += "openstack-qemu-layer"
8BBFILE_PATTERN_openstack-qemu-layer := "^${LAYERDIR}/"
9BBFILE_PRIORITY_openstack-qemu-layer = "6"
diff --git a/meta-openstack-qemu/recipes-devtools/python/python-nova-compute_2013.1.3.bbappend b/meta-openstack-qemu/recipes-devtools/python/python-nova-compute_2013.1.3.bbappend
new file mode 100644
index 0000000..45f4307
--- /dev/null
+++ b/meta-openstack-qemu/recipes-devtools/python/python-nova-compute_2013.1.3.bbappend
@@ -0,0 +1,11 @@
1do_install_append() {
2 if [ ! -f "${WORKDIR}/nova.conf" ]; then
3 return
4 fi
5
6 TEMPLATE_CONF_DIR=${S}${sysconfdir}/${SRCNAME}
7 NOVA_CONF_DIR=${D}/${sysconfdir}/nova
8
9 sed -e "s:^libvirt_type.*=.*$:libvirt_type = qemu:" \
10 -i ${NOVA_CONF_DIR}/nova.conf
11}
diff --git a/meta-openstack-qemu/recipes-devtools/python/python-nova-controller_2013.1.3.bbappend b/meta-openstack-qemu/recipes-devtools/python/python-nova-controller_2013.1.3.bbappend
new file mode 100644
index 0000000..f45a02b
--- /dev/null
+++ b/meta-openstack-qemu/recipes-devtools/python/python-nova-controller_2013.1.3.bbappend
@@ -0,0 +1,11 @@
1do_install_append() {
2 if [ ! -f "${WORKDIR}/nova.conf" ]; then
3 return
4 fi
5
6 TEMPLATE_CONF_DIR=${S}${sysconfdir}/${SRCNAME}
7 NOVA_CONF_DIR=${D}/${sysconfdir}/nova
8
9 sed -e "s:^libvirt_type.*=.*$:libvirt_type = qemu:" \
10 -i ${NOVA_CONF_DIR}/nova.conf
11} \ No newline at end of file