summaryrefslogtreecommitdiffstats
path: root/meta-openstack/recipes-devtools/python/python3-oslo.versionedobjects_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openstack/recipes-devtools/python/python3-oslo.versionedobjects_git.bb')
-rw-r--r--meta-openstack/recipes-devtools/python/python3-oslo.versionedobjects_git.bb41
1 files changed, 41 insertions, 0 deletions
diff --git a/meta-openstack/recipes-devtools/python/python3-oslo.versionedobjects_git.bb b/meta-openstack/recipes-devtools/python/python3-oslo.versionedobjects_git.bb
new file mode 100644
index 0000000..41064dd
--- /dev/null
+++ b/meta-openstack/recipes-devtools/python/python3-oslo.versionedobjects_git.bb
@@ -0,0 +1,41 @@
1DESCRIPTION = "oslo.versionedobjects library"
2HOMEPAGE = "https://wiki.openstack.org/wiki/Oslo"
3SECTION = "devel/python"
4LICENSE = "Apache-2"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=1dece7821bf3fd70fe1309eaa37d52a2"
6
7PV = "2.3.0+git${SRCPV}"
8SRCREV = "8db69628834332ed2df6690135be5d5c1ebd3ca1"
9
10SRCNAME = "oslo.versionedobjects"
11SRC_URI = "git://github.com/openstack/${SRCNAME}.git"
12
13S = "${WORKDIR}/git"
14
15inherit setuptools3
16
17DEPENDS += " \
18 python3-pip \
19 python3-pbr \
20 "
21
22# Satisfy setup.py 'setup_requires'
23DEPENDS += " \
24 python3-pbr-native \
25 "
26
27# RDEPENDS_default:
28RDEPENDS_${PN} += " \
29 python3-six \
30 python3-oslo.concurrency \
31 python3-oslo.config \
32 python3-oslo.context \
33 python3-oslo.messaging \
34 python3-oslo.serialization \
35 python3-oslo.utils \
36 python3-oslo.log \
37 python3-oslo.i18n \
38 python3-webob \
39 python3-iso8601 \
40 python3-netaddr \
41 "