summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDavid Burns <dburns@digi.com>2020-09-23 10:36:24 +1000
committerBruce Ashfield <bruce.ashfield@gmail.com>2020-09-27 22:45:44 -0400
commitd64a289a868e106a331984f1c27baec88e6d6005 (patch)
treea1e89045cb301e3746f4e971a6fd2d7ea526441c
parent285b64586ccfee5e374b27142ea2af0b2093ec9a (diff)
downloadmeta-cloud-services-d64a289a868e106a331984f1c27baec88e6d6005.tar.gz
salt: Move to version 3001.1 and fix RDEPENDS
Move to a new minor version of salt, 3001.1 that includes a number of bug fixes. Salt also needs the python3-distro runtime dependency for all of the packages in the recipe, not just the salt-master package so it has been included in the common package. A runtime dependency on python-pycryptodomex has been added to the salt-master and salt-minion packages as both have required it since the 3001 salt version. Signed-off-by: David Burns <dburns@digi.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
-rw-r--r--meta-openstack/recipes-support/salt/salt_3001.1.bb (renamed from meta-openstack/recipes-support/salt/salt_3001.bb)10
1 files changed, 5 insertions, 5 deletions
diff --git a/meta-openstack/recipes-support/salt/salt_3001.bb b/meta-openstack/recipes-support/salt/salt_3001.1.bb
index 04ef1c7..9b485d6 100644
--- a/meta-openstack/recipes-support/salt/salt_3001.bb
+++ b/meta-openstack/recipes-support/salt/salt_3001.1.bb
@@ -21,8 +21,8 @@ PACKAGECONFIG[tcp] = ",,python3-pycrypto"
21SRC_URI = "https://files.pythonhosted.org/packages/source/s/${PN}/${PN}-${PV}.tar.gz \ 21SRC_URI = "https://files.pythonhosted.org/packages/source/s/${PN}/${PN}-${PV}.tar.gz \
22" 22"
23 23
24SRC_URI[md5sum] = "ae06cef7557e237a954491a069e79a25" 24SRC_URI[md5sum] = "4174a6dd2c7eee808086ca06bdd928c9"
25SRC_URI[sha256sum] = "5ca60d1b2cc8e63db50995bd8b117914eeaf57c48ce2b3a3731ee57163adf154" 25SRC_URI[sha256sum] = "e9ebb4d92fae8dabf21b8749dc126e4a4048bf8f613f5b1b851fe4b8226b5abc"
26 26
27 27
28SYSTEMD_AUTO_ENABLE_${PN}-master = "disable" 28SYSTEMD_AUTO_ENABLE_${PN}-master = "disable"
@@ -87,7 +87,7 @@ Between the remote execution system, and state management Salt addresses the bac
87 87
88SUMMARY_${PN}-minion = "client package for salt, the distributed remote execution system" 88SUMMARY_${PN}-minion = "client package for salt, the distributed remote execution system"
89DESCRIPTION_${PN}-minion = "${DESCRIPTION_COMMON} This particular package provides the worker agent for salt." 89DESCRIPTION_${PN}-minion = "${DESCRIPTION_COMMON} This particular package provides the worker agent for salt."
90RDEPENDS_${PN}-minion = "${PN}-common (= ${EXTENDPKGV}) python3-msgpack" 90RDEPENDS_${PN}-minion = "${PN}-common (= ${EXTENDPKGV}) python3-msgpack python3-pycryptodomex (>= 3.9.7)"
91RDEPENDS_${PN}-minion += "${@bb.utils.contains('PACKAGECONFIG', 'zeromq', 'python3-pycrypto python3-pyzmq (>= 13.1.0)', '',d)}" 91RDEPENDS_${PN}-minion += "${@bb.utils.contains('PACKAGECONFIG', 'zeromq', 'python3-pycrypto python3-pyzmq (>= 13.1.0)', '',d)}"
92RDEPENDS_${PN}-minion += "${@bb.utils.contains('PACKAGECONFIG', 'tcp', 'python3-pycrypto', '',d)}" 92RDEPENDS_${PN}-minion += "${@bb.utils.contains('PACKAGECONFIG', 'tcp', 'python3-pycrypto', '',d)}"
93RRECOMMENDS_${PN}-minion_append_x64 = "dmidecode" 93RRECOMMENDS_${PN}-minion_append_x64 = "dmidecode"
@@ -98,7 +98,7 @@ FILES_${PN}-minion = "${bindir}/${PN}-minion ${sysconfdir}/${PN}/minion.d/ ${CON
98SUMMARY_${PN}-common = "shared libraries that salt requires for all packages" 98SUMMARY_${PN}-common = "shared libraries that salt requires for all packages"
99DESCRIPTION_${PN}-common ="${DESCRIPTION_COMMON} This particular package provides shared libraries that \ 99DESCRIPTION_${PN}-common ="${DESCRIPTION_COMMON} This particular package provides shared libraries that \
100salt-master, salt-minion, and salt-syndic require to function." 100salt-master, salt-minion, and salt-syndic require to function."
101RDEPENDS_${PN}-common = "python3-dateutil python3-jinja2 python3-pyyaml python3-requests (>= 1.0.0)" 101RDEPENDS_${PN}-common = "python3-dateutil python3-jinja2 python3-pyyaml python3-requests (>= 1.0.0) python3-distro"
102RRECOMMENDS_${PN}-common = "lsb-release" 102RRECOMMENDS_${PN}-common = "lsb-release"
103RSUGGESTS_${PN}-common = "python3-mako python3-git" 103RSUGGESTS_${PN}-common = "python3-mako python3-git"
104RCONFLICTS_${PN}-common = "python3-mako (< 0.7.0)" 104RCONFLICTS_${PN}-common = "python3-mako (< 0.7.0)"
@@ -127,7 +127,7 @@ FILES_${PN}-api = "${bindir}/${PN}-api ${CONFFILES_${PN}-api} ${systemd_system_u
127 127
128SUMMARY_${PN}-master = "remote manager to administer servers via salt" 128SUMMARY_${PN}-master = "remote manager to administer servers via salt"
129DESCRIPTION_${PN}-master ="${DESCRIPTION_COMMON} This particular package provides the salt controller." 129DESCRIPTION_${PN}-master ="${DESCRIPTION_COMMON} This particular package provides the salt controller."
130RDEPENDS_${PN}-master = "${PN}-common (= ${EXTENDPKGV}) python3-msgpack python3-distro" 130RDEPENDS_${PN}-master = "${PN}-common (= ${EXTENDPKGV}) python3-msgpack python3-pycryptodomex (>= 3.9.7)"
131RDEPENDS_${PN}-master += "${@bb.utils.contains('PACKAGECONFIG', 'zeromq', 'python3-pycrypto python3-pyzmq (>= 13.1.0)', '',d)}" 131RDEPENDS_${PN}-master += "${@bb.utils.contains('PACKAGECONFIG', 'zeromq', 'python3-pycrypto python3-pyzmq (>= 13.1.0)', '',d)}"
132RDEPENDS_${PN}-master += "${@bb.utils.contains('PACKAGECONFIG', 'tcp', 'python3-pycrypto', '',d)}" 132RDEPENDS_${PN}-master += "${@bb.utils.contains('PACKAGECONFIG', 'tcp', 'python3-pycrypto', '',d)}"
133CONFFILES_${PN}-master="${sysconfdir}/init.d/${PN}-master ${sysconfdir}/${PN}/master" 133CONFFILES_${PN}-master="${sysconfdir}/init.d/${PN}-master ${sysconfdir}/${PN}/master"