summaryrefslogtreecommitdiffstats
path: root/meta-openstack/recipes-support/salt/salt_3001.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openstack/recipes-support/salt/salt_3001.1.bb')
-rw-r--r--meta-openstack/recipes-support/salt/salt_3001.1.bb158
1 files changed, 158 insertions, 0 deletions
diff --git a/meta-openstack/recipes-support/salt/salt_3001.1.bb b/meta-openstack/recipes-support/salt/salt_3001.1.bb
new file mode 100644
index 0000000..9b485d6
--- /dev/null
+++ b/meta-openstack/recipes-support/salt/salt_3001.1.bb
@@ -0,0 +1,158 @@
1HOMEPAGE = "http://saltstack.com/"
2SECTION = "admin"
3LICENSE = "Apache-2.0"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=89aea4e17d99a7cacdbeed46a0096b10"
5DEPENDS = "\
6 python3-msgpack \
7 python3-pyyaml \
8 python3-jinja2 \
9 python3-markupsafe \
10 python3-dateutil \
11 python3-pycrypto \
12 python3-pytest-salt \
13 python3-pyzmq \
14 python3-requests \
15"
16
17PACKAGECONFIG ??= "zeromq"
18PACKAGECONFIG[zeromq] = ",,python3-pyzmq python3-pycrypto,"
19PACKAGECONFIG[tcp] = ",,python3-pycrypto"
20
21SRC_URI = "https://files.pythonhosted.org/packages/source/s/${PN}/${PN}-${PV}.tar.gz \
22"
23
24SRC_URI[md5sum] = "4174a6dd2c7eee808086ca06bdd928c9"
25SRC_URI[sha256sum] = "e9ebb4d92fae8dabf21b8749dc126e4a4048bf8f613f5b1b851fe4b8226b5abc"
26
27
28SYSTEMD_AUTO_ENABLE_${PN}-master = "disable"
29SYSTEMD_AUTO_ENABLE_${PN}-minion = "disable"
30SYSTEMD_AUTO_ENABLE_${PN}-api = "disable"
31
32S = "${WORKDIR}/${PN}-${PV}"
33
34inherit setuptools3 systemd
35
36# Avoid a QA Warning triggered by the test package including a file
37# with a .a extension
38INSANE_SKIP_${PN}-tests += "staticdev"
39
40RDEPENDS_${PN} += "${PN}-api \
41 ${PN}-common \
42 ${PN}-master \
43 ${PN}-minion \
44 ${PN}-bash-completion \
45"
46
47# Note ${PN}-tests must be before ${PN}-common in the PACKAGES variable
48# in order for ${PN}-tests to own the correct FILES.
49PACKAGES += "\
50 ${PN}-api \
51 ${PN}-common \
52 ${PN}-master \
53 ${PN}-minion \
54 ${PN}-cloud \
55 ${PN}-syndic \
56 ${PN}-ssh \
57 ${PN}-bash-completion \
58 ${PN}-zsh-completion \
59"
60
61do_install_append() {
62 install -Dm644 ${S}/pkg/salt-common.logrotate ${D}${sysconfdir}/logrotate.d/${PN}
63 install -Dm644 ${S}/pkg/salt.bash ${D}${datadir}/bash-completion/completions/${PN}
64 install -Dm644 ${S}/pkg/zsh_completion.zsh ${D}${datadir}/zsh/site-functions/_${PN}
65
66 # default config
67 install -Dm644 ${S}/conf/minion ${D}${sysconfdir}/${PN}/minion
68 install -Dm644 ${S}/conf/minion ${D}${sysconfdir}/${PN}/master
69
70 # systemd services
71 for _svc in salt-master.service salt-syndic.service salt-minion.service salt-api.service; do
72 install -Dm644 ${S}/pkg/$_svc "${D}${systemd_system_unitdir}/$_svc"
73 done
74}
75
76ALLOW_EMPTY_${PN} = "1"
77FILES_${PN} = ""
78FILES_${PN} += "${systemd_system_unitdir} ${systemd_system_unitdir}/* /etc/salt/master.d /etc/salt/master.d/preseed_key.py"
79
80DESCRIPTION_COMMON = "salt is a powerful remote execution manager that can be used to administer servers in a\
81 fast and efficient way. It allows commands to be executed across large groups of servers. This means systems\
82 can be easily managed, but data can also be easily gathered. Quick introspection into running systems becomes\
83 a reality. Remote execution is usually used to set up a certain state on a remote system. Salt addresses this\
84 problem as well, the salt state system uses salt state files to define the state a server needs to be in. \
85Between the remote execution system, and state management Salt addresses the backbone of cloud and data center\
86 management."
87
88SUMMARY_${PN}-minion = "client package for salt, the distributed remote execution system"
89DESCRIPTION_${PN}-minion = "${DESCRIPTION_COMMON} This particular package provides the worker agent for salt."
90RDEPENDS_${PN}-minion = "${PN}-common (= ${EXTENDPKGV}) python3-msgpack python3-pycryptodomex (>= 3.9.7)"
91RDEPENDS_${PN}-minion += "${@bb.utils.contains('PACKAGECONFIG', 'zeromq', 'python3-pycrypto python3-pyzmq (>= 13.1.0)', '',d)}"
92RDEPENDS_${PN}-minion += "${@bb.utils.contains('PACKAGECONFIG', 'tcp', 'python3-pycrypto', '',d)}"
93RRECOMMENDS_${PN}-minion_append_x64 = "dmidecode"
94RSUGGESTS_${PN}-minion = "python3-augeas"
95CONFFILES_${PN}-minion = "${sysconfdir}/${PN}/minion"
96FILES_${PN}-minion = "${bindir}/${PN}-minion ${sysconfdir}/${PN}/minion.d/ ${CONFFILES_${PN}-minion} ${bindir}/${PN}-proxy ${systemd_system_unitdir}/salt-minion.service"
97
98SUMMARY_${PN}-common = "shared libraries that salt requires for all packages"
99DESCRIPTION_${PN}-common ="${DESCRIPTION_COMMON} This particular package provides shared libraries that \
100salt-master, salt-minion, and salt-syndic require to function."
101RDEPENDS_${PN}-common = "python3-dateutil python3-jinja2 python3-pyyaml python3-requests (>= 1.0.0) python3-distro"
102RRECOMMENDS_${PN}-common = "lsb-release"
103RSUGGESTS_${PN}-common = "python3-mako python3-git"
104RCONFLICTS_${PN}-common = "python3-mako (< 0.7.0)"
105CONFFILES_${PN}-common="${sysconfdir}/logrotate.d/${PN}"
106FILES_${PN}-common = "${bindir}/${PN}-call ${PYTHON_SITEPACKAGES_DIR}/* ${CONFFILES_${PN}-common}"
107
108SUMMARY_${PN}-ssh = "remote manager to administer servers via salt"
109DESCRIPTION_${PN}-ssh = "${DESCRIPTION_COMMON} This particular package provides the salt ssh controller. It \
110is able to run salt modules and states on remote hosts via ssh. No minion or other salt specific software needs\
111 to be installed on the remote host."
112RDEPENDS_${PN}-ssh = "${PN}-common (= ${EXTENDPKGV}) python3-msgpack"
113CONFFILES_${PN}-ssh="${sysconfdir}/${PN}/roster"
114FILES_${PN}-ssh = "${bindir}/${PN}-ssh ${CONFFILES_${PN}-ssh}"
115
116SUMMARY_${PN}-api = "generic, modular network access system"
117DESCRIPTION_${PN}-api = "a modular interface on top of Salt that can provide a variety of entry points into a \
118running Salt system. It can start and manage multiple interfaces allowing a REST API to coexist with XMLRPC or \
119even a Websocket API. The Salt API system is used to expose the fundamental aspects of Salt control to external\
120 sources. salt-api acts as the bridge between Salt itself and REST, Websockets, etc. Documentation is available\
121 on Read the Docs: http://salt-api.readthedocs.org/"
122RDEPENDS_${PN}-api = "${PN}-master"
123RSUGGESTS_${PN}-api = "python3-cherrypy"
124CONFFILES_${PN}-api = "${sysconfdir}/init.d/${PN}-api"
125FILES_${PN}-api = "${bindir}/${PN}-api ${CONFFILES_${PN}-api} ${systemd_system_unitdir}/${PN}-api.service"
126
127
128SUMMARY_${PN}-master = "remote manager to administer servers via salt"
129DESCRIPTION_${PN}-master ="${DESCRIPTION_COMMON} This particular package provides the salt controller."
130RDEPENDS_${PN}-master = "${PN}-common (= ${EXTENDPKGV}) python3-msgpack python3-pycryptodomex (>= 3.9.7)"
131RDEPENDS_${PN}-master += "${@bb.utils.contains('PACKAGECONFIG', 'zeromq', 'python3-pycrypto python3-pyzmq (>= 13.1.0)', '',d)}"
132RDEPENDS_${PN}-master += "${@bb.utils.contains('PACKAGECONFIG', 'tcp', 'python3-pycrypto', '',d)}"
133CONFFILES_${PN}-master="${sysconfdir}/init.d/${PN}-master ${sysconfdir}/${PN}/master"
134RSUGGESTS_${PN}-master = "python3-git"
135FILES_${PN}-master = "${bindir}/${PN} ${bindir}/${PN}-cp ${bindir}/${PN}-key ${bindir}/${PN}-master ${bindir}/${PN}-run ${bindir}/${PN}-unity ${bindir}/spm ${CONFFILES_${PN}-master} ${systemd_system_unitdir}/${PN}-master.service"
136
137
138SUMMARY_${PN}-syndic = "master-of-masters for salt, the distributed remote execution system"
139DESCRIPTION_${PN}-syndic = "${DESCRIPTION_COMMON} This particular package provides the master of masters for \
140salt; it enables the management of multiple masters at a time."
141RDEPENDS_${PN}-syndic = "${PN}-master (= ${EXTENDPKGV})"
142CONFFILES_${PN}-syndic="${sysconfdir}/init.d/${PN}-syndic"
143FILES_${PN}-syndic = "${bindir}/${PN}-syndic ${CONFFILES_${PN}-syndic} ${systemd_system_unitdir}/${PN}-syndic.service"
144
145SUMMARY_${PN}-cloud = "public cloud VM management system"
146DESCRIPTION_${PN}-cloud = "provision virtual machines on various public clouds via a cleanly controlled profile and mapping system."
147RDEPENDS_${PN}-cloud = "${PN}-common (= ${EXTENDPKGV})"
148RSUGGESTS_${PN}-cloud = "python3-netaddr python3-botocore"
149CONFFILES_${PN}-cloud = "${sysconfdir}/${PN}/cloud"
150FILES_${PN}-cloud = "${bindir}/${PN}-cloud ${sysconfdir}/${PN}/cloud.conf.d/ ${sysconfdir}/${PN}/cloud.profiles.d/ ${sysconfdir}/${PN}/cloud.providers.d/ ${CONFFILES_${PN}-cloud}"
151
152SUMMARY_${PN}-tests = "salt stack test suite"
153DESCRIPTION_${PN}-tests ="${DESCRIPTION_COMMON} This particular package provides the salt unit test suite."
154RDEPENDS_${PN}-tests = "${PN}-common python3-pytest-salt python3-tests python3-image bash"
155FILES_${PN}-tests = "${PYTHON_SITEPACKAGES_DIR}/salt-tests/tests/"
156
157FILES_${PN}-bash-completion = "${datadir}/bash-completion"
158FILES_${PN}-zsh-completion = "${datadir}/zsh/site-functions"