summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorzhengruoqin <zhengrq.fnst@cn.fujitsu.com>2020-08-19 02:36:43 +0800
committerBruce Ashfield <bruce.ashfield@gmail.com>2020-08-20 15:25:42 -0400
commit8d2689c2eb446776745bd1cb2ef7ce1424d0f840 (patch)
tree9d741759dc8bf2f02ffbe5c45eda4754aef42308
parent8f0f7f7b12e5e67c5c37806c400601b36f95e4d3 (diff)
downloadmeta-cloud-services-8d2689c2eb446776745bd1cb2ef7ce1424d0f840.tar.gz
python3-pysaml2: Change to python3
-License-Update: Rename from LICENSE.txt to LICENSE. Signed-off-by: Zheng Ruoqin <zhengrq.fnst@cn.fujitsu.com>/ Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
-rw-r--r--meta-openstack/recipes-devtools/python/python-pysaml2_git.bb24
-rw-r--r--meta-openstack/recipes-devtools/python/python3-pysaml2_6.1.0.bb18
2 files changed, 18 insertions, 24 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-pysaml2_git.bb b/meta-openstack/recipes-devtools/python/python-pysaml2_git.bb
deleted file mode 100644
index 3e1aa9b..0000000
--- a/meta-openstack/recipes-devtools/python/python-pysaml2_git.bb
+++ /dev/null
@@ -1,24 +0,0 @@
1DESCRIPTION = "Python implementation of SAML Version 2 to be used in a WSGI environment"
2HOMEPAGE = "https://github.com/rohe/pysaml2"
3SECTION = "devel/python"
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=e53b335c47f863b1e324a1c9f2e8e3f3"
6
7PV = "3.0.2+git${SRCPV}"
8SRCREV = "248c629aa570b16fdc79c5a5eb2b3c4c0ee52916"
9
10SRCNAME = "pysaml2"
11SRC_URI = "git://github.com/rohe/${SRCNAME}.git"
12
13S = "${WORKDIR}/git"
14
15inherit setuptools3
16
17DEPENDS += " \
18 python-pip \
19 "
20
21RDEPENDS_${PN} += " \
22 python-zopeinterface \
23 python-repoze.who \
24 "
diff --git a/meta-openstack/recipes-devtools/python/python3-pysaml2_6.1.0.bb b/meta-openstack/recipes-devtools/python/python3-pysaml2_6.1.0.bb
new file mode 100644
index 0000000..bfd1c48
--- /dev/null
+++ b/meta-openstack/recipes-devtools/python/python3-pysaml2_6.1.0.bb
@@ -0,0 +1,18 @@
1DESCRIPTION = "Python implementation of SAML Version 2 to be used in a WSGI environment"
2HOMEPAGE = "https://github.com/rohe/pysaml2"
3SECTION = "devel/python"
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=861cc9087857b5bea2e11356c3de95d9"
6
7inherit setuptools3 pypi
8
9SRC_URI[sha256sum] = "f7b80553f84bf4e3c823266d2243ab6c0303785648402fbbc1c13a14737876d4"
10
11DEPENDS += " \
12 python3-pip \
13 "
14
15RDEPENDS_${PN} += " \
16 python3-zopeinterface \
17 python3-repoze.who \
18 "