summaryrefslogtreecommitdiffstats
path: root/meta-openstack/recipes-devtools/python/python3-pysaml2_6.1.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openstack/recipes-devtools/python/python3-pysaml2_6.1.0.bb')
-rw-r--r--meta-openstack/recipes-devtools/python/python3-pysaml2_6.1.0.bb18
1 files changed, 18 insertions, 0 deletions
diff --git a/meta-openstack/recipes-devtools/python/python3-pysaml2_6.1.0.bb b/meta-openstack/recipes-devtools/python/python3-pysaml2_6.1.0.bb
new file mode 100644
index 0000000..bfd1c48
--- /dev/null
+++ b/meta-openstack/recipes-devtools/python/python3-pysaml2_6.1.0.bb
@@ -0,0 +1,18 @@
1DESCRIPTION = "Python implementation of SAML Version 2 to be used in a WSGI environment"
2HOMEPAGE = "https://github.com/rohe/pysaml2"
3SECTION = "devel/python"
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=861cc9087857b5bea2e11356c3de95d9"
6
7inherit setuptools3 pypi
8
9SRC_URI[sha256sum] = "f7b80553f84bf4e3c823266d2243ab6c0303785648402fbbc1c13a14737876d4"
10
11DEPENDS += " \
12 python3-pip \
13 "
14
15RDEPENDS_${PN} += " \
16 python3-zopeinterface \
17 python3-repoze.who \
18 "