summaryrefslogtreecommitdiffstats
path: root/meta-openstack/recipes-devtools/python/python3-oslo.messaging_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openstack/recipes-devtools/python/python3-oslo.messaging_git.bb')
-rw-r--r--meta-openstack/recipes-devtools/python/python3-oslo.messaging_git.bb51
1 files changed, 51 insertions, 0 deletions
diff --git a/meta-openstack/recipes-devtools/python/python3-oslo.messaging_git.bb b/meta-openstack/recipes-devtools/python/python3-oslo.messaging_git.bb
new file mode 100644
index 0000000..9582c6b
--- /dev/null
+++ b/meta-openstack/recipes-devtools/python/python3-oslo.messaging_git.bb
@@ -0,0 +1,51 @@
1DESCRIPTION = "Oslo Messaging API"
2HOMEPAGE = "https://launchpad.net/oslo"
3SECTION = "devel/python"
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=c46f31914956e4579f9b488e71415ac8"
6
7SRCNAME = "oslo.messaging"
8SRC_URI = "git://github.com/openstack/${SRCNAME}.git"
9
10PV = "12.5.0+git${SRCPV}"
11SRCREV = "62e104bdb57714a0754f788795d1b4faf8ebb74d"
12S = "${WORKDIR}/git"
13
14inherit setuptools3
15
16# DEPENDS_default: python-pip
17
18DEPENDS += " \
19 python3-pip \
20 python3-pbr \
21 "
22
23# Satisfy setup.py 'setup_requires'
24DEPENDS += " \
25 python3-pbr-native \
26 "
27
28# RDEPENDS_default:
29RDEPENDS_${PN} += " \
30 bash \
31 python3-pbr \
32 python3-cachetools \
33 python3-futurist \
34 python3-oslo.log \
35 python3-oslo.utils \
36 python3-oslo.serialization \
37 python3-oslo.middleware \
38 python3-oslo.service \
39 python3-oslo.i18n \
40 python3-stevedore \
41 python3-debtcollector \
42 python3-monotonic \
43 python3-six \
44 python3-webob \
45 python3-pyyaml \
46 python3-amqp \
47 python3-kombu \
48 python3-pika \
49 python3-pika-pool \
50 python3-tenacity \
51 "