summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorzhengruoqin <zhengrq.fnst@cn.fujitsu.com>2020-11-23 22:42:49 +0800
committerBruce Ashfield <bruce.ashfield@gmail.com>2020-12-01 16:30:52 -0500
commit60437785af1571799e112bf7d7b581fa76273c01 (patch)
tree182e7cd1a3b47a12a3f8232ebae39bd97c960266
parent287d65e67684a9a409d776c296952f3a08f09b79 (diff)
downloadmeta-cloud-services-60437785af1571799e112bf7d7b581fa76273c01.tar.gz
python3-os-vif: Change to python3
Signed-off-by: Zheng Ruoqin <zhengrq.fnst@cn.fujitsu.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
-rw-r--r--meta-openstack/recipes-devtools/python/python-os-vif_git.bb38
-rw-r--r--meta-openstack/recipes-devtools/python/python3-os-vif_git.bb37
2 files changed, 37 insertions, 38 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-os-vif_git.bb b/meta-openstack/recipes-devtools/python/python-os-vif_git.bb
deleted file mode 100644
index 6ad2020..0000000
--- a/meta-openstack/recipes-devtools/python/python-os-vif_git.bb
+++ /dev/null
@@ -1,38 +0,0 @@
1DESCRIPTION = "OpenStack integration library between network and compute providers."
2HOMEPAGE = "https://github.com/openstack/os-vif"
3SECTION = "devel/python"
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=1dece7821bf3fd70fe1309eaa37d52a2"
6
7SRC_URI = "\
8 git://github.com/openstack/os-vif.git;branch=stable/pike \
9 "
10
11PV = "1.7.0+git${SRCPV}"
12SRCREV = "5184b7fc3b8d1689823eacb859087c8a943f9a09"
13S = "${WORKDIR}/git"
14
15inherit setuptools3
16
17DEPENDS += " \
18 python-pbr \
19 "
20
21# Satisfy setup.py 'setup_requires'
22DEPENDS += " \
23 python-pbr-native \
24 "
25
26RDEPENDS_${PN} += " \
27 python-pbr \
28 python-netaddr \
29 python-oslo.concurrency \
30 python-oslo.config \
31 python-oslo.log \
32 python-oslo.i18n \
33 python-oslo.privsep \
34 python-oslo.versionedobjects \
35 python-six \
36 python-stevedore \
37 "
38
diff --git a/meta-openstack/recipes-devtools/python/python3-os-vif_git.bb b/meta-openstack/recipes-devtools/python/python3-os-vif_git.bb
new file mode 100644
index 0000000..18a9e6b
--- /dev/null
+++ b/meta-openstack/recipes-devtools/python/python3-os-vif_git.bb
@@ -0,0 +1,37 @@
1DESCRIPTION = "OpenStack integration library between network and compute providers."
2HOMEPAGE = "https://github.com/openstack/os-vif"
3SECTION = "devel/python"
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=1dece7821bf3fd70fe1309eaa37d52a2"
6
7SRC_URI = "\
8 git://github.com/openstack/os-vif.git \
9 "
10
11PV = "2.2.0+git${SRCPV}"
12SRCREV = "d7928102d69dadf653c9f734e5cf8fd504335849"
13S = "${WORKDIR}/git"
14
15inherit setuptools3
16
17DEPENDS += " \
18 python3-pbr \
19 "
20
21# Satisfy setup.py 'setup_requires'
22DEPENDS += " \
23 python3-pbr-native \
24 "
25
26RDEPENDS_${PN} += " \
27 python3-pbr \
28 python3-netaddr \
29 python3-oslo.concurrency \
30 python3-oslo.config \
31 python3-oslo.log \
32 python3-oslo.i18n \
33 python3-oslo.privsep \
34 python3-six \
35 python3-stevedore \
36 "
37