summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorzhengruoqin <zhengrq.fnst@cn.fujitsu.com>2020-11-23 22:43:03 +0800
committerBruce Ashfield <bruce.ashfield@gmail.com>2020-12-01 16:30:52 -0500
commit287d65e67684a9a409d776c296952f3a08f09b79 (patch)
tree10372a70f581d0e1ea5b5cba917cb6966fa4942f
parentbf8731534a49ade4d879114f548101d2d384a814 (diff)
downloadmeta-cloud-services-287d65e67684a9a409d776c296952f3a08f09b79.tar.gz
python3-pypowervm: upgrade 1.1.10 -> 1.1.24
Because python2 is no longer maintained, bb file is changed to python3 version. Signed-off-by: Zheng Ruoqin <zhengrq.fnst@cn.fujitsu.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
-rw-r--r--meta-openstack/recipes-devtools/python/python-pypowervm_1.1.10.bb33
-rw-r--r--meta-openstack/recipes-devtools/python/python3-pypowervm_1.1.24.bb32
2 files changed, 32 insertions, 33 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-pypowervm_1.1.10.bb b/meta-openstack/recipes-devtools/python/python-pypowervm_1.1.10.bb
deleted file mode 100644
index 062d351..0000000
--- a/meta-openstack/recipes-devtools/python/python-pypowervm_1.1.10.bb
+++ /dev/null
@@ -1,33 +0,0 @@
1DESCRIPTION = "Python binding for the PowerVM REST API"
2HOMEPAGE = "https://pypi.python.org/pypi/pypowervm"
3SECTION = "devel/python"
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=1dece7821bf3fd70fe1309eaa37d52a2"
6
7SRC_URI[md5sum] = "54e4dfaa569350254b0a0f4c19686ded"
8SRC_URI[sha256sum] = "ab27d4efb59105555b6c9b1fe7792fd895ad9ca893058c39bba4106d6a0ad986"
9
10inherit setuptools3 pypi
11
12# Satisfy setup.py 'setup_requires'
13DEPENDS += " \
14 python-pbr-native \
15 "
16
17RDEPENDS_${PN} += " \
18 python-lxml \
19 python-oslo.concurrency \
20 python-oslo.context \
21 python-oslo.i18n \
22 python-oslo.log \
23 python-oslo.utils \
24 python-pbr \
25 python-pyasn1-modules \
26 python-pyasn1 \
27 python-pytz \
28 python-requests \
29 python-six \
30 python-futures \
31 python-taskflow \
32 python-networkx \
33 "
diff --git a/meta-openstack/recipes-devtools/python/python3-pypowervm_1.1.24.bb b/meta-openstack/recipes-devtools/python/python3-pypowervm_1.1.24.bb
new file mode 100644
index 0000000..e659f61
--- /dev/null
+++ b/meta-openstack/recipes-devtools/python/python3-pypowervm_1.1.24.bb
@@ -0,0 +1,32 @@
1DESCRIPTION = "Python binding for the PowerVM REST API"
2HOMEPAGE = "https://pypi.python.org/pypi/pypowervm"
3SECTION = "devel/python"
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=1dece7821bf3fd70fe1309eaa37d52a2"
6
7SRC_URI[md5sum] = "50b580055e5628aadaeb42fd69158ff8"
8SRC_URI[sha256sum] = "4c6bf225d2b1022b5d363f9b3695fd1692523235d3ce1b5b4506fbc608bdb535"
9
10inherit setuptools3 pypi
11
12# Satisfy setup.py 'setup_requires'
13DEPENDS += " \
14 python3-pbr-native \
15 "
16
17RDEPENDS_${PN} += " \
18 python3-lxml \
19 python3-oslo.concurrency \
20 python3-oslo.context \
21 python3-oslo.i18n \
22 python3-oslo.log \
23 python3-oslo.utils \
24 python3-pbr \
25 python3-pyasn1-modules \
26 python3-pyasn1 \
27 python3-pytz \
28 python3-requests \
29 python3-six \
30 python3-taskflow \
31 python3-networkx \
32 "