summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Asselstine <mark.asselstine@windriver.com>2015-12-08 18:33:15 +0100
committerBruce Ashfield <bruce.ashfield@windriver.com>2015-12-11 12:11:28 -0500
commit5e4c6f860802e1b392305fe4d6bbf94170aba0e2 (patch)
treea5c154b2a7504404c204e159397fb763b1698165
parent9354507f0b8190ddb5091f786ab49c4747f5f960 (diff)
downloadmeta-cloud-services-5e4c6f860802e1b392305fe4d6bbf94170aba0e2.tar.gz
python-nova: add missing dependency on sqlparse
Attempting to use nova-manage, for example to perform 'service list', will result in a python trace indicating that the sqlparse module was not found. Add the python-sqlparse recipe and include it in the RDEPENDS list for nova. Signed-off-by: Mark Asselstine <mark.asselstine@windriver.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com> Signed-off-by: Josep Puigdemont <josep.puigdemont@enea.com> Conflicts: meta-openstack/recipes-devtools/python/python-nova_git.bb Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
-rw-r--r--meta-openstack/recipes-devtools/python/python-nova_git.bb1
-rw-r--r--meta-openstack/recipes-devtools/python/python-sqlparse_0.1.16.bb27
2 files changed, 28 insertions, 0 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-nova_git.bb b/meta-openstack/recipes-devtools/python/python-nova_git.bb
index 79fad92..8bfcbea 100644
--- a/meta-openstack/recipes-devtools/python/python-nova_git.bb
+++ b/meta-openstack/recipes-devtools/python/python-nova_git.bb
@@ -323,6 +323,7 @@ RDEPENDS_${PN} = " libvirt \
323 python-rfc3986 \ 323 python-rfc3986 \
324 python-oslo.i18n \ 324 python-oslo.i18n \
325 python-psutil \ 325 python-psutil \
326 python-sqlparse \
326 " 327 "
327 328
328RDEPENDS_${SRCNAME}-common = "${PN} openssl openssl-misc libxml2 libxslt \ 329RDEPENDS_${SRCNAME}-common = "${PN} openssl openssl-misc libxml2 libxslt \
diff --git a/meta-openstack/recipes-devtools/python/python-sqlparse_0.1.16.bb b/meta-openstack/recipes-devtools/python/python-sqlparse_0.1.16.bb
new file mode 100644
index 0000000..8ea99d7
--- /dev/null
+++ b/meta-openstack/recipes-devtools/python/python-sqlparse_0.1.16.bb
@@ -0,0 +1,27 @@
1DESCRIPTION = "Non-validating SQL parser module"
2HOMEPAGE = "http://pypi.python.org/pypi/sqlparse"
3SECTION = "devel/python"
4LICENSE = "BSD"
5LIC_FILES_CHKSUM = "file://COPYING;md5=13ec2f893997ca1f516b55496e019a81"
6
7SRCNAME = "sqlparse"
8SRC_URI = "http://pypi.python.org/packages/source/s/${SRCNAME}/${SRCNAME}-${PV}.tar.gz"
9
10SRC_URI[md5sum] = "370962a307ebaaa70a28b6b0ccb53980"
11SRC_URI[sha256sum] = "678c6c36ca4b01405177da8b84eecf92ec92c9f6c762396c965bb5d305f20f81"
12
13S = "${WORKDIR}/${SRCNAME}-${PV}"
14
15export BUILD_SYS
16export HOST_SYS
17
18inherit setuptools
19
20# DEPENDS_default: python-pip
21
22DEPENDS += " \
23 "
24
25# RDEPENDS_default:
26RDEPENDS_${PN} += " \
27 "