summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorzhengruoqin <zhengrq.fnst@cn.fujitsu.com>2020-10-20 14:43:47 +0800
committerBruce Ashfield <bruce.ashfield@gmail.com>2020-10-27 23:27:51 -0400
commit5e2cd1dde8c6f5a034e1f34fa93b06a168b3a8af (patch)
tree02c65e8c12271a0fa6c3bef2445c6217ef79b2cd
parent9791cef9fa0104391927ee9616163e657b5a1677 (diff)
downloadmeta-cloud-services-5e2cd1dde8c6f5a034e1f34fa93b06a168b3a8af.tar.gz
python3-tooz: upgrade 1.48.0 -> 2.7.1
Because python2 is no longer maintained, bb file is changed to python3 version. Signed-off-by: Zheng Ruoqin <zhengrq.fnst@cn.fujitsu.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
-rw-r--r--meta-openstack/recipes-devtools/python/python-tooz_1.48.0.bb37
-rw-r--r--meta-openstack/recipes-devtools/python/python3-tooz_2.7.1.bb36
2 files changed, 36 insertions, 37 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-tooz_1.48.0.bb b/meta-openstack/recipes-devtools/python/python-tooz_1.48.0.bb
deleted file mode 100644
index 14f69d1..0000000
--- a/meta-openstack/recipes-devtools/python/python-tooz_1.48.0.bb
+++ /dev/null
@@ -1,37 +0,0 @@
1DESCRIPTION = "Coordination library for distributed systems."
2HOMEPAGE = "https://pypi.python.org/pypi/tooz"
3SECTION = "devel/python"
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=1dece7821bf3fd70fe1309eaa37d52a2"
6
7SRC_URI[md5sum] = "8b39e07002f21c15d2a463b63d8a2952"
8SRC_URI[sha256sum] = "c1b17935207e9c4809feff91b679883928aa5bd3fce75e09b4945c261b513e60"
9
10inherit setuptools3 pypi
11
12# DEPENDS_default: python-pip
13
14DEPENDS += " \
15 python-pip \
16 python-pbr \
17 "
18
19# Satisfy setup.py 'setup_requires'
20DEPENDS += " \
21 python-pbr-native \
22 "
23
24# RDEPENDS_default:
25RDEPENDS_${PN} += " \
26 python-pbr \
27 python-stevedore \
28 python-six \
29 python-voluptuous \
30 python-msgpack \
31 python-fasteners \
32 python-tenacity \
33 python-futures \
34 python-futurist \
35 python-oslo.utils \
36 python-oslo.serialization \
37 "
diff --git a/meta-openstack/recipes-devtools/python/python3-tooz_2.7.1.bb b/meta-openstack/recipes-devtools/python/python3-tooz_2.7.1.bb
new file mode 100644
index 0000000..cc2824c
--- /dev/null
+++ b/meta-openstack/recipes-devtools/python/python3-tooz_2.7.1.bb
@@ -0,0 +1,36 @@
1DESCRIPTION = "Coordination library for distributed systems."
2HOMEPAGE = "https://pypi.python.org/pypi/tooz"
3SECTION = "devel/python"
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=1dece7821bf3fd70fe1309eaa37d52a2"
6
7SRC_URI[md5sum] = "f8afa62d566f602d63050850d4873583"
8SRC_URI[sha256sum] = "bee07684b12e9fb06adbe6b1a5ddb60ef9e8dc20f5a2d46e667d8797028bcfe5"
9
10inherit setuptools3 pypi
11
12# DEPENDS_default: python-pip
13
14DEPENDS += " \
15 python3-pip \
16 python3-pbr \
17 "
18
19# Satisfy setup.py 'setup_requires'
20DEPENDS += " \
21 python3-pbr-native \
22 "
23
24# RDEPENDS_default:
25RDEPENDS_${PN} += " \
26 python3-pbr \
27 python3-stevedore \
28 python3-six \
29 python3-voluptuous \
30 python3-msgpack \
31 python3-fasteners \
32 python3-tenacity \
33 python3-futurist \
34 python3-oslo.utils \
35 python3-oslo.serialization \
36 "