summaryrefslogtreecommitdiffstats
path: root/meta-openstack/recipes-devtools/python/python3-salttesting_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openstack/recipes-devtools/python/python3-salttesting_git.bb')
-rw-r--r--meta-openstack/recipes-devtools/python/python3-salttesting_git.bb20
1 files changed, 20 insertions, 0 deletions
diff --git a/meta-openstack/recipes-devtools/python/python3-salttesting_git.bb b/meta-openstack/recipes-devtools/python/python3-salttesting_git.bb
new file mode 100644
index 0000000..3447621
--- /dev/null
+++ b/meta-openstack/recipes-devtools/python/python3-salttesting_git.bb
@@ -0,0 +1,20 @@
1SUMMARY = "Common testing tools used in the Salt Stack projects"
2HOMEPAGE = "https://github.com/saltstack/salt-testing"
3SECTION = "devel/python"
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=f36f1e9e3e30f90180efdf7e40d943e5"
6
7SRC_URI = "git://github.com/saltstack/salt-testing.git;branch=develop;tag=v2018.9.21 \
8 file://0001-Add-ptest-output-option-to-test-suite.patch \
9 "
10
11PV = "2018.9.21+git${SRCPV}"
12
13S = "${WORKDIR}/git"
14
15RDEPENDS_${PN} = "\
16 python3-mock \
17 python3-unittest \
18"
19
20inherit setuptools3