summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorzhengruoqin <zhengrq.fnst@cn.fujitsu.com>2020-10-27 13:29:03 +0800
committerBruce Ashfield <bruce.ashfield@gmail.com>2020-11-03 16:33:44 -0500
commit42810cb115791be03fba6a5f7e48b2e37e7396e5 (patch)
tree84756ec64aa2d47f42c4fcdde67ff18dc0aad7d9
parent0513ee7ec1b0286e69a84a63185ffd3df1df87fb (diff)
downloadmeta-cloud-services-42810cb115791be03fba6a5f7e48b2e37e7396e5.tar.gz
python3-requestsexceptions: Consolidate in a single file
Consolidate inc and bb files into a single bb file. Signed-off-by: Zheng Ruoqin <zhengrq.fnst@cn.fujitsu.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
-rw-r--r--meta-openstack/recipes-devtools/python/python-requestsexceptions.inc23
-rw-r--r--meta-openstack/recipes-devtools/python/python3-requestsexceptions_1.4.0.bb25
2 files changed, 23 insertions, 25 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-requestsexceptions.inc b/meta-openstack/recipes-devtools/python/python-requestsexceptions.inc
deleted file mode 100644
index bac99a3..0000000
--- a/meta-openstack/recipes-devtools/python/python-requestsexceptions.inc
+++ /dev/null
@@ -1,23 +0,0 @@
1DESCRIPTION = "Import exceptions from potentially bundled packages in requests."
2HOMEPAGE = "https://www.openstack.org/"
3SECTION = "devel/python"
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=d273d63619c9aeaf15cdaf76422c4f87"
6
7SRC_URI[md5sum] = "f43b246ccd7d5b618e6f0dc946a6c3f3"
8SRC_URI[sha256sum] = "b095cbc77618f066d459a02b137b020c37da9f46d9b057704019c9f77dba3065"
9
10inherit pypi
11
12# conflicting file prevention
13do_install_append() {
14 rm -f ${D}${libdir}/python*/site-packages/tests/*
15}
16
17DEPENDS += " \
18 ${PYTHON_PN}-pbr-native \
19 "
20
21RDEPENDS_${PN} += " \
22 ${PYTHON_PN}-pbr \
23 "
diff --git a/meta-openstack/recipes-devtools/python/python3-requestsexceptions_1.4.0.bb b/meta-openstack/recipes-devtools/python/python3-requestsexceptions_1.4.0.bb
index 1c049f3..4bf9c0e 100644
--- a/meta-openstack/recipes-devtools/python/python3-requestsexceptions_1.4.0.bb
+++ b/meta-openstack/recipes-devtools/python/python3-requestsexceptions_1.4.0.bb
@@ -1,2 +1,23 @@
1inherit setuptools3 1DESCRIPTION = "Import exceptions from potentially bundled packages in requests."
2require python-requestsexceptions.inc 2HOMEPAGE = "https://www.openstack.org/"
3SECTION = "devel/python"
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=d273d63619c9aeaf15cdaf76422c4f87"
6
7SRC_URI[md5sum] = "f43b246ccd7d5b618e6f0dc946a6c3f3"
8SRC_URI[sha256sum] = "b095cbc77618f066d459a02b137b020c37da9f46d9b057704019c9f77dba3065"
9
10inherit setuptools3 pypi
11
12# conflicting file prevention
13do_install_append() {
14 rm -f ${D}${libdir}/python*/site-packages/tests/*
15}
16
17DEPENDS += " \
18 ${PYTHON_PN}-pbr-native \
19 "
20
21RDEPENDS_${PN} += " \
22 ${PYTHON_PN}-pbr \
23 "