summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorzhengruoqin <zhengrq.fnst@cn.fujitsu.com>2020-10-27 13:29:56 +0800
committerBruce Ashfield <bruce.ashfield@gmail.com>2020-11-03 16:33:44 -0500
commit0513ee7ec1b0286e69a84a63185ffd3df1df87fb (patch)
tree655ae708f11a15fd78a05b1d2f078381bac9363f
parentf5578cf12b0939e5ad98afe9a921e04d1fbc4206 (diff)
downloadmeta-cloud-services-0513ee7ec1b0286e69a84a63185ffd3df1df87fb.tar.gz
python3-retrying: Consolidate in a single file
Consolidate inc and bb files into a single bb file. Signed-off-by: Zheng Ruoqin <zhengrq.fnst@cn.fujitsu.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
-rw-r--r--meta-openstack/recipes-devtools/python/python-retrying.inc20
-rw-r--r--meta-openstack/recipes-devtools/python/python3-retrying_1.3.3.bb22
2 files changed, 20 insertions, 22 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-retrying.inc b/meta-openstack/recipes-devtools/python/python-retrying.inc
deleted file mode 100644
index b33dc90..0000000
--- a/meta-openstack/recipes-devtools/python/python-retrying.inc
+++ /dev/null
@@ -1,20 +0,0 @@
1DESCRIPTION = "Retrying"
2HOMEPAGE = "https://github.com/rholder/retrying"
3SECTION = "devel/python"
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=175792518e4ac015ab6696d16c4f607e"
6
7SRC_URI[md5sum] = "2a126aeef8b21324ecdeac15ff46ef17"
8SRC_URI[sha256sum] = "08c039560a6da2fe4f2c426d0766e284d3b736e355f8dd24b37367b0bb41973b"
9
10inherit pypi
11
12# DEPENDS_default: python-pip
13
14DEPENDS += " \
15 ${PYTHON_PN}-pip \
16 "
17
18# RDEPENDS_default:
19RDEPENDS_${PN} += " \
20 "
diff --git a/meta-openstack/recipes-devtools/python/python3-retrying_1.3.3.bb b/meta-openstack/recipes-devtools/python/python3-retrying_1.3.3.bb
index 9f001fe..e599670 100644
--- a/meta-openstack/recipes-devtools/python/python3-retrying_1.3.3.bb
+++ b/meta-openstack/recipes-devtools/python/python3-retrying_1.3.3.bb
@@ -1,2 +1,20 @@
1require python-retrying.inc 1DESCRIPTION = "Retrying"
2inherit setuptools3 2HOMEPAGE = "https://github.com/rholder/retrying"
3SECTION = "devel/python"
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=175792518e4ac015ab6696d16c4f607e"
6
7SRC_URI[md5sum] = "2a126aeef8b21324ecdeac15ff46ef17"
8SRC_URI[sha256sum] = "08c039560a6da2fe4f2c426d0766e284d3b736e355f8dd24b37367b0bb41973b"
9
10inherit setuptools3 pypi
11
12# DEPENDS_default: python-pip
13
14DEPENDS += " \
15 ${PYTHON_PN}-pip \
16 "
17
18# RDEPENDS_default:
19RDEPENDS_${PN} += " \
20 "