summaryrefslogtreecommitdiffstats
path: root/meta-openstack/recipes-devtools/python/python3-pypowervm_1.1.24.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openstack/recipes-devtools/python/python3-pypowervm_1.1.24.bb')
-rw-r--r--meta-openstack/recipes-devtools/python/python3-pypowervm_1.1.24.bb32
1 files changed, 32 insertions, 0 deletions
diff --git a/meta-openstack/recipes-devtools/python/python3-pypowervm_1.1.24.bb b/meta-openstack/recipes-devtools/python/python3-pypowervm_1.1.24.bb
new file mode 100644
index 0000000..e659f61
--- /dev/null
+++ b/meta-openstack/recipes-devtools/python/python3-pypowervm_1.1.24.bb
@@ -0,0 +1,32 @@
1DESCRIPTION = "Python binding for the PowerVM REST API"
2HOMEPAGE = "https://pypi.python.org/pypi/pypowervm"
3SECTION = "devel/python"
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=1dece7821bf3fd70fe1309eaa37d52a2"
6
7SRC_URI[md5sum] = "50b580055e5628aadaeb42fd69158ff8"
8SRC_URI[sha256sum] = "4c6bf225d2b1022b5d363f9b3695fd1692523235d3ce1b5b4506fbc608bdb535"
9
10inherit setuptools3 pypi
11
12# Satisfy setup.py 'setup_requires'
13DEPENDS += " \
14 python3-pbr-native \
15 "
16
17RDEPENDS_${PN} += " \
18 python3-lxml \
19 python3-oslo.concurrency \
20 python3-oslo.context \
21 python3-oslo.i18n \
22 python3-oslo.log \
23 python3-oslo.utils \
24 python3-pbr \
25 python3-pyasn1-modules \
26 python3-pyasn1 \
27 python3-pytz \
28 python3-requests \
29 python3-six \
30 python3-taskflow \
31 python3-networkx \
32 "