summaryrefslogtreecommitdiffstats
path: root/recipes-devtools/clang/libcxx_git.bb
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2021-05-26 11:37:31 -0700
committerKhem Raj <raj.khem@gmail.com>2021-06-08 11:37:54 -0700
commita0a318157ca0555b0d6e20028dcb7e3e3f3c08c6 (patch)
tree45373e29576475f3f30223519737f7dea25d7130 /recipes-devtools/clang/libcxx_git.bb
parentf4bb299c409128801e68c30187381fadeb0a451d (diff)
downloadmeta-clang-a0a318157ca0555b0d6e20028dcb7e3e3f3c08c6.tar.gz
libcxx: Build undwinder when RUNTIME = "llvm"
ensure that libcxx can be built when RUNTIME = "llvm" as it might need to pass some cmake compiler tests Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'recipes-devtools/clang/libcxx_git.bb')
-rw-r--r--recipes-devtools/clang/libcxx_git.bb6
1 files changed, 5 insertions, 1 deletions
diff --git a/recipes-devtools/clang/libcxx_git.bb b/recipes-devtools/clang/libcxx_git.bb
index 38e3555..dd87f1d 100644
--- a/recipes-devtools/clang/libcxx_git.bb
+++ b/recipes-devtools/clang/libcxx_git.bb
@@ -8,7 +8,7 @@ SECTION = "base"
8require clang.inc 8require clang.inc
9require common-source.inc 9require common-source.inc
10 10
11inherit cmake python3native 11inherit cmake cmake-native python3native
12 12
13PACKAGECONFIG ??= "compiler-rt exceptions ${@bb.utils.contains("RUNTIME", "llvm", "unwind unwind-shared", "", d)}" 13PACKAGECONFIG ??= "compiler-rt exceptions ${@bb.utils.contains("RUNTIME", "llvm", "unwind unwind-shared", "", d)}"
14PACKAGECONFIG_append_armv5 = " no-atomics" 14PACKAGECONFIG_append_armv5 = " no-atomics"
@@ -25,6 +25,8 @@ DEPENDS_append_class-target = " clang-cross-${TARGET_ARCH} virtual/${MLPREFIX}li
25LIBCPLUSPLUS = "" 25LIBCPLUSPLUS = ""
26COMPILER_RT ?= "-rtlib=compiler-rt" 26COMPILER_RT ?= "-rtlib=compiler-rt"
27 27
28CXXFLAGS += "-stdlib=libstdc++"
29LDFLAGS += "-unwindlib=libgcc -stdlib=libstdc++"
28INHIBIT_DEFAULT_DEPS = "1" 30INHIBIT_DEFAULT_DEPS = "1"
29 31
30LIC_FILES_CHKSUM = "file://libcxx/LICENSE.TXT;md5=55d89dd7eec8d3b4204b680e27da3953 \ 32LIC_FILES_CHKSUM = "file://libcxx/LICENSE.TXT;md5=55d89dd7eec8d3b4204b680e27da3953 \
@@ -66,5 +68,7 @@ CXXFLAGS_append_armv5 = " -mfpu=vfp2"
66 68
67ALLOW_EMPTY_${PN} = "1" 69ALLOW_EMPTY_${PN} = "1"
68 70
71PROVIDES += "${@bb.utils.contains("RUNTIME", "llvm", "libunwind", "", d)}"
72
69BBCLASSEXTEND = "native nativesdk" 73BBCLASSEXTEND = "native nativesdk"
70TOOLCHAIN = "clang" 74TOOLCHAIN = "clang"