summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-devtools/clang/libcxx_git.bb6
1 files changed, 5 insertions, 1 deletions
diff --git a/recipes-devtools/clang/libcxx_git.bb b/recipes-devtools/clang/libcxx_git.bb
index 38e3555..dd87f1d 100644
--- a/recipes-devtools/clang/libcxx_git.bb
+++ b/recipes-devtools/clang/libcxx_git.bb
@@ -8,7 +8,7 @@ SECTION = "base"
8require clang.inc 8require clang.inc
9require common-source.inc 9require common-source.inc
10 10
11inherit cmake python3native 11inherit cmake cmake-native python3native
12 12
13PACKAGECONFIG ??= "compiler-rt exceptions ${@bb.utils.contains("RUNTIME", "llvm", "unwind unwind-shared", "", d)}" 13PACKAGECONFIG ??= "compiler-rt exceptions ${@bb.utils.contains("RUNTIME", "llvm", "unwind unwind-shared", "", d)}"
14PACKAGECONFIG_append_armv5 = " no-atomics" 14PACKAGECONFIG_append_armv5 = " no-atomics"
@@ -25,6 +25,8 @@ DEPENDS_append_class-target = " clang-cross-${TARGET_ARCH} virtual/${MLPREFIX}li
25LIBCPLUSPLUS = "" 25LIBCPLUSPLUS = ""
26COMPILER_RT ?= "-rtlib=compiler-rt" 26COMPILER_RT ?= "-rtlib=compiler-rt"
27 27
28CXXFLAGS += "-stdlib=libstdc++"
29LDFLAGS += "-unwindlib=libgcc -stdlib=libstdc++"
28INHIBIT_DEFAULT_DEPS = "1" 30INHIBIT_DEFAULT_DEPS = "1"
29 31
30LIC_FILES_CHKSUM = "file://libcxx/LICENSE.TXT;md5=55d89dd7eec8d3b4204b680e27da3953 \ 32LIC_FILES_CHKSUM = "file://libcxx/LICENSE.TXT;md5=55d89dd7eec8d3b4204b680e27da3953 \
@@ -66,5 +68,7 @@ CXXFLAGS_append_armv5 = " -mfpu=vfp2"
66 68
67ALLOW_EMPTY_${PN} = "1" 69ALLOW_EMPTY_${PN} = "1"
68 70
71PROVIDES += "${@bb.utils.contains("RUNTIME", "llvm", "libunwind", "", d)}"
72
69BBCLASSEXTEND = "native nativesdk" 73BBCLASSEXTEND = "native nativesdk"
70TOOLCHAIN = "clang" 74TOOLCHAIN = "clang"