summaryrefslogtreecommitdiffstats
path: root/dynamic-layers
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2024-01-21 12:25:50 -0800
committerKhem Raj <raj.khem@gmail.com>2024-01-23 12:50:35 -0800
commite18cec09b30a3946a1b1c590d4bf1fe5080d7087 (patch)
tree88f06ffbd481830afb31c688ba9aaa227cc11782 /dynamic-layers
parent1aadfcc64ead4eb00484ab9477c82d21773f2aab (diff)
downloadmeta-clang-e18cec09b30a3946a1b1c590d4bf1fe5080d7087.tar.gz
bcc: Upgrade to 0.29.1
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'dynamic-layers')
-rw-r--r--dynamic-layers/meta-python/recipes-devtools/bcc/bcc/0001-CMakeLists.txt-override-the-PY_CMD_ESCAPED.patch8
-rw-r--r--dynamic-layers/meta-python/recipes-devtools/bcc/bcc/0001-python-CMakeLists.txt-Remove-check-for-host-etc-debi.patch35
-rw-r--r--dynamic-layers/meta-python/recipes-devtools/bcc/bcc/0001-tools-trace.py-Fix-failing-to-exit.patch41
-rw-r--r--dynamic-layers/meta-python/recipes-devtools/bcc/bcc_0.29.1.bb (renamed from dynamic-layers/meta-python/recipes-devtools/bcc/bcc_0.28.0.bb)7
4 files changed, 6 insertions, 85 deletions
diff --git a/dynamic-layers/meta-python/recipes-devtools/bcc/bcc/0001-CMakeLists.txt-override-the-PY_CMD_ESCAPED.patch b/dynamic-layers/meta-python/recipes-devtools/bcc/bcc/0001-CMakeLists.txt-override-the-PY_CMD_ESCAPED.patch
index 3e0a6aa..1f9c41d 100644
--- a/dynamic-layers/meta-python/recipes-devtools/bcc/bcc/0001-CMakeLists.txt-override-the-PY_CMD_ESCAPED.patch
+++ b/dynamic-layers/meta-python/recipes-devtools/bcc/bcc/0001-CMakeLists.txt-override-the-PY_CMD_ESCAPED.patch
@@ -21,7 +21,7 @@ Signed-off-by: Mingli Yu <mingli.yu@windriver.com>
21 21
22--- a/src/python/CMakeLists.txt 22--- a/src/python/CMakeLists.txt
23+++ b/src/python/CMakeLists.txt 23+++ b/src/python/CMakeLists.txt
24@@ -12,7 +12,7 @@ file(GLOB_RECURSE PYTHON_INCLUDES RELATI 24@@ -16,7 +16,7 @@ file(GLOB_RECURSE PYTHON_INCLUDES RELATI
25 25
26 foreach(PY_CMD ${PYTHON_CMD}) 26 foreach(PY_CMD ${PYTHON_CMD})
27 string(REPLACE "/" "-" PY_CMD_ESCAPED ${PY_CMD}) 27 string(REPLACE "/" "-" PY_CMD_ESCAPED ${PY_CMD})
@@ -30,12 +30,12 @@ Signed-off-by: Mingli Yu <mingli.yu@windriver.com>
30 30
31 foreach(PY_SRC ${PYTHON_SOURCES}) 31 foreach(PY_SRC ${PYTHON_SOURCES})
32 configure_file(${PY_SRC} ${PY_DIRECTORY}/${PY_SRC} COPYONLY) 32 configure_file(${PY_SRC} ${PY_DIRECTORY}/${PY_SRC} COPYONLY)
33@@ -31,7 +31,7 @@ foreach(PY_CMD ${PYTHON_CMD}) 33@@ -35,7 +35,7 @@ foreach(PY_CMD ${PYTHON_CMD})
34 DEPENDS ${PYTHON_SOURCES} ${PYTHON_INCLUDES} 34 DEPENDS ${PYTHON_SOURCES} ${PYTHON_INCLUDES}
35 COMMENT "Building sdist for ${PY_CMD}" 35 COMMENT "Building sdist for ${PY_CMD}"
36 ) 36 )
37- add_custom_target(bcc_py_${PY_CMD_ESCAPED} ALL DEPENDS ${PIP_INSTALLABLE}) 37- add_custom_target(bcc_py_${PY_CMD_ESCAPED} ALL DEPENDS ${PIP_INSTALLABLE})
38+ add_custom_target(bcc_py_python3 ALL DEPENDS ${PIP_INSTALLABLE}) 38+ add_custom_target(bcc_py_python3 ALL DEPENDS ${PIP_INSTALLABLE})
39 39
40 install( 40 if(NOT PYTHON_PREFIX)
41 CODE " 41 set(PYTHON_PREFIX ${CMAKE_INSTALL_PREFIX})
diff --git a/dynamic-layers/meta-python/recipes-devtools/bcc/bcc/0001-python-CMakeLists.txt-Remove-check-for-host-etc-debi.patch b/dynamic-layers/meta-python/recipes-devtools/bcc/bcc/0001-python-CMakeLists.txt-Remove-check-for-host-etc-debi.patch
deleted file mode 100644
index 3ca7fdd..0000000
--- a/dynamic-layers/meta-python/recipes-devtools/bcc/bcc/0001-python-CMakeLists.txt-Remove-check-for-host-etc-debi.patch
+++ /dev/null
@@ -1,35 +0,0 @@
1From cb3f032b55b32c50201862b26c76ea18ad37cb39 Mon Sep 17 00:00:00 2001
2From: Ovidiu Panait <ovidiu.panait@windriver.com>
3Date: Thu, 30 Jan 2020 14:19:33 +0200
4Subject: [PATCH] python/CMakeLists.txt: Remove check for host
5 /etc/debian_version
6
7Fix the following error that occurs during do_install when using the native
8version of python3:
9usage: setup.py [global_opts] cmd1 [cmd1_opts] [cmd2 [cmd2_opts] ...]
10 or: setup.py --help [cmd1 cmd2 ...]
11 or: setup.py --help-commands
12 or: setup.py cmd --help
13
14error: option --install-layout not recognized
15
16Upstream-Status: Inappropriate [oe-specific]
17
18Signed-off-by: Ovidiu Panait <ovidiu.panait@windriver.com>
19---
20 src/python/CMakeLists.txt | 4 ----
21 1 file changed, 4 deletions(-)
22
23--- a/src/python/CMakeLists.txt
24+++ b/src/python/CMakeLists.txt
25@@ -5,10 +5,6 @@ if(NOT PYTHON_CMD)
26 set(PYTHON_CMD "python3")
27 endif()
28
29-if(EXISTS "/etc/debian_version")
30- set(PYTHON_FLAGS "${PYTHON_FLAGS} --install-layout deb")
31-endif()
32-
33 file(GLOB_RECURSE PYTHON_SOURCES RELATIVE ${CMAKE_CURRENT_SOURCE_DIR}
34 ${CMAKE_CURRENT_SOURCE_DIR}/*.py)
35 file(GLOB_RECURSE PYTHON_INCLUDES RELATIVE ${CMAKE_CURRENT_SOURCE_DIR}
diff --git a/dynamic-layers/meta-python/recipes-devtools/bcc/bcc/0001-tools-trace.py-Fix-failing-to-exit.patch b/dynamic-layers/meta-python/recipes-devtools/bcc/bcc/0001-tools-trace.py-Fix-failing-to-exit.patch
deleted file mode 100644
index 6ac7219..0000000
--- a/dynamic-layers/meta-python/recipes-devtools/bcc/bcc/0001-tools-trace.py-Fix-failing-to-exit.patch
+++ /dev/null
@@ -1,41 +0,0 @@
1From a9f59fc8605de1bcca0b6c2d8132585f40c3b9bc Mon Sep 17 00:00:00 2001
2From: He Zhe <zhe.he@windriver.com>
3Date: Thu, 13 Aug 2020 11:25:58 +0800
4Subject: [PATCH] tools/trace.py: Fix failing to exit
5
6Class Probe::print_event is used as a callback of a ctypes wrapper. With
7Yocto latest python v3.8.5, the exception raised by exit() is ignored and
8thus trace cannot exit. Use os._exit(0) instead.
9
10$ /usr/share/bcc/tools/trace do_sys_open -M 1
11PID TID COMM FUNC
123740 3740 irqbalance do_sys_open
13Exception ignored on calling ctypes callback function:
14<function PerfEventArray.open_perf_buffer.<locals>.raw_cb at 0x7f7c9efea280>
15Traceback (most recent call last):
16File "/usr/lib64/python3.8/site-packages/bcc/table.py", line 685, in raw_cb_
17callback(cpu, data, size)
18File "/usr/share/bcc/tools/trace", line 630, in print_event
19exit()
20File "/usr/lib64/python3.8/sitebuiltins.py", line 26, in __call_
21raise SystemExit(code)
22SystemExit: None
23
24Upstream-Status: Pending
25
26Signed-off-by: He Zhe <zhe.he@windriver.com>
27---
28 tools/trace.py | 2 +-
29 1 file changed, 1 insertion(+), 1 deletion(-)
30
31--- a/tools/trace.py
32+++ b/tools/trace.py
33@@ -671,7 +671,7 @@ BPF_PERF_OUTPUT(%s);
34 if self.aggregate:
35 self.print_aggregate_events()
36 sys.stdout.flush()
37- exit()
38+ os._exit(0)
39
40 def attach(self, bpf, verbose):
41 if len(self.library) == 0:
diff --git a/dynamic-layers/meta-python/recipes-devtools/bcc/bcc_0.28.0.bb b/dynamic-layers/meta-python/recipes-devtools/bcc/bcc_0.29.1.bb
index 5625e47..6690d82 100644
--- a/dynamic-layers/meta-python/recipes-devtools/bcc/bcc_0.28.0.bb
+++ b/dynamic-layers/meta-python/recipes-devtools/bcc/bcc_0.29.1.bb
@@ -25,8 +25,6 @@ RDEPENDS:${PN} += "bash python3 python3-core python3-setuptools xz"
25RDEPENDS:${PN}-ptest = "cmake python3 python3-netaddr python3-pyroute2" 25RDEPENDS:${PN}-ptest = "cmake python3 python3-netaddr python3-pyroute2"
26 26
27SRC_URI = "gitsm://github.com/iovisor/bcc;branch=master;protocol=https \ 27SRC_URI = "gitsm://github.com/iovisor/bcc;branch=master;protocol=https \
28 file://0001-python-CMakeLists.txt-Remove-check-for-host-etc-debi.patch \
29 file://0001-tools-trace.py-Fix-failing-to-exit.patch \
30 file://0001-CMakeLists.txt-override-the-PY_CMD_ESCAPED.patch \ 28 file://0001-CMakeLists.txt-override-the-PY_CMD_ESCAPED.patch \
31 file://0001-Vendor-just-enough-extra-headers-to-allow-libbpf-to-.patch \ 29 file://0001-Vendor-just-enough-extra-headers-to-allow-libbpf-to-.patch \
32 file://0001-tests-cc-Use-c-14-standard.patch \ 30 file://0001-tests-cc-Use-c-14-standard.patch \
@@ -35,9 +33,7 @@ SRC_URI = "gitsm://github.com/iovisor/bcc;branch=master;protocol=https \
35 file://ptest_wrapper.sh \ 33 file://ptest_wrapper.sh \
36 " 34 "
37 35
38SRCREV = "8422cd449ad2e60414a4508aa4a150a9db39c4a3" 36SRCREV = "eb8ede2d70b17350757f2570ef76ea4c2e1dbff8"
39
40PV .= "+git${SRCPV}"
41 37
42S = "${WORKDIR}/git" 38S = "${WORKDIR}/git"
43 39
@@ -51,6 +47,7 @@ EXTRA_OECMAKE = " \
51 -DCMAKE_USE_LIBBPF_PACKAGE=ON \ 47 -DCMAKE_USE_LIBBPF_PACKAGE=ON \
52 -DENABLE_LLVM_SHARED=ON \ 48 -DENABLE_LLVM_SHARED=ON \
53 -DENABLE_CLANG_JIT=ON \ 49 -DENABLE_CLANG_JIT=ON \
50 -DPY_SKIP_DEB_LAYOUT=ON \
54 -DLLVM_PACKAGE_VERSION=${LLVMVERSION} \ 51 -DLLVM_PACKAGE_VERSION=${LLVMVERSION} \
55 -DPYTHON_CMD=${PYTHON} \ 52 -DPYTHON_CMD=${PYTHON} \
56 -DPYTHON_FLAGS=--install-lib=${PYTHON_SITEPACKAGES_DIR} \ 53 -DPYTHON_FLAGS=--install-lib=${PYTHON_SITEPACKAGES_DIR} \