summaryrefslogtreecommitdiffstats
path: root/dynamic-layers/meta-python/recipes-devtools/bcc/bcc/0001-python-CMakeLists.txt-Remove-check-for-host-etc-debi.patch
diff options
context:
space:
mode:
Diffstat (limited to 'dynamic-layers/meta-python/recipes-devtools/bcc/bcc/0001-python-CMakeLists.txt-Remove-check-for-host-etc-debi.patch')
-rw-r--r--dynamic-layers/meta-python/recipes-devtools/bcc/bcc/0001-python-CMakeLists.txt-Remove-check-for-host-etc-debi.patch35
1 files changed, 0 insertions, 35 deletions
diff --git a/dynamic-layers/meta-python/recipes-devtools/bcc/bcc/0001-python-CMakeLists.txt-Remove-check-for-host-etc-debi.patch b/dynamic-layers/meta-python/recipes-devtools/bcc/bcc/0001-python-CMakeLists.txt-Remove-check-for-host-etc-debi.patch
deleted file mode 100644
index 3ca7fdd..0000000
--- a/dynamic-layers/meta-python/recipes-devtools/bcc/bcc/0001-python-CMakeLists.txt-Remove-check-for-host-etc-debi.patch
+++ /dev/null
@@ -1,35 +0,0 @@
1From cb3f032b55b32c50201862b26c76ea18ad37cb39 Mon Sep 17 00:00:00 2001
2From: Ovidiu Panait <ovidiu.panait@windriver.com>
3Date: Thu, 30 Jan 2020 14:19:33 +0200
4Subject: [PATCH] python/CMakeLists.txt: Remove check for host
5 /etc/debian_version
6
7Fix the following error that occurs during do_install when using the native
8version of python3:
9usage: setup.py [global_opts] cmd1 [cmd1_opts] [cmd2 [cmd2_opts] ...]
10 or: setup.py --help [cmd1 cmd2 ...]
11 or: setup.py --help-commands
12 or: setup.py cmd --help
13
14error: option --install-layout not recognized
15
16Upstream-Status: Inappropriate [oe-specific]
17
18Signed-off-by: Ovidiu Panait <ovidiu.panait@windriver.com>
19---
20 src/python/CMakeLists.txt | 4 ----
21 1 file changed, 4 deletions(-)
22
23--- a/src/python/CMakeLists.txt
24+++ b/src/python/CMakeLists.txt
25@@ -5,10 +5,6 @@ if(NOT PYTHON_CMD)
26 set(PYTHON_CMD "python3")
27 endif()
28
29-if(EXISTS "/etc/debian_version")
30- set(PYTHON_FLAGS "${PYTHON_FLAGS} --install-layout deb")
31-endif()
32-
33 file(GLOB_RECURSE PYTHON_SOURCES RELATIVE ${CMAKE_CURRENT_SOURCE_DIR}
34 ${CMAKE_CURRENT_SOURCE_DIR}/*.py)
35 file(GLOB_RECURSE PYTHON_INCLUDES RELATIVE ${CMAKE_CURRENT_SOURCE_DIR}