summaryrefslogtreecommitdiffstats
path: root/dynamic-layers/openembedded-layer/recipes-devtools/bcc/bcc_0.24.0.bb
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2022-02-04 09:10:30 -0800
committerKhem Raj <raj.khem@gmail.com>2022-02-16 08:24:58 -0800
commit73cfe6b02642296de161235ae98e7252b60a6e0e (patch)
treebd53886bf20a6e705281d03c75477bcb879dbab1 /dynamic-layers/openembedded-layer/recipes-devtools/bcc/bcc_0.24.0.bb
parent6b79646f85f3293e0fbedf07592a94860d659053 (diff)
downloadmeta-clang-73cfe6b02642296de161235ae98e7252b60a6e0e.tar.gz
bcc: Upgrade to 0.24.0
Drop upstreamed patch 0001-Remove-APInt-APSInt-toString-std-string-variants.patch Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'dynamic-layers/openembedded-layer/recipes-devtools/bcc/bcc_0.24.0.bb')
-rw-r--r--dynamic-layers/openembedded-layer/recipes-devtools/bcc/bcc_0.24.0.bb56
1 files changed, 56 insertions, 0 deletions
diff --git a/dynamic-layers/openembedded-layer/recipes-devtools/bcc/bcc_0.24.0.bb b/dynamic-layers/openembedded-layer/recipes-devtools/bcc/bcc_0.24.0.bb
new file mode 100644
index 0000000..65831c3
--- /dev/null
+++ b/dynamic-layers/openembedded-layer/recipes-devtools/bcc/bcc_0.24.0.bb
@@ -0,0 +1,56 @@
1SUMMARY = "BPF Compiler Collection (BCC)"
2HOMEPAGE = "https://github.com/iovisor/bcc"
3LICENSE = "Apache-2.0"
4LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=e3fc50a88d0a364313df4b21ef20c29e"
5
6inherit cmake python3native manpages
7
8DEPENDS += "bison-native \
9 flex-native \
10 flex \
11 elfutils \
12 ${LUAJIT} \
13 clang \
14 "
15
16LUAJIT ?= "luajit"
17LUAJIT:powerpc64le = ""
18LUAJIT:powerpc64 = ""
19
20RDEPENDS:${PN} += "bash python3 python3-core python3-setuptools xz"
21
22SRC_URI = "gitsm://github.com/iovisor/bcc;branch=master;protocol=https \
23 file://0001-python-CMakeLists.txt-Remove-check-for-host-etc-debi.patch \
24 file://0001-tools-trace.py-Fix-failing-to-exit.patch \
25 file://0001-CMakeLists.txt-override-the-PY_CMD_ESCAPED.patch \
26 "
27
28SRCREV = "8f40d6f57a8d94e7aee74ce358572d34d31b4ed4"
29
30PV .= "+git${SRCPV}"
31
32S = "${WORKDIR}/git"
33
34PACKAGECONFIG ??= "examples"
35PACKAGECONFIG:remove:libc-musl = "examples"
36
37PACKAGECONFIG[manpages] = "-DENABLE_MAN=ON,-DENABLE_MAN=OFF,"
38PACKAGECONFIG[examples] = "-DENABLE_EXAMPLES=ON,-DENABLE_EXAMPLES=OFF,"
39
40EXTRA_OECMAKE = " \
41 -DENABLE_LLVM_SHARED=ON \
42 -DENABLE_CLANG_JIT=ON \
43 -DLLVM_PACKAGE_VERSION=${LLVMVERSION} \
44 -DPYTHON_CMD=${PYTHON} \
45 -DPYTHON_FLAGS=--install-lib=${PYTHON_SITEPACKAGES_DIR} \
46"
47
48do_install:append() {
49 sed -e 's@#!/usr/bin/python@#!/usr/bin/env python3@g' \
50 -i $(find ${D}${datadir}/${PN} -type f)
51}
52
53FILES:${PN} += "${PYTHON_SITEPACKAGES_DIR}"
54FILES:${PN}-doc += "${datadir}/${PN}/man"
55
56COMPATIBLE_HOST = "(x86_64.*|aarch64.*|powerpc64.*)-linux"