summaryrefslogtreecommitdiffstats
path: root/dynamic-layers
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2022-02-04 09:10:30 -0800
committerKhem Raj <raj.khem@gmail.com>2022-02-16 08:24:58 -0800
commit73cfe6b02642296de161235ae98e7252b60a6e0e (patch)
treebd53886bf20a6e705281d03c75477bcb879dbab1 /dynamic-layers
parent6b79646f85f3293e0fbedf07592a94860d659053 (diff)
downloadmeta-clang-73cfe6b02642296de161235ae98e7252b60a6e0e.tar.gz
bcc: Upgrade to 0.24.0
Drop upstreamed patch 0001-Remove-APInt-APSInt-toString-std-string-variants.patch Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'dynamic-layers')
-rw-r--r--dynamic-layers/openembedded-layer/recipes-devtools/bcc/bcc/0001-CMakeLists.txt-override-the-PY_CMD_ESCAPED.patch7
-rw-r--r--dynamic-layers/openembedded-layer/recipes-devtools/bcc/bcc/0001-Remove-APInt-APSInt-toString-std-string-variants.patch42
-rw-r--r--dynamic-layers/openembedded-layer/recipes-devtools/bcc/bcc/0001-python-CMakeLists.txt-Remove-check-for-host-etc-debi.patch7
-rw-r--r--dynamic-layers/openembedded-layer/recipes-devtools/bcc/bcc/0001-tools-trace.py-Fix-failing-to-exit.patch19
-rw-r--r--dynamic-layers/openembedded-layer/recipes-devtools/bcc/bcc_0.24.0.bb (renamed from dynamic-layers/openembedded-layer/recipes-devtools/bcc/bcc_0.20.0.bb)3
5 files changed, 10 insertions, 68 deletions
diff --git a/dynamic-layers/openembedded-layer/recipes-devtools/bcc/bcc/0001-CMakeLists.txt-override-the-PY_CMD_ESCAPED.patch b/dynamic-layers/openembedded-layer/recipes-devtools/bcc/bcc/0001-CMakeLists.txt-override-the-PY_CMD_ESCAPED.patch
index a08c109..3e0a6aa 100644
--- a/dynamic-layers/openembedded-layer/recipes-devtools/bcc/bcc/0001-CMakeLists.txt-override-the-PY_CMD_ESCAPED.patch
+++ b/dynamic-layers/openembedded-layer/recipes-devtools/bcc/bcc/0001-CMakeLists.txt-override-the-PY_CMD_ESCAPED.patch
@@ -19,11 +19,9 @@ Signed-off-by: Mingli Yu <mingli.yu@windriver.com>
19 src/python/CMakeLists.txt | 4 ++-- 19 src/python/CMakeLists.txt | 4 ++--
20 1 file changed, 2 insertions(+), 2 deletions(-) 20 1 file changed, 2 insertions(+), 2 deletions(-)
21 21
22diff --git a/src/python/CMakeLists.txt b/src/python/CMakeLists.txt
23index 797e0d14..8afa6ffa 100644
24--- a/src/python/CMakeLists.txt 22--- a/src/python/CMakeLists.txt
25+++ b/src/python/CMakeLists.txt 23+++ b/src/python/CMakeLists.txt
26@@ -12,7 +12,7 @@ file(GLOB_RECURSE PYTHON_INCLUDES RELATIVE ${CMAKE_CURRENT_SOURCE_DIR} 24@@ -12,7 +12,7 @@ file(GLOB_RECURSE PYTHON_INCLUDES RELATI
27 25
28 foreach(PY_CMD ${PYTHON_CMD}) 26 foreach(PY_CMD ${PYTHON_CMD})
29 string(REPLACE "/" "-" PY_CMD_ESCAPED ${PY_CMD}) 27 string(REPLACE "/" "-" PY_CMD_ESCAPED ${PY_CMD})
@@ -41,6 +39,3 @@ index 797e0d14..8afa6ffa 100644
41 39
42 install( 40 install(
43 CODE " 41 CODE "
44--
452.26.2
46
diff --git a/dynamic-layers/openembedded-layer/recipes-devtools/bcc/bcc/0001-Remove-APInt-APSInt-toString-std-string-variants.patch b/dynamic-layers/openembedded-layer/recipes-devtools/bcc/bcc/0001-Remove-APInt-APSInt-toString-std-string-variants.patch
deleted file mode 100644
index c41e2e2..0000000
--- a/dynamic-layers/openembedded-layer/recipes-devtools/bcc/bcc/0001-Remove-APInt-APSInt-toString-std-string-variants.patch
+++ /dev/null
@@ -1,42 +0,0 @@
1From 3a402d393a02cca4ccbf46e1c9eadb31e33d9753 Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Mon, 14 Jun 2021 12:49:43 -0700
4Subject: [PATCH] Remove APInt/APSInt toString() std::string variants
5
6clang 13+ has removed this in favour of a pair of llvm::toString
7() helpers inside StringExtras.h to improve compile speed by avoiding
8hits on <string> header
9
10Upstream-Status: Submitted [https://github.com/iovisor/bcc/pull/3488]
11Signed-off-by: Khem Raj <raj.khem@gmail.com>
12---
13 src/cc/json_map_decl_visitor.cc | 5 +++++
14 1 file changed, 5 insertions(+)
15
16diff --git a/src/cc/json_map_decl_visitor.cc b/src/cc/json_map_decl_visitor.cc
17index eff4d067..53896199 100644
18--- a/src/cc/json_map_decl_visitor.cc
19+++ b/src/cc/json_map_decl_visitor.cc
20@@ -20,6 +20,7 @@
21 #include <clang/AST/ASTContext.h>
22 #include <clang/AST/RecordLayout.h>
23 #include <clang/AST/RecursiveASTVisitor.h>
24+#include <llvm/ADT/StringExtras.h>
25 #include "common.h"
26 #include "table_desc.h"
27
28@@ -79,7 +80,11 @@ void BMapDeclVisitor::genJSONForField(FieldDecl *F) {
29 result_ += "[";
30 TraverseDecl(F);
31 if (const ConstantArrayType *T = dyn_cast<ConstantArrayType>(F->getType()))
32+#if LLVM_MAJOR_VERSION >= 13
33+ result_ += ", [" + toString(T->getSize(), 10, false) + "]";
34+#else
35 result_ += ", [" + T->getSize().toString(10, false) + "]";
36+#endif
37 if (F->isBitField())
38 result_ += ", " + to_string(F->getBitWidthValue(C));
39 result_ += "], ";
40--
412.32.0
42
diff --git a/dynamic-layers/openembedded-layer/recipes-devtools/bcc/bcc/0001-python-CMakeLists.txt-Remove-check-for-host-etc-debi.patch b/dynamic-layers/openembedded-layer/recipes-devtools/bcc/bcc/0001-python-CMakeLists.txt-Remove-check-for-host-etc-debi.patch
index 4d71b15..4d5ceda 100644
--- a/dynamic-layers/openembedded-layer/recipes-devtools/bcc/bcc/0001-python-CMakeLists.txt-Remove-check-for-host-etc-debi.patch
+++ b/dynamic-layers/openembedded-layer/recipes-devtools/bcc/bcc/0001-python-CMakeLists.txt-Remove-check-for-host-etc-debi.patch
@@ -20,12 +20,10 @@ Signed-off-by: Ovidiu Panait <ovidiu.panait@windriver.com>
20 src/python/CMakeLists.txt | 4 ---- 20 src/python/CMakeLists.txt | 4 ----
21 1 file changed, 4 deletions(-) 21 1 file changed, 4 deletions(-)
22 22
23diff --git a/src/python/CMakeLists.txt b/src/python/CMakeLists.txt
24index fa602397..797e0d14 100644
25--- a/src/python/CMakeLists.txt 23--- a/src/python/CMakeLists.txt
26+++ b/src/python/CMakeLists.txt 24+++ b/src/python/CMakeLists.txt
27@@ -5,10 +5,6 @@ if(NOT PYTHON_CMD) 25@@ -5,10 +5,6 @@ if(NOT PYTHON_CMD)
28 set(PYTHON_CMD "python") 26 set(PYTHON_CMD "python3")
29 endif() 27 endif()
30 28
31-if(EXISTS "/etc/debian_version") 29-if(EXISTS "/etc/debian_version")
@@ -35,6 +33,3 @@ index fa602397..797e0d14 100644
35 file(GLOB_RECURSE PYTHON_SOURCES RELATIVE ${CMAKE_CURRENT_SOURCE_DIR} 33 file(GLOB_RECURSE PYTHON_SOURCES RELATIVE ${CMAKE_CURRENT_SOURCE_DIR}
36 ${CMAKE_CURRENT_SOURCE_DIR}/*.py) 34 ${CMAKE_CURRENT_SOURCE_DIR}/*.py)
37 file(GLOB_RECURSE PYTHON_INCLUDES RELATIVE ${CMAKE_CURRENT_SOURCE_DIR} 35 file(GLOB_RECURSE PYTHON_INCLUDES RELATIVE ${CMAKE_CURRENT_SOURCE_DIR}
38--
392.17.1
40
diff --git a/dynamic-layers/openembedded-layer/recipes-devtools/bcc/bcc/0001-tools-trace.py-Fix-failing-to-exit.patch b/dynamic-layers/openembedded-layer/recipes-devtools/bcc/bcc/0001-tools-trace.py-Fix-failing-to-exit.patch
index e39e21f..6ac7219 100644
--- a/dynamic-layers/openembedded-layer/recipes-devtools/bcc/bcc/0001-tools-trace.py-Fix-failing-to-exit.patch
+++ b/dynamic-layers/openembedded-layer/recipes-devtools/bcc/bcc/0001-tools-trace.py-Fix-failing-to-exit.patch
@@ -28,19 +28,14 @@ Signed-off-by: He Zhe <zhe.he@windriver.com>
28 tools/trace.py | 2 +- 28 tools/trace.py | 2 +-
29 1 file changed, 1 insertion(+), 1 deletion(-) 29 1 file changed, 1 insertion(+), 1 deletion(-)
30 30
31diff --git a/tools/trace.py b/tools/trace.py
32index 7a61594f..d09dd2a8 100755
33--- a/tools/trace.py 31--- a/tools/trace.py
34+++ b/tools/trace.py 32+++ b/tools/trace.py
35@@ -627,7 +627,7 @@ BPF_PERF_OUTPUT(%s); 33@@ -671,7 +671,7 @@ BPF_PERF_OUTPUT(%s);
36 Probe.event_count += 1 34 if self.aggregate:
37 if Probe.max_events is not None and \ 35 self.print_aggregate_events()
38 Probe.event_count >= Probe.max_events: 36 sys.stdout.flush()
39- exit() 37- exit()
40+ os._exit(0) 38+ os._exit(0)
41 sys.stdout.flush()
42 39
43 def attach(self, bpf, verbose): 40 def attach(self, bpf, verbose):
44-- 41 if len(self.library) == 0:
452.17.1
46
diff --git a/dynamic-layers/openembedded-layer/recipes-devtools/bcc/bcc_0.20.0.bb b/dynamic-layers/openembedded-layer/recipes-devtools/bcc/bcc_0.24.0.bb
index d9b476d..65831c3 100644
--- a/dynamic-layers/openembedded-layer/recipes-devtools/bcc/bcc_0.20.0.bb
+++ b/dynamic-layers/openembedded-layer/recipes-devtools/bcc/bcc_0.24.0.bb
@@ -23,10 +23,9 @@ SRC_URI = "gitsm://github.com/iovisor/bcc;branch=master;protocol=https \
23 file://0001-python-CMakeLists.txt-Remove-check-for-host-etc-debi.patch \ 23 file://0001-python-CMakeLists.txt-Remove-check-for-host-etc-debi.patch \
24 file://0001-tools-trace.py-Fix-failing-to-exit.patch \ 24 file://0001-tools-trace.py-Fix-failing-to-exit.patch \
25 file://0001-CMakeLists.txt-override-the-PY_CMD_ESCAPED.patch \ 25 file://0001-CMakeLists.txt-override-the-PY_CMD_ESCAPED.patch \
26 file://0001-Remove-APInt-APSInt-toString-std-string-variants.patch \
27 " 26 "
28 27
29SRCREV = "b2a76fa63f19036fbc9b3a705fbfa6358992ae22" 28SRCREV = "8f40d6f57a8d94e7aee74ce358572d34d31b4ed4"
30 29
31PV .= "+git${SRCPV}" 30PV .= "+git${SRCPV}"
32 31