summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorOvidiu Panait <ovidiu.panait@windriver.com>2020-03-03 21:40:52 +0200
committerKhem Raj <raj.khem@gmail.com>2020-03-04 19:31:09 -0800
commit69291f7a5dfc3747ecd4f9c0d2d3b5915285ee60 (patch)
tree575efc21a9a77fa2d9055746767b51119a7f2e46
parent653bea6d3b478ad50b0c6576d8543cdc11dfc808 (diff)
downloadmeta-clang-69291f7a5dfc3747ecd4f9c0d2d3b5915285ee60.tar.gz
bcc: inherit python3native
Use python3-native rather than the version provided by the build host. Signed-off-by: Ovidiu Panait <ovidiu.panait@windriver.com>
-rw-r--r--recipes-devtools/bcc/bcc/0001-python-CMakeLists.txt-Remove-check-for-host-etc-debi.patch40
-rw-r--r--recipes-devtools/bcc/bcc_0.13.0.bb10
2 files changed, 46 insertions, 4 deletions
diff --git a/recipes-devtools/bcc/bcc/0001-python-CMakeLists.txt-Remove-check-for-host-etc-debi.patch b/recipes-devtools/bcc/bcc/0001-python-CMakeLists.txt-Remove-check-for-host-etc-debi.patch
new file mode 100644
index 0000000..4d71b15
--- /dev/null
+++ b/recipes-devtools/bcc/bcc/0001-python-CMakeLists.txt-Remove-check-for-host-etc-debi.patch
@@ -0,0 +1,40 @@
1From cb3f032b55b32c50201862b26c76ea18ad37cb39 Mon Sep 17 00:00:00 2001
2From: Ovidiu Panait <ovidiu.panait@windriver.com>
3Date: Thu, 30 Jan 2020 14:19:33 +0200
4Subject: [PATCH] python/CMakeLists.txt: Remove check for host
5 /etc/debian_version
6
7Fix the following error that occurs during do_install when using the native
8version of python3:
9usage: setup.py [global_opts] cmd1 [cmd1_opts] [cmd2 [cmd2_opts] ...]
10 or: setup.py --help [cmd1 cmd2 ...]
11 or: setup.py --help-commands
12 or: setup.py cmd --help
13
14error: option --install-layout not recognized
15
16Upstream-status: Innapropriate [oe-specific]
17
18Signed-off-by: Ovidiu Panait <ovidiu.panait@windriver.com>
19---
20 src/python/CMakeLists.txt | 4 ----
21 1 file changed, 4 deletions(-)
22
23diff --git a/src/python/CMakeLists.txt b/src/python/CMakeLists.txt
24index fa602397..797e0d14 100644
25--- a/src/python/CMakeLists.txt
26+++ b/src/python/CMakeLists.txt
27@@ -5,10 +5,6 @@ if(NOT PYTHON_CMD)
28 set(PYTHON_CMD "python")
29 endif()
30
31-if(EXISTS "/etc/debian_version")
32- set(PYTHON_FLAGS "${PYTHON_FLAGS} --install-layout deb")
33-endif()
34-
35 file(GLOB_RECURSE PYTHON_SOURCES RELATIVE ${CMAKE_CURRENT_SOURCE_DIR}
36 ${CMAKE_CURRENT_SOURCE_DIR}/*.py)
37 file(GLOB_RECURSE PYTHON_INCLUDES RELATIVE ${CMAKE_CURRENT_SOURCE_DIR}
38--
392.17.1
40
diff --git a/recipes-devtools/bcc/bcc_0.13.0.bb b/recipes-devtools/bcc/bcc_0.13.0.bb
index c5aeb29..058baa3 100644
--- a/recipes-devtools/bcc/bcc_0.13.0.bb
+++ b/recipes-devtools/bcc/bcc_0.13.0.bb
@@ -3,6 +3,8 @@ HOMEPAGE = "https://github.com/iovisor/bcc"
3LICENSE = "Apache-2.0" 3LICENSE = "Apache-2.0"
4LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=e3fc50a88d0a364313df4b21ef20c29e" 4LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=e3fc50a88d0a364313df4b21ef20c29e"
5 5
6inherit cmake python3native
7
6DEPENDS += "bison-native \ 8DEPENDS += "bison-native \
7 ninja-native \ 9 ninja-native \
8 elfutils-native \ 10 elfutils-native \
@@ -17,20 +19,20 @@ DEPENDS += "bison-native \
17RDEPENDS_${PN} += "bash python3 python3-core" 19RDEPENDS_${PN} += "bash python3 python3-core"
18 20
19SRC_URI = "git://github.com/iovisor/bcc \ 21SRC_URI = "git://github.com/iovisor/bcc \
22 file://0001-python-CMakeLists.txt-Remove-check-for-host-etc-debi.patch \
20 " 23 "
24
21SRCREV = "942227484d3207f6a42103674001ef01fb5335a0" 25SRCREV = "942227484d3207f6a42103674001ef01fb5335a0"
22 26
23S = "${WORKDIR}/git" 27S = "${WORKDIR}/git"
24 28
25inherit cmake
26
27EXTRA_OECMAKE = " \ 29EXTRA_OECMAKE = " \
28 -DCMAKE_INSTALL_PREFIX=/usr \ 30 -DCMAKE_INSTALL_PREFIX=/usr \
29 -DENABLE_LLVM_SHARED=ON \ 31 -DENABLE_LLVM_SHARED=ON \
30 -DENABLE_CLANG_JIT=ON \ 32 -DENABLE_CLANG_JIT=ON \
31 -DENABLE_MAN=OFF \ 33 -DENABLE_MAN=OFF \
32 -DLLVM_PACKAGE_VERSION=${LLVMVERSION} \ 34 -DLLVM_PACKAGE_VERSION=${LLVMVERSION} \
33 -DPYTHON_CMD=python3 \ 35 -DPYTHON_CMD=${PYTHON} \
34" 36"
35 37
36do_install_append() { 38do_install_append() {
@@ -38,6 +40,6 @@ do_install_append() {
38 -i $(find ${D}${datadir}/${PN} -type f) 40 -i $(find ${D}${datadir}/${PN} -type f)
39} 41}
40 42
41FILES_${PN} += "${libdir}/python*/dist-packages" 43FILES_${PN} += "${PYTHON_SITEPACKAGES_DIR}"
42 44
43COMPATIBLE_HOST = "(x86_64.*|aarch64.*|powerpc64.*)-linux" 45COMPATIBLE_HOST = "(x86_64.*|aarch64.*|powerpc64.*)-linux"