summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorOvidiu Panait <ovidiu.panait@windriver.com>2020-03-03 21:19:45 +0200
committerKhem Raj <raj.khem@gmail.com>2020-03-04 19:31:09 -0800
commit653bea6d3b478ad50b0c6576d8543cdc11dfc808 (patch)
tree9b27616aeb61510142403fd7d271fd473e662c58
parent8d8da26055e9f6b61f5a61da7d191c2b54944b33 (diff)
downloadmeta-clang-653bea6d3b478ad50b0c6576d8543cdc11dfc808.tar.gz
bcc: Remove cross-compilation cmake patch
Commit ab686950af8d was integrated to fix this particular issue, so this patch is not needed anymore. Signed-off-by: Ovidiu Panait <ovidiu.panait@windriver.com>
-rw-r--r--recipes-devtools/bcc/bcc/0001-Allow-to-build-with-OE-LLVM-cross-compiled-package.patch33
-rw-r--r--recipes-devtools/bcc/bcc_0.13.0.bb1
2 files changed, 0 insertions, 34 deletions
diff --git a/recipes-devtools/bcc/bcc/0001-Allow-to-build-with-OE-LLVM-cross-compiled-package.patch b/recipes-devtools/bcc/bcc/0001-Allow-to-build-with-OE-LLVM-cross-compiled-package.patch
deleted file mode 100644
index 7b09df6..0000000
--- a/recipes-devtools/bcc/bcc/0001-Allow-to-build-with-OE-LLVM-cross-compiled-package.patch
+++ /dev/null
@@ -1,33 +0,0 @@
1From cb13627f25a7af1b54a395eb59e5d7f7786e609d Mon Sep 17 00:00:00 2001
2From: Sumit Garg <sumit.garg@linaro.org>
3Date: Fri, 14 Feb 2020 07:40:11 +0000
4Subject: [PATCH] Allow to build with OE LLVM cross compiled package
5
6The default LLVM cmake package requires all libraries, headers and tools
7to be present but in case of cross compilation, OE only provides
8target specific libraries and headers and requires native llvm tools.
9
10So instead of looking for a complete llvm package, look for libraries and
11headers which are installed in target sysroot-recipe path.
12
13Signed-off-by: Sumit Garg <sumit.garg@linaro.org>
14---
15 CMakeLists.txt | 2 --
16 1 file changed, 2 deletions(-)
17
18diff --git a/CMakeLists.txt b/CMakeLists.txt
19index f1916b55..f16d84c3 100644
20--- a/CMakeLists.txt
21+++ b/CMakeLists.txt
22@@ -39,8 +39,6 @@ endif()
23 if(NOT PYTHON_ONLY AND ENABLE_CLANG_JIT)
24 find_package(BISON)
25 find_package(FLEX)
26-find_package(LLVM REQUIRED CONFIG)
27-message(STATUS "Found LLVM: ${LLVM_INCLUDE_DIRS} ${LLVM_PACKAGE_VERSION}")
28 find_package(LibElf REQUIRED)
29
30 if(CLANG_DIR)
31--
322.17.1
33
diff --git a/recipes-devtools/bcc/bcc_0.13.0.bb b/recipes-devtools/bcc/bcc_0.13.0.bb
index 6c92b17..c5aeb29 100644
--- a/recipes-devtools/bcc/bcc_0.13.0.bb
+++ b/recipes-devtools/bcc/bcc_0.13.0.bb
@@ -17,7 +17,6 @@ DEPENDS += "bison-native \
17RDEPENDS_${PN} += "bash python3 python3-core" 17RDEPENDS_${PN} += "bash python3 python3-core"
18 18
19SRC_URI = "git://github.com/iovisor/bcc \ 19SRC_URI = "git://github.com/iovisor/bcc \
20 file://0001-Allow-to-build-with-OE-LLVM-cross-compiled-package.patch \
21 " 20 "
22SRCREV = "942227484d3207f6a42103674001ef01fb5335a0" 21SRCREV = "942227484d3207f6a42103674001ef01fb5335a0"
23 22