summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorOla Redell <ola.redell@retotech.se>2017-12-28 14:07:43 +0100
committerOla Redell <ola.redell@retotech.se>2017-12-28 14:07:43 +0100
commit5c476eab0ab43f5ff83215488474fdb6e2a3432c (patch)
tree1051015216f875a255db498a6b6f94ef7b8c8999
parent697eeb3669ea95a3e55fed711d5511e7f6262113 (diff)
downloadmeta-jailhouse-5c476eab0ab43f5ff83215488474fdb6e2a3432c.tar.gz
removed old recipes for jailhouse 0.6 and 0.7
-rw-r--r--recipes-jailhouse/jailhouse/jailhouse-0.6/0002-no-ldflags-in-tools.patch13
-rw-r--r--recipes-jailhouse/jailhouse/jailhouse-0.6/0003-workaround-if-changed-problem-in-tools-makefile.patch18
-rw-r--r--recipes-jailhouse/jailhouse/jailhouse-0.6/0004-no-kbuild-of-tools.patch13
-rw-r--r--recipes-jailhouse/jailhouse/jailhouse-0.7/0004-no-kbuild-of-tools.patch13
-rw-r--r--recipes-jailhouse/jailhouse/jailhouse-0.7/0005-tools-makefile.patch36
-rw-r--r--recipes-jailhouse/jailhouse/jailhouse_0.6.bb11
-rw-r--r--recipes-jailhouse/jailhouse/jailhouse_0.7.bb11
7 files changed, 0 insertions, 115 deletions
diff --git a/recipes-jailhouse/jailhouse/jailhouse-0.6/0002-no-ldflags-in-tools.patch b/recipes-jailhouse/jailhouse/jailhouse-0.6/0002-no-ldflags-in-tools.patch
deleted file mode 100644
index e94f69d..0000000
--- a/recipes-jailhouse/jailhouse/jailhouse-0.6/0002-no-ldflags-in-tools.patch
+++ /dev/null
@@ -1,13 +0,0 @@
1diff --git a/tools/Makefile b/tools/Makefile
2index 4d91e7a..ecc5503 100644
3--- a/tools/Makefile
4+++ b/tools/Makefile
5@@ -19,7 +19,7 @@ LINUXINCLUDE := -I$(src)/../driver
6 KBUILD_CFLAGS := -g -O3 -DLIBEXECDIR=\"$(libexecdir)\" \
7 -Wall -Wextra -Wmissing-declarations -Wmissing-prototypes -Werror \
8 -DJAILHOUSE_VERSION=\"$(shell cat $(src)/../VERSION)\" $(EXTRA_CFLAGS)
9-LDFLAGS :=
10+#LDFLAGS := $(EXTRA_LDLAGS)
11
12 BINARIES := jailhouse
13 HELPERS := \
diff --git a/recipes-jailhouse/jailhouse/jailhouse-0.6/0003-workaround-if-changed-problem-in-tools-makefile.patch b/recipes-jailhouse/jailhouse/jailhouse-0.6/0003-workaround-if-changed-problem-in-tools-makefile.patch
deleted file mode 100644
index 7d02b55..0000000
--- a/recipes-jailhouse/jailhouse/jailhouse-0.6/0003-workaround-if-changed-problem-in-tools-makefile.patch
+++ /dev/null
@@ -1,18 +0,0 @@
1Index: git/tools/Makefile
2===================================================================
3--- git.orig/tools/Makefile
4+++ git/tools/Makefile
5@@ -55,10 +55,11 @@ endef
6 targets += jailhouse.o
7
8 $(obj)/jailhouse: $(obj)/jailhouse.o
9- $(call if_changed,ld)
10+ $(LD) $(LDFLAGS) -o $@ $^
11
12 $(obj)/jailhouse-config-collect: $(src)/jailhouse-config-create $(src)/jailhouse-config-collect.tmpl
13- $(call if_changed,gen_collect)
14+ $< -g $@; \
15+ chmod +x $@
16
17 install-bin: $(BINARIES) $(DESTDIR)$(sbindir)
18 $(INSTALL_PROGRAM) $^
diff --git a/recipes-jailhouse/jailhouse/jailhouse-0.6/0004-no-kbuild-of-tools.patch b/recipes-jailhouse/jailhouse/jailhouse-0.6/0004-no-kbuild-of-tools.patch
deleted file mode 100644
index 4e0f337..0000000
--- a/recipes-jailhouse/jailhouse/jailhouse-0.6/0004-no-kbuild-of-tools.patch
+++ /dev/null
@@ -1,13 +0,0 @@
1Index: git/Kbuild
2===================================================================
3--- git.orig/Kbuild
4+++ git/Kbuild
5@@ -11,7 +11,7 @@
6 # the COPYING file in the top-level directory.
7 #
8
9-subdir-y := driver hypervisor configs inmates tools
10+subdir-y := driver hypervisor configs inmates
11
12 subdir-ccflags-y := -Werror
13
diff --git a/recipes-jailhouse/jailhouse/jailhouse-0.7/0004-no-kbuild-of-tools.patch b/recipes-jailhouse/jailhouse/jailhouse-0.7/0004-no-kbuild-of-tools.patch
deleted file mode 100644
index 30d3b6d..0000000
--- a/recipes-jailhouse/jailhouse/jailhouse-0.7/0004-no-kbuild-of-tools.patch
+++ /dev/null
@@ -1,13 +0,0 @@
1Index: git/Kbuild
2===================================================================
3--- git.orig/Kbuild
4+++ git/Kbuild
5@@ -53,7 +53,7 @@ $(obj)/driver $(obj)/hypervisor: $(GEN_V
6
7 endif
8
9-subdir-y := driver hypervisor configs inmates tools
10+subdir-y := driver hypervisor configs inmates
11
12 subdir-ccflags-y := -Werror
13
diff --git a/recipes-jailhouse/jailhouse/jailhouse-0.7/0005-tools-makefile.patch b/recipes-jailhouse/jailhouse/jailhouse-0.7/0005-tools-makefile.patch
deleted file mode 100644
index ea041a9..0000000
--- a/recipes-jailhouse/jailhouse/jailhouse-0.7/0005-tools-makefile.patch
+++ /dev/null
@@ -1,36 +0,0 @@
1Index: git/tools/Makefile
2===================================================================
3--- git.orig/tools/Makefile
4+++ git/tools/Makefile
5@@ -19,7 +19,7 @@ LINUXINCLUDE := -I$(src)/../driver
6 KBUILD_CFLAGS := -g -O3 -DLIBEXECDIR=\"$(libexecdir)\" \
7 -Wall -Wextra -Wmissing-declarations -Wmissing-prototypes -Werror \
8 -DJAILHOUSE_VERSION=\"$(shell cat $(src)/../VERSION)\" $(EXTRA_CFLAGS)
9-LDFLAGS :=
10+
11 GCOV_PROFILE := n
12
13 BINARIES := jailhouse
14@@ -57,7 +57,7 @@ endef
15 targets += jailhouse.o
16
17 $(obj)/jailhouse: $(obj)/jailhouse.o
18- $(call if_changed,ld)
19+ $(LD) $(LDFLAGS) -o $@ $^
20
21 CFLAGS_jailhouse-gcov-extract.o := -I$(src)/../hypervisor/include \
22 -I$(src)/../hypervisor/arch/$(SRCARCH)/include
23@@ -68,10 +68,11 @@ targets += jailhouse-gcov-extract.o
24 always += jailhouse-gcov-extract
25
26 $(obj)/jailhouse-gcov-extract: $(obj)/jailhouse-gcov-extract.o
27- $(call if_changed,ld)
28+ $(LD) $(LDFLAGS) -o $@ $^
29
30 $(obj)/jailhouse-config-collect: $(src)/jailhouse-config-create $(src)/jailhouse-config-collect.tmpl
31- $(call if_changed,gen_collect)
32+ $< -g $@; \
33+ chmod +x $@
34
35 install-bin: $(BINARIES) $(DESTDIR)$(sbindir)
36 $(INSTALL_PROGRAM) $^
diff --git a/recipes-jailhouse/jailhouse/jailhouse_0.6.bb b/recipes-jailhouse/jailhouse/jailhouse_0.6.bb
deleted file mode 100644
index fe63070..0000000
--- a/recipes-jailhouse/jailhouse/jailhouse_0.6.bb
+++ /dev/null
@@ -1,11 +0,0 @@
1require jailhouse.inc
2
3SRC_URI = "git://github.com/siemens/jailhouse.git;protocol=git \
4 file://0002-no-ldflags-in-tools.patch \
5 file://0003-workaround-if-changed-problem-in-tools-makefile.patch \
6 file://0004-no-kbuild-of-tools.patch \
7 "
8
9SRCREV = "81528e48763c8dfc10851c49968eb3d053d4b85c"
10
11CELLS = ""
diff --git a/recipes-jailhouse/jailhouse/jailhouse_0.7.bb b/recipes-jailhouse/jailhouse/jailhouse_0.7.bb
deleted file mode 100644
index dcc6af5..0000000
--- a/recipes-jailhouse/jailhouse/jailhouse_0.7.bb
+++ /dev/null
@@ -1,11 +0,0 @@
1require jailhouse.inc
2
3SRC_URI = "git://github.com/siemens/jailhouse.git;protocol=git \
4 file://0004-no-kbuild-of-tools.patch \
5 file://0005-tools-makefile.patch \
6 "
7
8SRCREV = "5c13b6409b6088ab717e8af444e11839868302eb"
9
10CELLS = ""
11