summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorOla Redell <ola.redell@retotech.se>2017-12-28 13:38:30 +0100
committerOla Redell <ola.redell@retotech.se>2017-12-28 13:38:30 +0100
commit697eeb3669ea95a3e55fed711d5511e7f6262113 (patch)
tree6b4411622aad1bcb5b4b52d6a03e558694a4ae94
parenta4a0e54936cbd80439fe9d524fbb4653664d8959 (diff)
downloadmeta-jailhouse-697eeb3669ea95a3e55fed711d5511e7f6262113.tar.gz
recipe for jailhouse 0.8 and updated -git recipe
-rw-r--r--recipes-jailhouse/jailhouse/jailhouse-0.8/0004-no-kbuild-of-tools.patch13
-rw-r--r--recipes-jailhouse/jailhouse/jailhouse-0.8/0005-tools-makefile.patch36
-rw-r--r--recipes-jailhouse/jailhouse/jailhouse-git/0004-no-kbuild-of-tools.patch13
-rw-r--r--recipes-jailhouse/jailhouse/jailhouse-git/0005-tools-makefile.patch36
-rw-r--r--recipes-jailhouse/jailhouse/jailhouse.inc16
-rw-r--r--recipes-jailhouse/jailhouse/jailhouse_0.8.bb11
-rw-r--r--recipes-jailhouse/jailhouse/jailhouse_git.bb4
7 files changed, 120 insertions, 9 deletions
diff --git a/recipes-jailhouse/jailhouse/jailhouse-0.8/0004-no-kbuild-of-tools.patch b/recipes-jailhouse/jailhouse/jailhouse-0.8/0004-no-kbuild-of-tools.patch
new file mode 100644
index 0000000..30d3b6d
--- /dev/null
+++ b/recipes-jailhouse/jailhouse/jailhouse-0.8/0004-no-kbuild-of-tools.patch
@@ -0,0 +1,13 @@
1Index: git/Kbuild
2===================================================================
3--- git.orig/Kbuild
4+++ git/Kbuild
5@@ -53,7 +53,7 @@ $(obj)/driver $(obj)/hypervisor: $(GEN_V
6
7 endif
8
9-subdir-y := driver hypervisor configs inmates tools
10+subdir-y := driver hypervisor configs inmates
11
12 subdir-ccflags-y := -Werror
13
diff --git a/recipes-jailhouse/jailhouse/jailhouse-0.8/0005-tools-makefile.patch b/recipes-jailhouse/jailhouse/jailhouse-0.8/0005-tools-makefile.patch
new file mode 100644
index 0000000..ea041a9
--- /dev/null
+++ b/recipes-jailhouse/jailhouse/jailhouse-0.8/0005-tools-makefile.patch
@@ -0,0 +1,36 @@
1Index: git/tools/Makefile
2===================================================================
3--- git.orig/tools/Makefile
4+++ git/tools/Makefile
5@@ -19,7 +19,7 @@ LINUXINCLUDE := -I$(src)/../driver
6 KBUILD_CFLAGS := -g -O3 -DLIBEXECDIR=\"$(libexecdir)\" \
7 -Wall -Wextra -Wmissing-declarations -Wmissing-prototypes -Werror \
8 -DJAILHOUSE_VERSION=\"$(shell cat $(src)/../VERSION)\" $(EXTRA_CFLAGS)
9-LDFLAGS :=
10+
11 GCOV_PROFILE := n
12
13 BINARIES := jailhouse
14@@ -57,7 +57,7 @@ endef
15 targets += jailhouse.o
16
17 $(obj)/jailhouse: $(obj)/jailhouse.o
18- $(call if_changed,ld)
19+ $(LD) $(LDFLAGS) -o $@ $^
20
21 CFLAGS_jailhouse-gcov-extract.o := -I$(src)/../hypervisor/include \
22 -I$(src)/../hypervisor/arch/$(SRCARCH)/include
23@@ -68,10 +68,11 @@ targets += jailhouse-gcov-extract.o
24 always += jailhouse-gcov-extract
25
26 $(obj)/jailhouse-gcov-extract: $(obj)/jailhouse-gcov-extract.o
27- $(call if_changed,ld)
28+ $(LD) $(LDFLAGS) -o $@ $^
29
30 $(obj)/jailhouse-config-collect: $(src)/jailhouse-config-create $(src)/jailhouse-config-collect.tmpl
31- $(call if_changed,gen_collect)
32+ $< -g $@; \
33+ chmod +x $@
34
35 install-bin: $(BINARIES) $(DESTDIR)$(sbindir)
36 $(INSTALL_PROGRAM) $^
diff --git a/recipes-jailhouse/jailhouse/jailhouse-git/0004-no-kbuild-of-tools.patch b/recipes-jailhouse/jailhouse/jailhouse-git/0004-no-kbuild-of-tools.patch
new file mode 100644
index 0000000..30d3b6d
--- /dev/null
+++ b/recipes-jailhouse/jailhouse/jailhouse-git/0004-no-kbuild-of-tools.patch
@@ -0,0 +1,13 @@
1Index: git/Kbuild
2===================================================================
3--- git.orig/Kbuild
4+++ git/Kbuild
5@@ -53,7 +53,7 @@ $(obj)/driver $(obj)/hypervisor: $(GEN_V
6
7 endif
8
9-subdir-y := driver hypervisor configs inmates tools
10+subdir-y := driver hypervisor configs inmates
11
12 subdir-ccflags-y := -Werror
13
diff --git a/recipes-jailhouse/jailhouse/jailhouse-git/0005-tools-makefile.patch b/recipes-jailhouse/jailhouse/jailhouse-git/0005-tools-makefile.patch
new file mode 100644
index 0000000..ea041a9
--- /dev/null
+++ b/recipes-jailhouse/jailhouse/jailhouse-git/0005-tools-makefile.patch
@@ -0,0 +1,36 @@
1Index: git/tools/Makefile
2===================================================================
3--- git.orig/tools/Makefile
4+++ git/tools/Makefile
5@@ -19,7 +19,7 @@ LINUXINCLUDE := -I$(src)/../driver
6 KBUILD_CFLAGS := -g -O3 -DLIBEXECDIR=\"$(libexecdir)\" \
7 -Wall -Wextra -Wmissing-declarations -Wmissing-prototypes -Werror \
8 -DJAILHOUSE_VERSION=\"$(shell cat $(src)/../VERSION)\" $(EXTRA_CFLAGS)
9-LDFLAGS :=
10+
11 GCOV_PROFILE := n
12
13 BINARIES := jailhouse
14@@ -57,7 +57,7 @@ endef
15 targets += jailhouse.o
16
17 $(obj)/jailhouse: $(obj)/jailhouse.o
18- $(call if_changed,ld)
19+ $(LD) $(LDFLAGS) -o $@ $^
20
21 CFLAGS_jailhouse-gcov-extract.o := -I$(src)/../hypervisor/include \
22 -I$(src)/../hypervisor/arch/$(SRCARCH)/include
23@@ -68,10 +68,11 @@ targets += jailhouse-gcov-extract.o
24 always += jailhouse-gcov-extract
25
26 $(obj)/jailhouse-gcov-extract: $(obj)/jailhouse-gcov-extract.o
27- $(call if_changed,ld)
28+ $(LD) $(LDFLAGS) -o $@ $^
29
30 $(obj)/jailhouse-config-collect: $(src)/jailhouse-config-create $(src)/jailhouse-config-collect.tmpl
31- $(call if_changed,gen_collect)
32+ $< -g $@; \
33+ chmod +x $@
34
35 install-bin: $(BINARIES) $(DESTDIR)$(sbindir)
36 $(INSTALL_PROGRAM) $^
diff --git a/recipes-jailhouse/jailhouse/jailhouse.inc b/recipes-jailhouse/jailhouse/jailhouse.inc
index e2d7ed1..e916196 100644
--- a/recipes-jailhouse/jailhouse/jailhouse.inc
+++ b/recipes-jailhouse/jailhouse/jailhouse.inc
@@ -2,12 +2,14 @@ SUMMARY = "Jailhouse"
2HOMEPAGE = "https://github.com/siemens/jailhouse" 2HOMEPAGE = "https://github.com/siemens/jailhouse"
3SECTION = "jailhouse" 3SECTION = "jailhouse"
4LICENSE = "GPL-2.0 & BSD-2-Clause" 4LICENSE = "GPL-2.0 & BSD-2-Clause"
5
5LIC_FILES_CHKSUM = "file://COPYING;md5=9fa7f895f96bde2d47fd5b7d95b6ba4d \ 6LIC_FILES_CHKSUM = "file://COPYING;md5=9fa7f895f96bde2d47fd5b7d95b6ba4d \
6 file://tools/root-cell-config.c.tmpl;beginline=6;endline=33;md5=2825581c1666c44a17955dc574cfbfb3 \ 7 file://tools/root-cell-config.c.tmpl;beginline=6;endline=33;md5=2825581c1666c44a17955dc574cfbfb3 \
7 file://hypervisor/include/jailhouse/hypercall.h;beginline=9;endline=36;md5=2825581c1666c44a17955dc574cfbfb3 \ 8 file://include/jailhouse/hypercall.h;beginline=9;endline=36;md5=2825581c1666c44a17955dc574cfbfb3 \
8 file://hypervisor/include/jailhouse/cell-config.h;beginline=9;endline=36;md5=2825581c1666c44a17955dc574cfbfb3 \ 9 file://include/jailhouse/cell-config.h;beginline=9;endline=36;md5=2825581c1666c44a17955dc574cfbfb3 \
9 file://hypervisor/arch/arm/include/asm/jailhouse_hypercall.h;beginline=9;endline=36;md5=2825581c1666c44a17955dc574cfbfb3 \ 10 file://include/arch/arm/asm/jailhouse_hypercall.h;beginline=9;endline=36;md5=2825581c1666c44a17955dc574cfbfb3 \
10 file://hypervisor/arch/x86/include/asm/jailhouse_hypercall.h;beginline=9;endline=36;md5=2825581c1666c44a17955dc574cfbfb3 \ 11 file://include/arch/arm64/asm/jailhouse_hypercall.h;beginline=9;endline=36;md5=2825581c1666c44a17955dc574cfbfb3 \
12 file://include/arch/x86/asm/jailhouse_hypercall.h;beginline=9;endline=36;md5=2825581c1666c44a17955dc574cfbfb3 \
11 file://driver/jailhouse.h;beginline=9;endline=36;md5=2825581c1666c44a17955dc574cfbfb3" 13 file://driver/jailhouse.h;beginline=9;endline=36;md5=2825581c1666c44a17955dc574cfbfb3"
12 14
13DEPENDS = "virtual/kernel make-native python-mako-native dtc-native python-mako" 15DEPENDS = "virtual/kernel make-native python-mako-native dtc-native python-mako"
@@ -28,7 +30,7 @@ do_configure() {
28 cp "${STAGING_DIR_HOST}/${CELLCONF_DIR}/"*.c ${S}/configs/ 30 cp "${STAGING_DIR_HOST}/${CELLCONF_DIR}/"*.c ${S}/configs/
29 fi 31 fi
30 32
31 cp -av ${JH_CONFIG} ${S}/hypervisor/include/jailhouse/config.h 33 cp -av ${JH_CONFIG} ${S}/include/jailhouse/config.h
32} 34}
33 35
34USER_SPACE_CFLAGS = '${CFLAGS} -DLIBEXECDIR=\\\"${libexecdir}\\\" \ 36USER_SPACE_CFLAGS = '${CFLAGS} -DLIBEXECDIR=\\\"${libexecdir}\\\" \
@@ -40,13 +42,13 @@ TOOLS_SRC_DIR = "${S}/tools"
40TOOLS_OBJ_DIR = "${S}/tools" 42TOOLS_OBJ_DIR = "${S}/tools"
41 43
42do_compile() { 44do_compile() {
43 oe_runmake V=1 \ 45 oe_runmake V=0 \
44 ARCH=${TARGET_ARCH} CROSS_COMPILE=${TARGET_PREFIX} \ 46 ARCH=${TARGET_ARCH} CROSS_COMPILE=${TARGET_PREFIX} \
45 KDIR=${STAGING_KERNEL_BUILDDIR} 47 KDIR=${STAGING_KERNEL_BUILDDIR}
46 48
47 cd ${TOOLS_SRC_DIR} 49 cd ${TOOLS_SRC_DIR}
48 export JAILHOUSE_VERSION=$(cat ../VERSION) 50 export JAILHOUSE_VERSION=$(cat ../VERSION)
49 oe_runmake V=1 \ 51 oe_runmake V=0 \
50 CFLAGS="${USER_SPACE_CFLAGS}" \ 52 CFLAGS="${USER_SPACE_CFLAGS}" \
51 src=${TOOLS_SRC_DIR} obj=${TOOLS_OBJ_DIR} \ 53 src=${TOOLS_SRC_DIR} obj=${TOOLS_OBJ_DIR} \
52 ${TOOLS_OBJ_DIR}/jailhouse-config-collect ${TOOLS_OBJ_DIR}/jailhouse 54 ${TOOLS_OBJ_DIR}/jailhouse-config-collect ${TOOLS_OBJ_DIR}/jailhouse
diff --git a/recipes-jailhouse/jailhouse/jailhouse_0.8.bb b/recipes-jailhouse/jailhouse/jailhouse_0.8.bb
new file mode 100644
index 0000000..4181776
--- /dev/null
+++ b/recipes-jailhouse/jailhouse/jailhouse_0.8.bb
@@ -0,0 +1,11 @@
1require jailhouse.inc
2
3SRC_URI = "git://github.com/siemens/jailhouse.git;protocol=git \
4 file://0004-no-kbuild-of-tools.patch \
5 file://0005-tools-makefile.patch \
6 "
7
8SRCREV = "07341fa315a7fabb38f07cd3c0b3fe880cffaa65"
9
10CELLS = ""
11
diff --git a/recipes-jailhouse/jailhouse/jailhouse_git.bb b/recipes-jailhouse/jailhouse/jailhouse_git.bb
index ec8e1d3..907dc8c 100644
--- a/recipes-jailhouse/jailhouse/jailhouse_git.bb
+++ b/recipes-jailhouse/jailhouse/jailhouse_git.bb
@@ -1,6 +1,6 @@
1require jailhouse.inc 1require jailhouse.inc
2 2
3FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}-0.7:" 3FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}-git:"
4 4
5SRC_URI = "git://github.com/siemens/jailhouse.git;protocol=git \ 5SRC_URI = "git://github.com/siemens/jailhouse.git;protocol=git \
6 file://0004-no-kbuild-of-tools.patch \ 6 file://0004-no-kbuild-of-tools.patch \
@@ -8,7 +8,7 @@ SRC_URI = "git://github.com/siemens/jailhouse.git;protocol=git \
8 " 8 "
9 9
10SRCREV = "${AUTOREV}" 10SRCREV = "${AUTOREV}"
11PV = "0.7-git${SRCPV}" 11PV = "0.8-git${SRCPV}"
12 12
13CELLS = "" 13CELLS = ""
14 14