summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--documentation/poky.ent3
-rw-r--r--documentation/ref-manual/introduction.xml12
-rw-r--r--documentation/yocto-project-qs/yocto-project-qs.xml2
3 files changed, 9 insertions, 8 deletions
diff --git a/documentation/poky.ent b/documentation/poky.ent
index 165b291..62c6503 100644
--- a/documentation/poky.ent
+++ b/documentation/poky.ent
@@ -67,4 +67,5 @@
67<!ENTITY OPENSUSE_HOST_PACKAGES_ESSENTIAL "python gcc gcc-c++ git chrpath make wget python-xml \ 67<!ENTITY OPENSUSE_HOST_PACKAGES_ESSENTIAL "python gcc gcc-c++ git chrpath make wget python-xml \
68 diffstat makeinfo python-curses patch socat"> 68 diffstat makeinfo python-curses patch socat">
69<!ENTITY CENTOS_HOST_PACKAGES_ESSENTIAL "gawk make wget tar bzip2 gzip python unzip perl patch \ 69<!ENTITY CENTOS_HOST_PACKAGES_ESSENTIAL "gawk make wget tar bzip2 gzip python unzip perl patch \
70 diffutils diffstat git cpp gcc gcc-c++ glibc-devel texinfo chrpath socat"> 70 diffutils diffstat git cpp gcc gcc-c++ glibc-devel texinfo chrpath socat \
71 perl-Data-Dumper perl-Text-ParseWords perl-Thread-Queue">
diff --git a/documentation/ref-manual/introduction.xml b/documentation/ref-manual/introduction.xml
index d65ec23..57e4a25 100644
--- a/documentation/ref-manual/introduction.xml
+++ b/documentation/ref-manual/introduction.xml
@@ -284,7 +284,7 @@
284 support or if you are going to use the Eclipse 284 support or if you are going to use the Eclipse
285 IDE: 285 IDE:
286 <literallayout class='monospaced'> 286 <literallayout class='monospaced'>
287 $ sudo dnf install SDL-devel xterm perl-Thread-Queue 287 $ sudo dnf install SDL-devel xterm
288 </literallayout></para></listitem> 288 </literallayout></para></listitem>
289 <listitem><para><emphasis>Documentation:</emphasis> 289 <listitem><para><emphasis>Documentation:</emphasis>
290 Packages needed if you are going to build out the 290 Packages needed if you are going to build out the
@@ -375,33 +375,33 @@
375 Packages needed to build an image for a headless 375 Packages needed to build an image for a headless
376 system: 376 system:
377 <literallayout class='monospaced'> 377 <literallayout class='monospaced'>
378 $ sudo dnf install &CENTOS_HOST_PACKAGES_ESSENTIAL; 378 $ sudo yum install &CENTOS_HOST_PACKAGES_ESSENTIAL;
379 </literallayout></para></listitem> 379 </literallayout></para></listitem>
380 <listitem><para><emphasis>Graphical and Eclipse Plug-In Extras:</emphasis> 380 <listitem><para><emphasis>Graphical and Eclipse Plug-In Extras:</emphasis>
381 Packages recommended if the host system has graphics 381 Packages recommended if the host system has graphics
382 support or if you are going to use the Eclipse 382 support or if you are going to use the Eclipse
383 IDE: 383 IDE:
384 <literallayout class='monospaced'> 384 <literallayout class='monospaced'>
385 $ sudo dnf install SDL-devel xterm 385 $ sudo yum install SDL-devel xterm
386 </literallayout></para></listitem> 386 </literallayout></para></listitem>
387 <listitem><para><emphasis>Documentation:</emphasis> 387 <listitem><para><emphasis>Documentation:</emphasis>
388 Packages needed if you are going to build out the 388 Packages needed if you are going to build out the
389 Yocto Project documentation manuals: 389 Yocto Project documentation manuals:
390 <literallayout class='monospaced'> 390 <literallayout class='monospaced'>
391 $ sudo dnf install make docbook-style-dsssl docbook-style-xsl \ 391 $ sudo yum install make docbook-style-dsssl docbook-style-xsl \
392 docbook-dtds docbook-utils fop libxslt dblatex xmlto xsltproc 392 docbook-dtds docbook-utils fop libxslt dblatex xmlto xsltproc
393 </literallayout></para></listitem> 393 </literallayout></para></listitem>
394 <listitem><para><emphasis>ADT Installer Extras:</emphasis> 394 <listitem><para><emphasis>ADT Installer Extras:</emphasis>
395 Packages needed if you are going to be using the 395 Packages needed if you are going to be using the
396 <ulink url='&YOCTO_DOCS_ADT_URL;#using-the-adt-installer'>Application Development Toolkit (ADT) Installer</ulink>: 396 <ulink url='&YOCTO_DOCS_ADT_URL;#using-the-adt-installer'>Application Development Toolkit (ADT) Installer</ulink>:
397 <literallayout class='monospaced'> 397 <literallayout class='monospaced'>
398 $ sudo dnf install autoconf automake libtool glib2-devel libarchive-devel 398 $ sudo yum install autoconf automake libtool glib2-devel libarchive-devel
399 </literallayout></para></listitem> 399 </literallayout></para></listitem>
400 <listitem><para><emphasis>OpenEmbedded Self-Test (<filename>oe-selftest</filename>):</emphasis> 400 <listitem><para><emphasis>OpenEmbedded Self-Test (<filename>oe-selftest</filename>):</emphasis>
401 Packages needed if you are going to run 401 Packages needed if you are going to run
402 <filename>oe-selftest</filename>: 402 <filename>oe-selftest</filename>:
403 <literallayout class='monospaced'> 403 <literallayout class='monospaced'>
404 $ sudo dnf install GitPython 404 $ sudo yum install GitPython
405 </literallayout> 405 </literallayout>
406 </para></listitem> 406 </para></listitem>
407 </itemizedlist> 407 </itemizedlist>
diff --git a/documentation/yocto-project-qs/yocto-project-qs.xml b/documentation/yocto-project-qs/yocto-project-qs.xml
index c36cccd..5315dfe 100644
--- a/documentation/yocto-project-qs/yocto-project-qs.xml
+++ b/documentation/yocto-project-qs/yocto-project-qs.xml
@@ -318,7 +318,7 @@
318 </para></listitem> 318 </para></listitem>
319 <listitem><para><emphasis>CentOS</emphasis> 319 <listitem><para><emphasis>CentOS</emphasis>
320 <literallayout class='monospaced'> 320 <literallayout class='monospaced'>
321 $ sudo dnf install &CENTOS_HOST_PACKAGES_ESSENTIAL; SDL-devel xterm 321 $ sudo yum install &CENTOS_HOST_PACKAGES_ESSENTIAL; SDL-devel xterm
322 </literallayout> 322 </literallayout>
323 <note> 323 <note>
324 CentOS 6.x users need to ensure that the required 324 CentOS 6.x users need to ensure that the required