summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta/classes/sanity.bbclass7
-rwxr-xr-xscripts/oe-buildenv-internal4
2 files changed, 5 insertions, 6 deletions
diff --git a/meta/classes/sanity.bbclass b/meta/classes/sanity.bbclass
index 0eb6ae3..e692f33 100644
--- a/meta/classes/sanity.bbclass
+++ b/meta/classes/sanity.bbclass
@@ -381,11 +381,10 @@ def check_sanity(sanity_data):
381 381
382 messages = "" 382 messages = ""
383 383
384 # Check the Python version, we now use Python 2.6 features in 384 # Check the Python version, we now have a minimum of Python 2.7.3
385 # various classes
386 import sys 385 import sys
387 if sys.hexversion < 0x020600F0: 386 if sys.hexversion < 0x020703F0:
388 messages = messages + 'The system requires at least Python 2.6 to run. Please update your Python interpreter.\n' 387 messages = messages + 'The system requires at least Python 2.7.3 to run. Please update your Python interpreter.\n'
389 # Check the python install is complete. glib-2.0-natives requries 388 # Check the python install is complete. glib-2.0-natives requries
390 # xml.parsers.expat 389 # xml.parsers.expat
391 try: 390 try:
diff --git a/scripts/oe-buildenv-internal b/scripts/oe-buildenv-internal
index a33698c..40d95b7 100755
--- a/scripts/oe-buildenv-internal
+++ b/scripts/oe-buildenv-internal
@@ -43,9 +43,9 @@ fi
43# Similarly, we now have code that doesn't parse correctly with older 43# Similarly, we now have code that doesn't parse correctly with older
44# versions of Python, and rather than fixing that and being eternally 44# versions of Python, and rather than fixing that and being eternally
45# vigilant for any other new feature use, just check the version here. 45# vigilant for any other new feature use, just check the version here.
46py_v26_check=`python -c 'import sys; print sys.version_info >= (2,6,0)'` 46py_v26_check=`python -c 'import sys; print sys.version_info >= (2,7,3)'`
47if [ "$py_v26_check" != "True" ]; then 47if [ "$py_v26_check" != "True" ]; then
48 echo "BitBake requires Python 2.6 or later" 48 echo "BitBake requires Python 2.7.3 or later"
49 exit 1 49 exit 1
50fi 50fi
51 51