summaryrefslogtreecommitdiffstats
path: root/scripts
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2013-06-17 09:40:15 (GMT)
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-06-17 09:41:01 (GMT)
commit7abcaf14ec9cd760fe94c777f0cd8426163de2c5 (patch)
tree0bcda80579a8fb3de16bf4ecd3b4c7fdbf8ca81d /scripts
parente023620773df82ba1551bec7fb921e4fef01322e (diff)
downloadpoky-7abcaf14ec9cd760fe94c777f0cd8426163de2c5.tar.gz
oe-buildenv-internal: Fix exit verses return
This script is sourced so we should return, not exit. (From OE-Core rev: bde54b4c4f8de696666a8c79c8cb6cf224c246e1) Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'scripts')
-rwxr-xr-xscripts/oe-buildenv-internal4
1 files changed, 2 insertions, 2 deletions
diff --git a/scripts/oe-buildenv-internal b/scripts/oe-buildenv-internal
index 40d95b7..62a410e 100755
--- a/scripts/oe-buildenv-internal
+++ b/scripts/oe-buildenv-internal
@@ -37,7 +37,7 @@ py_v3_check=`/usr/bin/env python --version 2>&1 | grep "Python 3"`
37if [ "$py_v3_check" != "" ]; then 37if [ "$py_v3_check" != "" ]; then
38 echo "Bitbake is not compatible with python v3" 38 echo "Bitbake is not compatible with python v3"
39 echo "Please set up python v2 as your default python interpreter" 39 echo "Please set up python v2 as your default python interpreter"
40 exit 1 40 return 1
41fi 41fi
42 42
43# Similarly, we now have code that doesn't parse correctly with older 43# Similarly, we now have code that doesn't parse correctly with older
@@ -46,7 +46,7 @@ fi
46py_v26_check=`python -c 'import sys; print sys.version_info >= (2,7,3)'` 46py_v26_check=`python -c 'import sys; print sys.version_info >= (2,7,3)'`
47if [ "$py_v26_check" != "True" ]; then 47if [ "$py_v26_check" != "True" ]; then
48 echo "BitBake requires Python 2.7.3 or later" 48 echo "BitBake requires Python 2.7.3 or later"
49 exit 1 49 return 1
50fi 50fi
51 51
52if [ "x$BDIR" = "x" ]; then 52if [ "x$BDIR" = "x" ]; then