summaryrefslogtreecommitdiffstats
path: root/meta
diff options
context:
space:
mode:
authorTim Orling <timothy.t.orling@linux.intel.com>2020-03-31 20:03:03 (GMT)
committerRichard Purdie <richard.purdie@linuxfoundation.org>2020-04-01 10:44:23 (GMT)
commit8c1aeb60c8a682be059c8615152cf1e96f8b1cb5 (patch)
tree354a15930bbc55f60c15b0c9edd5fd43ff418d7c /meta
parent1834a0ce44a154dccaa43b55b51d1a848f087b7e (diff)
downloadpoky-8c1aeb60c8a682be059c8615152cf1e96f8b1cb5.tar.gz
sanity.bbclass: recommend using install-buildtools
For old tar version (< 1.28), recommend using scripts/install-buildtools Drop check for tar version 1.24. Dubious extra value. (From OE-Core rev: 7a66434cf11b7f051699b774e4fccd6738351368) Signed-off-by: Tim Orling <timothy.t.orling@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta')
-rw-r--r--meta/classes/sanity.bbclass4
1 files changed, 1 insertions, 3 deletions
diff --git a/meta/classes/sanity.bbclass b/meta/classes/sanity.bbclass
index cca5cda..fef05fb 100644
--- a/meta/classes/sanity.bbclass
+++ b/meta/classes/sanity.bbclass
@@ -532,10 +532,8 @@ def check_tar_version(sanity_data):
532 except subprocess.CalledProcessError as e: 532 except subprocess.CalledProcessError as e:
533 return "Unable to execute tar --version, exit code %d\n%s\n" % (e.returncode, e.output) 533 return "Unable to execute tar --version, exit code %d\n%s\n" % (e.returncode, e.output)
534 version = result.split()[3] 534 version = result.split()[3]
535 if LooseVersion(version) < LooseVersion("1.24"):
536 return "Your version of tar is older than 1.24 and has bugs which will break builds. Please install a newer version of tar (1.28+).\n"
537 if LooseVersion(version) < LooseVersion("1.28"): 535 if LooseVersion(version) < LooseVersion("1.28"):
538 return "Your version of tar is older than 1.28 and does not have the support needed to enable reproducible builds. Please install a newer version of tar (you could use the projects buildtools-tarball from our last release).\n" 536 return "Your version of tar is older than 1.28 and does not have the support needed to enable reproducible builds. Please install a newer version of tar (you could use the projects buildtools-tarball from our last release or use scripts/install-buildtools).\n"
539 return None 537 return None
540 538
541# We use git parameters and functionality only found in 1.7.8 or later 539# We use git parameters and functionality only found in 1.7.8 or later